互換性のあるオペレーティング システムと Kubernetes のバージョン

このトピックでは、Migrate for Anthos でテスト済みのオペレーティング システムと Kubernetes のバージョンについて説明します。

Migrate for Anthos には、コンテナに移行する VM ワークロードの適合性を判定するツールが用意されています。詳しくは、次をご覧ください。

移行元 VM オペレーティング システム

Linux VM

Migrate for Anthos では、次の表にある 64 ビット Linux オペレーティング システムの VM を Google Kubernetes Engine のコンテナに移行できます。

OS Compute Engine VMware AWS Azure
CentOS 6.0, 7.0, 7.0 UEFI, 8.0 6.7, 6.9, 7.6 6.10, 7.5, 7.6 6.5-7.6, 7.0 LVM
Debian 7.0, 8.0, 9.0, 10.0 9.4, 9.6 6.0, 7.0, 8.0, 9.0, 10.0 8.0, 9.0, 10.0
RHEL 6.0, 7.0, 7.0 UEFI, 7.4 SAP, 7.6 SAP, 8.0 6.5, 7.5, 7.6 5.10, 5.11, 6.5-7.0, 7.1-7.7, 8.0, 8.1 6.7-6.10, 7.2-7.4, 7.5 LVM, 7.5 RAW, 7.6 LVM, 7.6 RAW, 7.4-7.7 SAP, 8.0
SUSE 12, 12 SP1 SAP, 12 SP2 SAP, 12 SP3 SAP, 12 SP4 SAP, 15, 15 SAP, 15 SP1 SAP 12 SP2, 12 SP3, 12 SP4, 15 11 SP4, 11 SP4 SAP, 12 SP1, 12 SP1 SAP, 12 SP2, 12 SP2 SAP, 12 SP3, 12 SP3 SAP, 12 SP4, 12 SP4 SAP, 15 SAP, 15 SP1, 15 SP1 SAP 11 SP4 SAP, 11 SP4, 12 SP1, 12 SP1 SAP, 12 SP2, 12 SP2 SAP, 12 SP3, 12 SP3 SAP, 12 SP4, 12 SP4 SAP, 15, 15 SAP, 15 SP1, 15 SP1 SAP
Ubuntu 12 LTS, 14 LTS, 16 LTS, 16 LTS minimal, 18 LTS, 18 LTS minimal, 18 LTS UEFI, 19.04, 19.04 minimal 12.04.5 LTS, 14.04 LTS, 16.04 LTS, 18.04.10 LTS 12 LTS, 14 LTS, 16 LTS, 18 LTS, 19.04 12.04 LTS, 14.04 LTS, 16.04 LTS, 18.04 LTS, 19 LTS

Windows VM

Migrate for Anthos では、次の表にある Windows オペレーティング システムの VM を Google Kubernetes Engine のコンテナに移行できます。

OS Compute Engine
Windows
  • Microsoft Windows Server 2008R2 以降。
  • Microsoft IIS 7 以降のウェブ アプリケーション。
  • ASP.NET および .NET Framework バージョン 3.5 以降。

移行後のコンテナでは Windows Server バージョン 1909 が実行されます。

クラスタ オペレーティング システムの処理

Linux ワークロード

  • Ubuntu - 完全サポート

  • Container-Optimized OS ノードのクラスタでは、ext2、ext3、ext4 タイプのファイル システムタイプを使用するワークロードを移行できます。

Windows ワークロード

ワークロード クラスタのオペレーティング システム

Linux ワークロード

Windows ワークロード

サポートされている Kubernetes のバージョン

Linux ワークロード

移行する Linux アプリケーションをサポートするには、次のバージョンを使用する必要があります。

  • 1.13.5-gke.10 以降

バージョン 1.13 より前の Kubernetes はサポートされません。

Windows ワークロード

移行する Windows アプリケーションをサポートするには、次のバージョンを使用する必要があります。

  • 1.16 以降