Effectuer une migration à partir du plug-in Google pour Eclipse

Le plug-in Google pour Eclipse (GPE) n'est plus disponible. Ce document explique comment migrer un projet utilisant le plug-in GPE vers Cloud Tools for Eclipse.

Environnement standard App Engine

Cloud Tools for Eclipse permet le développement d'applications pour l'environnement App Engine. Pour migrer votre projet GPE existant vers Cloud Tools for Eclipse, procédez comme suit :

  1. Assurez-vous d'exécuter la version 4.6 d'Eclipse IDE for Java EE Developers.

  2. Installez Cloud Tools for Eclipse. Ce processus désinstalle le plug-in GPE.

  3. Ouvrez l'explorateur de projets dans Eclipse.

  4. Cliquez avec le bouton droit sur le projet à convertir, puis sélectionnez Configure > Convert to App Engine Project (Configurer > Convertir en projet App Engine).

Apps Script

Vous pouvez modifier vos projets Apps Script directement dans votre navigateur Web à l'aide de l'éditeur de scripts Google Drive.

Tous vos projets Apps Script sont déjà disponibles dans Google Drive, sans avoir à procéder à de nouvelles exportations ou conversions.

GWT

Installez le plug-in Eclipse GWT.

Il se peut que des erreurs de génération s'affichent dans vos projets GWT. Pour les résoudre, procédez comme suit :

  1. Sélectionnez le projet dans l'explorateur de projets.

  2. Ouvrez le menu contextuel.

  3. Sélectionnez Configure > Enable GWT SDM builder (Configurer > Activer l'outil de création GWT en mode SuperDevMode).

App Engine et GWT

Le code App Engine s'exécute sur le serveur, et le code GWT sur le client, bien qu'il soit compilé sur serveur et diffusé à partir de ce dernier. Dans l'idéal, ces codes doivent être divisés en projets distincts : un projet Eclipse App Engine et un projet Eclipse GWT.

Une fois que vous avez terminé, vous pouvez suivre la procédure de migration vers l'environnement standard App Engine et la procédure de migration des projets GWT, comme décrit ci-dessus.

Android

Android Studio est l'IDE officiel pour le développement d'applications Android.

Vous pouvez convertir vos projets Eclipse Android existants en projets Android Studio à l'aide de fichiers de version basés sur Gradle en suivant les procédures de migration depuis Eclipse.

Endpoints

GPE était compatible avec Endpoints v1. Vous pouvez être amené à effectuer une mise à niveau vers Endpoints v2. Aucun élément de cette mise à niveau n'est spécifique à l'IDE.

Aucun IDE, Eclipse inclus, n'est actuellement compatible avec Endpoints v2. Vous pouvez utiliser des projets Endpoints v2 dans Eclipse comme vous le feriez avec tout autre projet Java. Cependant, vous ne bénéficiez pas d'outils d'inspection du code, de générateurs de code, d'assistants de création de projet, d'éditeurs ou d'outils de déploiement Endpoints spécifiques.

Si vous souhaitez continuer à utiliser Endpoints v1, vous pouvez également importer votre projet backend dans Eclipse comme vous le feriez avec tout autre projet Java. L'approche la plus simple pour utiliser Endpoints v1 sans le plug-in GPE consiste à se servir du plug-in com.google.appengine:appengine-maven-plugin et de l'intégration du plug-in Eclipse m2e.

Si votre projet n'est pas déjà créé à l'aide de Maven, vous devez ajouter un fichier pom.xml en procédant comme suit :

  1. Si nécessaire, installez le plug-in m2e.

  2. Sélectionnez le projet dans l'explorateur de projets.

  3. Dans le menu contextuel, sélectionnez Configure > Convert to Maven Project (Configurer > Convertir en projet Maven). Cette conversion ajoute un fichier pom.xml au projet et le configure afin qu'il utilise l'outil de création Maven.

  4. Ajoutez les dépendances dependencies suivantes au fichier pom.xml :

    <dependencies>
      <dependency>
        <groupId>com.google.appengine</groupId>
        <artifactId>appengine-endpoints</artifactId>
        <version>1.9.73</version>
      </dependency>
      <dependency>
        <groupId>org.eclipse.persistence</groupId>
        <artifactId>javax.persistence</artifactId>
        <version>2.1.0</version>
      </dependency>
      <dependency>
        <groupId>javax.inject</groupId>
        <artifactId>javax.inject</artifactId>
        <version>1</version>
      </dependency>
      <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>javax.servlet-api</artifactId>
        <version>3.1.0</version>
      </dependency>
      <dependency>
        <groupId>com.google.code.findbugs</groupId>
        <artifactId>jsr305</artifactId>
        <version>3.0.2</version>
      </dependency>
      <dependency>
        <groupId>com.google.appengine.orm</groupId>
        <artifactId>datanucleus-appengine</artifactId>
        <version>2.1.2</version>
      </dependency>
    </dependencies>
    

    Si votre application dépend d'autres bibliothèques, ajoutez également ces dépendances.

  5. Ajoutez le plug-in suivant à la section plugins :

    <plugin>
        <groupId>com.google.cloud.tools</groupId>
        <artifactId>endpoints-framework-maven-plugin</artifactId>
        <version>1.0.0</version>
    </plugin>
    
  6. Une fois votre fichier pom.xml configuré, utilisez l’objectif endpoints-framework:discoveryDocs pour générer des documents de découverte :

    $ mvn endpoints-framework:discoveryDocs
    
  7. Utilisez l'objectif endpoints-framework:clientLibs pour générer des bibliothèques clientes :

    $ mvn endpoints-framework:clientLibs
    

Vous pouvez mapper ces objectifs sur les configurations d'exécution Maven Build (Version Maven) Eclipse pour faciliter l'accès à partir du menu Run (Exécuter).

Configuration des versions Maven Eclipse

DataNucleus (JPA et JDO)

Cloud Tools for Eclipse n'améliore pas automatiquement les classes d'entité.

Pour bénéficier de cette fonctionnalité, vous pouvez utiliser Maven.

Objectify

Les workflows de développement de Cloud Tools for Eclipse permettent d'utiliser Objectify 5.x sans procéder à la moindre modification.

Si vous le souhaitez, vous pouvez procéder à la migration de vos applications vers Objectify 6.0. Cette migration nécessite de mettre à jour le code de votre projet. Le développement local avec Objectify 6.0 nécessite également l'émulateur Cloud Datastore (gcloud beta emulators datastore), qui doit être lancé en dehors d'Eclipse et nécessite une configuration supplémentaire avant le lancement.

Pour en savoir plus, reportez-vous à la documentation relative à Objectify.

Étapes suivantes

Cette page vous a-t-elle été utile ? Évaluez-la :

Envoyer des commentaires concernant…

Cloud Tools for Eclipse
Besoin d'aide ? Consultez notre page d'assistance.