버전 정책

이 페이지에서는 Dataproc Metastore 및 Apache Hive 버전 관리의 작동 방법을 설명합니다. 버전 관리를 사용하면 Dataproc Metastore 서비스에서 관리할 수 있는 유용한 Hive 구성요소를 하나로 묶을 수 있습니다.

Hive 버전 지원

Dataproc Metastore는 다음과 같은 안정적인 Hive 패치 버전을 지원합니다.

  • 3.1.2
  • 2.3.6
  • 2.2.0
  • 1.2.2

Hive 버전 지원 기간

Dataproc Metastore에 Hive 패치 버전이 지원된 후에는 일정 기간 동안 해당 Hive 버전을 사용하는 서비스 지원이 계속됩니다. 지원 기간이 종료된 다음에는 버전이 지원 중단될 수 있습니다. 지원 중단 버전을 실행하는 서비스는 더 이상 지원되지 않습니다. Dataproc Metastore 버전 지원 정책은 다음과 같이 정의됩니다.

초기 Hive 버전 출시 후 개월 수 새 서비스 기존 서비스
0-12 지원됨 지원됨
12-24 지원되지 않음 지원됨
24+ 지원되지 않음 지원되지 않음

Hive 버전 선택

새 서비스를 생성할 때 서비스에 사용할 Hive 메타스토어 버전을 선택할 수 있습니다. 버전을 선택하지 않으면 Dataproc Metastore에서 Hive 버전 3.1.2가 사용됩니다.