Supported Python versions

Cloud Composer 1 | Cloud Composer 2

Cloud Composer 2 supports Python 3.

Cloud Composer 2 environments use Airflow 2. Because Airflow 2 does not support Python 2, Cloud Composer 2 does not support Python 2 as well.

To see the major.minor.patch versions of Python 3 used in a specific Cloud Composer image, see Cloud Composer version list.

What's next