Guia de início rápido sobre o uso do Data Studio

O BigQuery BI Engine permite executar serviços de análise rápidos e de baixa latência e análises interativas com relatórios e painéis baseados no BigQuery.

Este tutorial de apresentação é destinado a analistas de dados e empresas que usam o Google Data Studio para criar relatórios e painéis.

Objetivos

Neste tutorial, você aprenderá a:

  • Crie uma reserva de capacidade do mecanismo de BI usando o Admin Console do BigQuery.
  • Use o Data Studio para conectar-se a uma tabela do BigQuery gerenciada pelo BI Engine.
  • Crie um painel do Data Studio que consulte sua tabela gerenciada pelo BI Engine.

Custos

Neste tutorial, há componentes faturáveis do Google Cloud, a saber:

  • BI Engine: incorrem em custos para a reserva que você cria no BI Engine.
  • BigQuery: incorrem em custos de armazenamento para a tabela que você cria no BigQuery.

Para mais informações sobre preços do BI Engine, consulte a página Preços.

Para mais informações sobre preços de armazenamento do BigQuery, consulte Preços de armazenamento na documentação do BigQuery.

Antes de começar

Antes de começar, verifique se você tem um projeto para usar, se ativou a cobrança para esse projeto e se ativou a API do BigQuery.

  1. Faça login na sua conta do Google Cloud. Se você começou a usar o Google Cloud agora, crie uma conta para avaliar o desempenho de nossos produtos em situações reais. Clientes novos também recebem US$ 300 em créditos para executar, testar e implantar cargas de trabalho.
  2. No Console do Google Cloud, na página do seletor de projetos, selecione ou crie um projeto do Google Cloud.

    Acessar o seletor de projetos

  3. Verifique se o faturamento está ativado para seu projeto na nuvem. Saiba como confirmar se o faturamento está ativado para o projeto.

  4. A API do BigQuery é ativada automaticamente em novos projetos. Para ativar a API do BigQuery em um projeto existente, vá para Ative a API BigQuery.

    Ative a API

Crie um conjunto de dados do BigQuery

A primeira etapa é criar um conjunto de dados do BI Engine para armazenar sua tabela gerenciada pelo BI Engine. Para criar um conjunto de dados, siga estas etapas:

  1. No Console do Cloud, acesse a página do BigQuery.

    Ir para o BigQuery

  2. No painel Navigation, clique no nome do seu projeto.

  3. No painel de detalhes, clique em Criar conjunto de dados.

  4. Na página Criar conjunto de dados, faça o seguinte:

    • Para o código do conjunto de dados, insira biengine_tutorial.
    • Em Local dos dados, selecione Estados Unidos. Os conjuntos de dados públicos são armazenados no local multirregional US. Para simplificar, recomendamos colocar o conjunto de dados no mesmo local.

      Página Criar conjunto de dados

  5. Mantenha todas as outras configurações padrão e clique em Criar conjunto de dados.

Criar uma tabela copiando dados de um conjunto de dados público

Neste tutorial, usamos um conjunto de dados disponível por meio do programa de conjuntos de dados públicos do Google Cloud. Os conjuntos de dados públicos são hospedados no BI Engine para você acessar e integrar a seus aplicativos.

Nesta seção, você cria uma tabela copiando dados do conjunto de dados San Francisco 311 service requests. É possível explorar o conjunto de dados usando o Console do Cloud.

Crie sua tabela

Para criar uma tabela, siga estas etapas:

  1. No Console do Cloud, abra o conjunto de dados SF 311.

    Acessar o conjunto de dados SF 311

  2. No painel de navegação, expanda san_francisco_311 e clique na tabela 311_service_requests.

  3. Clique em Copiar tabela.

  4. Na caixa de diálogo Copiar tabela, na seção Destino, faça o seguinte:

    • Para Nome do projeto, escolha seu projeto.
    • Em Nome do conjunto de dados, verifique se biengine_tutorial está selecionado.
    • Em Nome da tabela, insira 311_service_requests_copy.

      Copie a tabela SF 311

    • Clique em Copiar.

  5. Quando o job de cópia estiver concluído, você poderá verificar o conteúdo da tabela expandindo PROJECT_NAME > biengine_tutorial e clicando em 311_service_requests_copy > Visualização.

Criar sua reserva do BI Engine

  1. No BigQuery Admin Console, acesse a página do BI Engine.

    Acesse o Admin Console do BigQuery

  2. Clique em Criar reserva.

  3. Siga estas etapas na página Criar reserva, para a Etapa 1:

    • Verifique o nome do seu projeto.
    • Selecione seu local. O local deve corresponder ao local dos conjuntos de dados que você está consultando.
    • Ajuste o controle deslizante para a quantidade de capacidade de memória que você está reservando. O exemplo a seguir define a capacidade para 2 GB. O máximo atual é de 100 GB.

      Localização da capacidade do BI Engine

  4. Clique em Next.

  5. Para a Etapa 2, revise os detalhes da sua reserva e clique em Próxima.

  6. Para a Etapa 3, revise o contrato e clique em Criar.

  7. Depois de confirmar sua reserva, os detalhes serão exibidos na página Reservas.

    Reserva confirmada

Criar uma conexão de fonte de dados no Data Studio

Antes de criar um relatório no Google Data Studio, você deve criar uma fonte de dados para o relatório. O relatório pode conter uma ou mais fontes de dados. O Google Data Studio usa o conector do BigQuery para conectar-se a uma tabela do BigQuery gerenciada pelo BI Engine.

Quando você define sua conexão de fonte de dados no Data Studio, o BI Engine usa a tabela e as colunas configuradas para determinar quais dados armazenar em cache. O BI Engine apenas armazena em cache as colunas que você adiciona ao seu relatório.

Permissões exigidas

Para adicionar uma fonte de dados do BigQuery a um relatório do Google Data Studio, é preciso ter as permissões apropriadas. Além disso, as mesmas permissões são aplicáveis aos conjuntos de dados do BigQuery e aos relatórios, gráficos e painéis criados no Google Data Studio. Quando um relatório é compartilhado, os componentes ficam visíveis apenas para os usuários com as permissões adequadas.

A execução de um job de consulta usado para preencher um relatório requer permissões bigquery.jobs.create. Para que o job de consulta seja concluído com êxito, o usuário ou grupo deve ter acesso ao conjunto de dados que contém as tabelas referenciadas pela consulta. O nível mínimo de acesso necessário é "Pode visualizar", que mapeia para o papel bigquery.dataViewer para esse conjunto de dados.

Como você criou o conjunto de dados usado neste tutorial, você recebe acesso de proprietário ao conjunto de dados, o que fornece controle total sobre ele. Além disso, como que você criou o projeto usado neste tutorial, você tem acesso de Proprietário no nível do projeto. O acesso de proprietário permite executar trabalhos no projeto.

Detalhes da permissão

Você pode definir permissões bigquery.jobs.create no nível do projeto, concedendo qualquer um dos seguintes papéis predefinidos do IAM:

  • bigquery.user
  • bigquery.jobUser
  • bigquery.admin

Se você conceder a um usuário ou grupo o papel bigquery.user no nível do projeto, por padrão, nenhum acesso será concedido a nenhum dos conjuntos de dados, tabelas ou visualizações no projeto. bigquery.user oferece aos usuários a capacidade de criar seus próprios conjuntos de dados e executar jobs de consulta em conjuntos de dados a que eles têm acesso. Se você atribuir o papel bigquery.user ou bigquery.jobUser, também precisará atribuir controles de acesso a cada conjunto de dados que o usuário ou grupo precisar acessar. t criado pelo usuário.

Ao atribuir acesso a um conjunto de dados, existem três opções:

O acesso mínimo necessário para um usuário executar uma consulta é "Pode visualizar".

Para mais informações sobre papéis do IAM no BigQuery, consulte Controle de acesso na documentação do BigQuery.

Para mais informações sobre como proteger conjuntos de dados no BigQuery, consulte Como controlar o acesso a um conjunto de dados na documentação do BigQuery.

Criar sua fonte de dados

Para criar sua fonte de dados:

  1. Abra o Google Data Studio.

  2. Na página Relatórios, na seção Iniciar um novo relatório, clique no modelo Em branco. Isso cria um novo relatório sem título.

    Modelo em branco

  3. Se solicitado, defina as configurações de Preferências de marketing e de Conta e privacidade e clique em Salvar. Talvez seja necessário clicar novamente no modelo em branco depois de salvar as configurações.

  4. Na janela Adicione uma fonte de dados, clique em Criar nova fonte de dados.

    Adicionar fonte de dados

  5. Na seção Conectores do Google, passe o cursor sobre BigQuery e clique em Selecionar.

  6. Em Autorização, clique em Autorizar. Isso permite que o Google Data Studio acesse seu projeto do Google Cloud.

  7. Na caixa de diálogo Solicitar permissão, clique em Permitir para que o Google Data Studio visualize dados no BigQuery. Se você tiver usado o Google Data Studio anteriormente, talvez não receba essa solicitação.

  8. Deixe Meus projetos selecionado e, no painel Projeto, clique no nome do seu projeto.

  9. No painel Conjunto de dados, clique em biengine_tutorial.

  10. No painel Tabela, clique em 311_service_requests_copy.

  11. No canto superior direito da janela, clique em Conectar. Depois que o Google Data Studio se conectar à fonte de dados do BigQuery, os campos da tabela serão exibidos. Use essa página para ajustar as propriedades do campo ou criar novos campos calculados.

  12. No canto superior direito, clique em Adicionar ao relatório.

  13. Quando solicitado, clique em Adicionar ao relatório.

  14. Na caixa de diálogo Solicitar permissão, clique em Permitir para que os arquivos do Google Drive possam ser vistos e gerenciados pelo Data Studio. Se você tiver usado o Google Data Studio anteriormente, talvez não receba essa solicitação.

Como criar um gráfico

Depois de adicionar a fonte de dados ao relatório, a próxima etapa é criar uma visualização. Comece criando um gráfico de barras. O gráfico de barras que você cria exibe as principais reclamações por bairro.

Para criar um gráfico de barras que exiba reclamações por bairro:

  1. (Opcional) No topo da página, clique em Relatório sem título para alterar o nome do relatório. Por exemplo, digite BI Engine tutorial.

  2. Depois que o editor do relatório for carregado, clique em Inserir > Gráfico de barras.

  3. Usando as alças, expanda o tamanho do gráfico.

  4. Na guia Dados, observe que o valor da Fonte de dados é 311_service_requests_copy.

  5. Como você está mapeando o número de solicitações por vizinhança, é necessário definir a Dimensão como category e a dimensão Breakdown como neighborhood. Clique na dimensão padrão (provavelmente status) e, na lista, escolha categoria.

    Escolha a dimensão da categoria

  6. NoCampos disponíveis lista, clique e arrastebairro naAdicione a dimensão aqui caixa em Dimensão detalhada ,

    Adicionar a dimensão do bairro

Adicione um filtro

Como os dados incluem diversos valores NULL na coluna neighborhood, você adiciona um filtro que exclui os valores NULL do gráfico.

Para adicionar um filtro:

  1. Na guia Dados, clique em Adicionar um filtro.

    Adicionar uma opção de filtro

  2. Na caixa de diálogo Criar filtro:

    • Em Nome, digite Excluir valores nulos.
    • Verifique se Fonte de dados está definida como 311_service_requests_copy.
    • Clique em Incluir e escolha Excluir.
    • Clique em Selecionar um campo e escolha Vizinhança.
    • Clique em Selecionar uma condição e escolha É nulo.

      Filtro concluído

    • Clique em Save.

  3. Após a aplicação do filtro, seu gráfico deve se parecer com o seguinte.

    Gráfico de barras concluído

Como fazer a limpeza

Para evitar cobranças na sua conta do Google Cloud pelos recursos usados neste guia de início rápido, é possível excluir o projeto, excluir a reserva do BI Engine ou ambas.

Excluir o projeto

O jeito mais fácil de evitar cobranças é excluindo o projeto que você criou para o tutorial.

Para excluir o projeto:

  1. No Console do Cloud, acesse a página Gerenciar recursos:

    Acessar "Gerenciar recursos"

  2. Na lista de projetos, selecione o projeto que você quer excluir e clique em Excluir .
  3. Na caixa de diálogo, digite o ID do projeto e clique em Encerrar para excluí-lo.

Excluir a reserva

Como alternativa, se você pretende manter o projeto, é possível evitar custos adicionais do BI Engine excluindo sua reserva de capacidade.

Para excluir sua reserva, siga estas etapas:

  1. No BigQuery Admin Console, acesse a página do BI Engine.

    Acesse o Admin Console do BigQuery

  2. Na seção Reservas, localize sua reserva.

  3. Na coluna Ações, clique no ícone à direita da sua reserva e escolha Excluir.

  4. Na caixa de diálogo Confirmar remoção de reserva, digite REMOVER e clique em Continuar.

A seguir