GKE Hub V1 API - Class Google::Cloud::GkeHub::V1::ResourceOptions (v0.3.0)

Stay organized with collections Save and categorize content based on your preferences.

Reference documentation and code samples for the GKE Hub V1 API class Google::Cloud::GkeHub::V1::ResourceOptions.

ResourceOptions represent options for Kubernetes resource generation.

Inherits

  • Object

Extended By

  • Google::Protobuf::MessageExts::ClassMethods

Includes

  • Google::Protobuf::MessageExts

Methods

#connect_version

def connect_version() -> ::String
Returns
  • (::String) — Optional. The Connect agent version to use for connect_resources. Defaults to the latest GKE Connect version. The version must be a currently supported version, obsolete versions will be rejected.

#connect_version=

def connect_version=(value) -> ::String
Parameter
  • value (::String) — Optional. The Connect agent version to use for connect_resources. Defaults to the latest GKE Connect version. The version must be a currently supported version, obsolete versions will be rejected.
Returns
  • (::String) — Optional. The Connect agent version to use for connect_resources. Defaults to the latest GKE Connect version. The version must be a currently supported version, obsolete versions will be rejected.

#k8s_version

def k8s_version() -> ::String
Returns
  • (::String) — Optional. Major version of the Kubernetes cluster. This is only used to determine which version to use for the CustomResourceDefinition resources, apiextensions/v1beta1 orapiextensions/v1.

#k8s_version=

def k8s_version=(value) -> ::String
Parameter
  • value (::String) — Optional. Major version of the Kubernetes cluster. This is only used to determine which version to use for the CustomResourceDefinition resources, apiextensions/v1beta1 orapiextensions/v1.
Returns
  • (::String) — Optional. Major version of the Kubernetes cluster. This is only used to determine which version to use for the CustomResourceDefinition resources, apiextensions/v1beta1 orapiextensions/v1.

#v1beta1_crd

def v1beta1_crd() -> ::Boolean
Returns
  • (::Boolean) — Optional. Use apiextensions/v1beta1 instead of apiextensions/v1 for CustomResourceDefinition resources. This option should be set for clusters with Kubernetes apiserver versions <1.16.

#v1beta1_crd=

def v1beta1_crd=(value) -> ::Boolean
Parameter
  • value (::Boolean) — Optional. Use apiextensions/v1beta1 instead of apiextensions/v1 for CustomResourceDefinition resources. This option should be set for clusters with Kubernetes apiserver versions <1.16.
Returns
  • (::Boolean) — Optional. Use apiextensions/v1beta1 instead of apiextensions/v1 for CustomResourceDefinition resources. This option should be set for clusters with Kubernetes apiserver versions <1.16.