Changelog

0.3.3 (2022-01-12)

Dependencies

  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.4.7 (#331) (44a9e93)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.4.8 (#335) (56360ba)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.4.8 (#343) (a191de9)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.7 (#330) (afa5b54)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.8 (#337) (214ba13)

0.3.2 (2021-12-17)

Bug Fixes

Dependencies

  • update dependency com.github.ben-manes.caffeine:caffeine to v2.9.3 (#307) (220aac6)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.0.3 (#238) (949b2c0)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.0.4 (#243) (7645350)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.0.6 (#264) (5e0c6a8)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.1.0 (#269) (df5cece)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.2.0 (#272) (c6ed63f)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.3.0 (#287) (7c370ad)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.4.1 (#300) (4a81ca9)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.4.4 (#316) (c9cbaf9)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.4.5 (#318) (e067f0f)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.4.6 (#323) (f8651bc)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.0.3 (#239) (0713504)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.0.4 (#244) (9ec097d)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.0.6 (#265) (325ba95)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.1.0 (#270) (30d442f)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.2.0 (#273) (5127233)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.3.0 and com.google.cloud:google-cloud-pubsublite-parent to v1.3.0 (#288) (c5e2af7)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.4.0 (#301) (aa4948b)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.4.1 (#309) (8ef3e63)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.4.4 (#312) (68bf001)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.4.5 (#320) (39f9dc3)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.4.6 (#324) (e3a03b9)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.0.3 (#240) (1756bd1)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.0.4 (#245) (95ea402)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.0.6 (#266) (87f135f)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.1.0 (#271) (09503b8)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.2.0 (#274) (d0e3413)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.0 (#302) (836aa5b)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.1 (#310) (de0bdfe)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.4 (#313) (67b4fd8)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.5 (#319) (46dcd42)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.4.6 (#325) (58ea56b)
  • update dependency org.scala-lang.modules:scala-java8-compat_2.11 to v1.0.1 (#283) (c3a05de)
  • update dependency org.scala-lang.modules:scala-java8-compat_2.11 to v1.0.2 (#295) (e659a3e)

0.3.1 (2021-08-11)

Bug Fixes

  • Add shopt -s nullglob to dependencies script (f7e3707)
  • update codeowner team in repo metadata (#195) (63a50bd)
  • Update dependencies.sh to not break on mac (#212) (f7e3707)

Dependencies

  • update dependency com.github.ben-manes.caffeine:caffeine to v2.9.2 (#210) (da04c32)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.16.0 (#199) (3a77dd1)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.16.1 (#203) (0fa77c2)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.17.0 (#217) (349dc13)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.18.0 (#222) (b5f8b5d)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1 (#229) (ba6ee89)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v1.0.2 (#233) (d161f37)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.16.0 (#202) (66e879e)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.16.1 (#204) (bacb9de)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.18.0 (#221) (7d073cd)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1 (#230) (4619d39)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.0.1 (#234) (7fba8b1)
  • update dependency com.google.cloud:google-cloud-pubsublite to v1.0.2 (#236) (4cef3a3)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.16.0 (#201) (5501df3)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.16.1 (#215) (1c1aae9)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.18.0 (#224) (372589a)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1 (#231) (37ad5f8)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v1.0.2 (#235) (8845c1c)
  • update scala-java8 version with parameter (#209) (9a5145d)

0.3.0 (2021-06-10)

Features

  • add gcf-owl-bot[bot] to ignoreAuthors (#180) (ff35157)

Bug Fixes

  • release scripts from issuing overlapping phases (#152) (72e8fdb)

Documentation

Dependencies

  • update dependency com.github.ben-manes.caffeine:caffeine to v2.9.1 (#165) (f1ec795)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.14.1 (#145) (914809d)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.14.2 (#172) (0e2ab3a)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.15.0 (#189) (7d1ac2f)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.13.2 (#146) (f5d49d6)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.14.1 (#163) (1f21f18)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.14.2 (#173) (0277bf6)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.13.2 (#147) (dd6e900)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.14.1 (#164) (bce6d3f)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.14.2 (#174) (b4cae22)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.15.0 (#191) (6206177)
  • update dependency org.apache.spark:spark-sql_2.11 to v2.4.8 (#176) (45997fc)
  • update dependency org.scala-lang.modules:scala-java8-compat_2.11 to v1 (#171) (7d8684b)
  • update spark.version to v2.4.8 (#177) (0eb6a42)
  • update to google-cloud-pubsublite to v0.15.0 (#192) (002191f)

0.2.0 (2021-04-12)

Features

Bug Fixes

  • Move Spark constants into its own class. (#127) (faf1ece)

Documentation

Dependencies

  • renovate bot ignore scala-library and caffeine deps. (#143) (368d7df)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.11.0 (#94) (d9b9289)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.11.1 (#102) (4812cbc)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.12.0 (#118) (880da1b)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.13.1 (#124) (4ef4a04)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.11.0 (#95) (508b90c)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.11.1 (#103) (86c8b7e)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.12.0 (#119) (821449e)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.13.1 (#136) (062b992)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.11.0 (#96) (4356247)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.11.1 (#104) (bb73ca2)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.12.0 (#120) (ea3596f)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.13.1 (#126) (d3130e7)

0.1.0 (2021-02-24)

Features

Bug Fixes

Dependencies

  • update dependency com.github.ben-manes.caffeine:caffeine to v2.9.0 (#79) (caebf8a)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.10.0 (#51) (e8d1b4b)
  • update dependency com.google.api.grpc:proto-google-cloud-pubsublite-v1 to v0.9.0 (#45) (c381c75)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.10.0 (#55) (2bbd9df)
  • update dependency com.google.cloud:google-cloud-pubsublite to v0.10.0 (#81) (110177e)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.10.0 (#52) (aaf4d4a)
  • update dependency com.google.cloud:google-cloud-pubsublite-parent to v0.9.0 (#48) (7da7a0b)

Documentation

  • Add sample common issues. (#88) (5726724)
  • Include mexmessageperbatch in the readme (#63) (eb0742c)
  • update information on connector jar (#68) (c7f5cac)
  • update readme (#76) (5e6476e)
  • update README about and correct distribution name in repo metadata (#16) (f968104)
  • Update readme about jar name. (#73) (7f24f1e)
  • update readme and other minor nits (#77) (ae18de6)
  • update readme partials (#6) (f9cde0a)