Class GetPolicyOptions.Builder

public static final class GetPolicyOptions.Builder extends GeneratedMessageV3.Builder<GetPolicyOptions.Builder> implements GetPolicyOptionsOrBuilder

Encapsulates settings provided to GetIamPolicy.

Protobuf type google.iam.v1.GetPolicyOptions

Static Methods

getDescriptor()

public static final Descriptors.Descriptor getDescriptor()
Returns
TypeDescription
Descriptor

Methods

addRepeatedField(Descriptors.FieldDescriptor field, Object value)

public GetPolicyOptions.Builder addRepeatedField(Descriptors.FieldDescriptor field, Object value)
Parameters
NameDescription
fieldFieldDescriptor
valueObject
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

build()

public GetPolicyOptions build()
Returns
TypeDescription
GetPolicyOptions

buildPartial()

public GetPolicyOptions buildPartial()
Returns
TypeDescription
GetPolicyOptions

clear()

public GetPolicyOptions.Builder clear()
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

clearField(Descriptors.FieldDescriptor field)

public GetPolicyOptions.Builder clearField(Descriptors.FieldDescriptor field)
Parameter
NameDescription
fieldFieldDescriptor
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

clearOneof(Descriptors.OneofDescriptor oneof)

public GetPolicyOptions.Builder clearOneof(Descriptors.OneofDescriptor oneof)
Parameter
NameDescription
oneofOneofDescriptor
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

clearRequestedPolicyVersion()

public GetPolicyOptions.Builder clearRequestedPolicyVersion()

Optional. The maximum policy version that will be used to format the policy. Valid values are 0, 1, and 3. Requests specifying an invalid value will be rejected. Requests for policies with any conditional role bindings must specify version 3. Policies with no conditional role bindings may specify any valid value or leave the field unset. The policy in the response might use the policy version that you specified, or it might use a lower policy version. For example, if you specify version 3, but the policy has no conditional role bindings, the response uses version 1. To learn which resources support conditions in their IAM policies, see the IAM documentation.

int32 requested_policy_version = 1;

Returns
TypeDescription
GetPolicyOptions.Builder

This builder for chaining.

clone()

public GetPolicyOptions.Builder clone()
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

getDefaultInstanceForType()

public GetPolicyOptions getDefaultInstanceForType()
Returns
TypeDescription
GetPolicyOptions

getDescriptorForType()

public Descriptors.Descriptor getDescriptorForType()
Returns
TypeDescription
Descriptor
Overrides

getRequestedPolicyVersion()

public int getRequestedPolicyVersion()

Optional. The maximum policy version that will be used to format the policy. Valid values are 0, 1, and 3. Requests specifying an invalid value will be rejected. Requests for policies with any conditional role bindings must specify version 3. Policies with no conditional role bindings may specify any valid value or leave the field unset. The policy in the response might use the policy version that you specified, or it might use a lower policy version. For example, if you specify version 3, but the policy has no conditional role bindings, the response uses version 1. To learn which resources support conditions in their IAM policies, see the IAM documentation.

int32 requested_policy_version = 1;

Returns
TypeDescription
int

The requestedPolicyVersion.

internalGetFieldAccessorTable()

protected GeneratedMessageV3.FieldAccessorTable internalGetFieldAccessorTable()
Returns
TypeDescription
FieldAccessorTable
Overrides

isInitialized()

public final boolean isInitialized()
Returns
TypeDescription
boolean
Overrides

mergeFrom(GetPolicyOptions other)

public GetPolicyOptions.Builder mergeFrom(GetPolicyOptions other)
Parameter
NameDescription
otherGetPolicyOptions
Returns
TypeDescription
GetPolicyOptions.Builder

mergeFrom(CodedInputStream input, ExtensionRegistryLite extensionRegistry)

public GetPolicyOptions.Builder mergeFrom(CodedInputStream input, ExtensionRegistryLite extensionRegistry)
Parameters
NameDescription
inputCodedInputStream
extensionRegistryExtensionRegistryLite
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides Exceptions
TypeDescription
IOException

mergeFrom(Message other)

public GetPolicyOptions.Builder mergeFrom(Message other)
Parameter
NameDescription
otherMessage
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

mergeUnknownFields(UnknownFieldSet unknownFields)

public final GetPolicyOptions.Builder mergeUnknownFields(UnknownFieldSet unknownFields)
Parameter
NameDescription
unknownFieldsUnknownFieldSet
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

setField(Descriptors.FieldDescriptor field, Object value)

public GetPolicyOptions.Builder setField(Descriptors.FieldDescriptor field, Object value)
Parameters
NameDescription
fieldFieldDescriptor
valueObject
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

setRepeatedField(Descriptors.FieldDescriptor field, int index, Object value)

public GetPolicyOptions.Builder setRepeatedField(Descriptors.FieldDescriptor field, int index, Object value)
Parameters
NameDescription
fieldFieldDescriptor
indexint
valueObject
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides

setRequestedPolicyVersion(int value)

public GetPolicyOptions.Builder setRequestedPolicyVersion(int value)

Optional. The maximum policy version that will be used to format the policy. Valid values are 0, 1, and 3. Requests specifying an invalid value will be rejected. Requests for policies with any conditional role bindings must specify version 3. Policies with no conditional role bindings may specify any valid value or leave the field unset. The policy in the response might use the policy version that you specified, or it might use a lower policy version. For example, if you specify version 3, but the policy has no conditional role bindings, the response uses version 1. To learn which resources support conditions in their IAM policies, see the IAM documentation.

int32 requested_policy_version = 1;

Parameter
NameDescription
valueint

The requestedPolicyVersion to set.

Returns
TypeDescription
GetPolicyOptions.Builder

This builder for chaining.

setUnknownFields(UnknownFieldSet unknownFields)

public final GetPolicyOptions.Builder setUnknownFields(UnknownFieldSet unknownFields)
Parameter
NameDescription
unknownFieldsUnknownFieldSet
Returns
TypeDescription
GetPolicyOptions.Builder
Overrides