Class VulnerabilityNote.Detail.Builder (2.4.5)

Stay organized with collections Save and categorize content based on your preferences.
public static final class VulnerabilityNote.Detail.Builder extends GeneratedMessageV3.Builder<VulnerabilityNote.Detail.Builder> implements VulnerabilityNote.DetailOrBuilder

A detail for a distro and package affected by this vulnerability and its associated fix (if one is available).

Protobuf type grafeas.v1.VulnerabilityNote.Detail

Static Methods

getDescriptor()

public static final Descriptors.Descriptor getDescriptor()
Returns
TypeDescription
Descriptor

Methods

addRepeatedField(Descriptors.FieldDescriptor field, Object value)

public VulnerabilityNote.Detail.Builder addRepeatedField(Descriptors.FieldDescriptor field, Object value)
Parameters
NameDescription
fieldFieldDescriptor
valueObject
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

build()

public VulnerabilityNote.Detail build()
Returns
TypeDescription
VulnerabilityNote.Detail

buildPartial()

public VulnerabilityNote.Detail buildPartial()
Returns
TypeDescription
VulnerabilityNote.Detail

clear()

public VulnerabilityNote.Detail.Builder clear()
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

clearAffectedCpeUri()

public VulnerabilityNote.Detail.Builder clearAffectedCpeUri()

Required. The CPE URI this vulnerability affects.

string affected_cpe_uri = 4;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearAffectedPackage()

public VulnerabilityNote.Detail.Builder clearAffectedPackage()

Required. The package this vulnerability affects.

string affected_package = 5;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearAffectedVersionEnd()

public VulnerabilityNote.Detail.Builder clearAffectedVersionEnd()

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

clearAffectedVersionStart()

public VulnerabilityNote.Detail.Builder clearAffectedVersionStart()

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

clearDescription()

public VulnerabilityNote.Detail.Builder clearDescription()

A vendor-specific description of this vulnerability.

string description = 2;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearField(Descriptors.FieldDescriptor field)

public VulnerabilityNote.Detail.Builder clearField(Descriptors.FieldDescriptor field)
Parameter
NameDescription
fieldFieldDescriptor
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

clearFixedCpeUri()

public VulnerabilityNote.Detail.Builder clearFixedCpeUri()

The distro recommended CPE URI to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_cpe_uri.

string fixed_cpe_uri = 8;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearFixedPackage()

public VulnerabilityNote.Detail.Builder clearFixedPackage()

The distro recommended package to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_package.

string fixed_package = 9;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearFixedVersion()

public VulnerabilityNote.Detail.Builder clearFixedVersion()

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

clearIsObsolete()

public VulnerabilityNote.Detail.Builder clearIsObsolete()

Whether this detail is obsolete. Occurrences are expected not to point to obsolete details.

bool is_obsolete = 11;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearOneof(Descriptors.OneofDescriptor oneof)

public VulnerabilityNote.Detail.Builder clearOneof(Descriptors.OneofDescriptor oneof)
Parameter
NameDescription
oneofOneofDescriptor
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

clearPackageType()

public VulnerabilityNote.Detail.Builder clearPackageType()

The type of package; whether native or non native (e.g., ruby gems, node.js packages, etc.).

string package_type = 3;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearSeverityName()

public VulnerabilityNote.Detail.Builder clearSeverityName()

The distro assigned severity of this vulnerability.

string severity_name = 1;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearSource()

public VulnerabilityNote.Detail.Builder clearSource()

The source from which the information in this Detail was obtained.

string source = 13;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clearSourceUpdateTime()

public VulnerabilityNote.Detail.Builder clearSourceUpdateTime()

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

clearVendor()

public VulnerabilityNote.Detail.Builder clearVendor()

The name of the vendor of the product.

string vendor = 14;

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

clone()

public VulnerabilityNote.Detail.Builder clone()
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

getAffectedCpeUri()

public String getAffectedCpeUri()

Required. The CPE URI this vulnerability affects.

string affected_cpe_uri = 4;

Returns
TypeDescription
String

The affectedCpeUri.

getAffectedCpeUriBytes()

public ByteString getAffectedCpeUriBytes()

Required. The CPE URI this vulnerability affects.

string affected_cpe_uri = 4;

Returns
TypeDescription
ByteString

The bytes for affectedCpeUri.

getAffectedPackage()

public String getAffectedPackage()

Required. The package this vulnerability affects.

string affected_package = 5;

Returns
TypeDescription
String

The affectedPackage.

getAffectedPackageBytes()

public ByteString getAffectedPackageBytes()

Required. The package this vulnerability affects.

string affected_package = 5;

Returns
TypeDescription
ByteString

The bytes for affectedPackage.

getAffectedVersionEnd()

public Version getAffectedVersionEnd()

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Returns
TypeDescription
Version

The affectedVersionEnd.

getAffectedVersionEndBuilder()

public Version.Builder getAffectedVersionEndBuilder()

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Returns
TypeDescription
Version.Builder

getAffectedVersionEndOrBuilder()

public VersionOrBuilder getAffectedVersionEndOrBuilder()

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Returns
TypeDescription
VersionOrBuilder

getAffectedVersionStart()

public Version getAffectedVersionStart()

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Returns
TypeDescription
Version

The affectedVersionStart.

getAffectedVersionStartBuilder()

public Version.Builder getAffectedVersionStartBuilder()

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Returns
TypeDescription
Version.Builder

getAffectedVersionStartOrBuilder()

public VersionOrBuilder getAffectedVersionStartOrBuilder()

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Returns
TypeDescription
VersionOrBuilder

getDefaultInstanceForType()

public VulnerabilityNote.Detail getDefaultInstanceForType()
Returns
TypeDescription
VulnerabilityNote.Detail

getDescription()

public String getDescription()

A vendor-specific description of this vulnerability.

string description = 2;

Returns
TypeDescription
String

The description.

getDescriptionBytes()

public ByteString getDescriptionBytes()

A vendor-specific description of this vulnerability.

string description = 2;

Returns
TypeDescription
ByteString

The bytes for description.

getDescriptorForType()

public Descriptors.Descriptor getDescriptorForType()
Returns
TypeDescription
Descriptor
Overrides

getFixedCpeUri()

public String getFixedCpeUri()

The distro recommended CPE URI to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_cpe_uri.

string fixed_cpe_uri = 8;

Returns
TypeDescription
String

The fixedCpeUri.

getFixedCpeUriBytes()

public ByteString getFixedCpeUriBytes()

The distro recommended CPE URI to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_cpe_uri.

string fixed_cpe_uri = 8;

Returns
TypeDescription
ByteString

The bytes for fixedCpeUri.

getFixedPackage()

public String getFixedPackage()

The distro recommended package to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_package.

string fixed_package = 9;

Returns
TypeDescription
String

The fixedPackage.

getFixedPackageBytes()

public ByteString getFixedPackageBytes()

The distro recommended package to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_package.

string fixed_package = 9;

Returns
TypeDescription
ByteString

The bytes for fixedPackage.

getFixedVersion()

public Version getFixedVersion()

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Returns
TypeDescription
Version

The fixedVersion.

getFixedVersionBuilder()

public Version.Builder getFixedVersionBuilder()

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Returns
TypeDescription
Version.Builder

getFixedVersionOrBuilder()

public VersionOrBuilder getFixedVersionOrBuilder()

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Returns
TypeDescription
VersionOrBuilder

getIsObsolete()

public boolean getIsObsolete()

Whether this detail is obsolete. Occurrences are expected not to point to obsolete details.

bool is_obsolete = 11;

Returns
TypeDescription
boolean

The isObsolete.

getPackageType()

public String getPackageType()

The type of package; whether native or non native (e.g., ruby gems, node.js packages, etc.).

string package_type = 3;

Returns
TypeDescription
String

The packageType.

getPackageTypeBytes()

public ByteString getPackageTypeBytes()

The type of package; whether native or non native (e.g., ruby gems, node.js packages, etc.).

string package_type = 3;

Returns
TypeDescription
ByteString

The bytes for packageType.

getSeverityName()

public String getSeverityName()

The distro assigned severity of this vulnerability.

string severity_name = 1;

Returns
TypeDescription
String

The severityName.

getSeverityNameBytes()

public ByteString getSeverityNameBytes()

The distro assigned severity of this vulnerability.

string severity_name = 1;

Returns
TypeDescription
ByteString

The bytes for severityName.

getSource()

public String getSource()

The source from which the information in this Detail was obtained.

string source = 13;

Returns
TypeDescription
String

The source.

getSourceBytes()

public ByteString getSourceBytes()

The source from which the information in this Detail was obtained.

string source = 13;

Returns
TypeDescription
ByteString

The bytes for source.

getSourceUpdateTime()

public Timestamp getSourceUpdateTime()

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Returns
TypeDescription
Timestamp

The sourceUpdateTime.

getSourceUpdateTimeBuilder()

public Timestamp.Builder getSourceUpdateTimeBuilder()

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Returns
TypeDescription
Builder

getSourceUpdateTimeOrBuilder()

public TimestampOrBuilder getSourceUpdateTimeOrBuilder()

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Returns
TypeDescription
TimestampOrBuilder

getVendor()

public String getVendor()

The name of the vendor of the product.

string vendor = 14;

Returns
TypeDescription
String

The vendor.

getVendorBytes()

public ByteString getVendorBytes()

The name of the vendor of the product.

string vendor = 14;

Returns
TypeDescription
ByteString

The bytes for vendor.

hasAffectedVersionEnd()

public boolean hasAffectedVersionEnd()

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Returns
TypeDescription
boolean

Whether the affectedVersionEnd field is set.

hasAffectedVersionStart()

public boolean hasAffectedVersionStart()

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Returns
TypeDescription
boolean

Whether the affectedVersionStart field is set.

hasFixedVersion()

public boolean hasFixedVersion()

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Returns
TypeDescription
boolean

Whether the fixedVersion field is set.

hasSourceUpdateTime()

public boolean hasSourceUpdateTime()

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Returns
TypeDescription
boolean

Whether the sourceUpdateTime field is set.

internalGetFieldAccessorTable()

protected GeneratedMessageV3.FieldAccessorTable internalGetFieldAccessorTable()
Returns
TypeDescription
FieldAccessorTable
Overrides

isInitialized()

public final boolean isInitialized()
Returns
TypeDescription
boolean
Overrides

mergeAffectedVersionEnd(Version value)

public VulnerabilityNote.Detail.Builder mergeAffectedVersionEnd(Version value)

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Parameter
NameDescription
valueVersion
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

mergeAffectedVersionStart(Version value)

public VulnerabilityNote.Detail.Builder mergeAffectedVersionStart(Version value)

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Parameter
NameDescription
valueVersion
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

mergeFixedVersion(Version value)

public VulnerabilityNote.Detail.Builder mergeFixedVersion(Version value)

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Parameter
NameDescription
valueVersion
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

mergeFrom(CodedInputStream input, ExtensionRegistryLite extensionRegistry)

public VulnerabilityNote.Detail.Builder mergeFrom(CodedInputStream input, ExtensionRegistryLite extensionRegistry)
Parameters
NameDescription
inputCodedInputStream
extensionRegistryExtensionRegistryLite
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides Exceptions
TypeDescription
IOException

mergeFrom(Message other)

public VulnerabilityNote.Detail.Builder mergeFrom(Message other)
Parameter
NameDescription
otherMessage
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

mergeFrom(VulnerabilityNote.Detail other)

public VulnerabilityNote.Detail.Builder mergeFrom(VulnerabilityNote.Detail other)
Parameter
NameDescription
otherVulnerabilityNote.Detail
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

mergeSourceUpdateTime(Timestamp value)

public VulnerabilityNote.Detail.Builder mergeSourceUpdateTime(Timestamp value)

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Parameter
NameDescription
valueTimestamp
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

mergeUnknownFields(UnknownFieldSet unknownFields)

public final VulnerabilityNote.Detail.Builder mergeUnknownFields(UnknownFieldSet unknownFields)
Parameter
NameDescription
unknownFieldsUnknownFieldSet
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

setAffectedCpeUri(String value)

public VulnerabilityNote.Detail.Builder setAffectedCpeUri(String value)

Required. The CPE URI this vulnerability affects.

string affected_cpe_uri = 4;

Parameter
NameDescription
valueString

The affectedCpeUri to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setAffectedCpeUriBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setAffectedCpeUriBytes(ByteString value)

Required. The CPE URI this vulnerability affects.

string affected_cpe_uri = 4;

Parameter
NameDescription
valueByteString

The bytes for affectedCpeUri to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setAffectedPackage(String value)

public VulnerabilityNote.Detail.Builder setAffectedPackage(String value)

Required. The package this vulnerability affects.

string affected_package = 5;

Parameter
NameDescription
valueString

The affectedPackage to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setAffectedPackageBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setAffectedPackageBytes(ByteString value)

Required. The package this vulnerability affects.

string affected_package = 5;

Parameter
NameDescription
valueByteString

The bytes for affectedPackage to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setAffectedVersionEnd(Version value)

public VulnerabilityNote.Detail.Builder setAffectedVersionEnd(Version value)

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Parameter
NameDescription
valueVersion
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setAffectedVersionEnd(Version.Builder builderForValue)

public VulnerabilityNote.Detail.Builder setAffectedVersionEnd(Version.Builder builderForValue)

The version number at the end of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_end = 7;

Parameter
NameDescription
builderForValueVersion.Builder
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setAffectedVersionStart(Version value)

public VulnerabilityNote.Detail.Builder setAffectedVersionStart(Version value)

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Parameter
NameDescription
valueVersion
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setAffectedVersionStart(Version.Builder builderForValue)

public VulnerabilityNote.Detail.Builder setAffectedVersionStart(Version.Builder builderForValue)

The version number at the start of an interval in which this vulnerability exists. A vulnerability can affect a package between version numbers that are disjoint sets of intervals (example: [1.0.0-1.1.0], [2.4.6-2.4.8] and [4.5.6-4.6.8]) each of which will be represented in its own Detail. If a specific affected version is provided by a vulnerability database, affected_version_start and affected_version_end will be the same in that Detail.

.grafeas.v1.Version affected_version_start = 6;

Parameter
NameDescription
builderForValueVersion.Builder
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setDescription(String value)

public VulnerabilityNote.Detail.Builder setDescription(String value)

A vendor-specific description of this vulnerability.

string description = 2;

Parameter
NameDescription
valueString

The description to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setDescriptionBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setDescriptionBytes(ByteString value)

A vendor-specific description of this vulnerability.

string description = 2;

Parameter
NameDescription
valueByteString

The bytes for description to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setField(Descriptors.FieldDescriptor field, Object value)

public VulnerabilityNote.Detail.Builder setField(Descriptors.FieldDescriptor field, Object value)
Parameters
NameDescription
fieldFieldDescriptor
valueObject
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

setFixedCpeUri(String value)

public VulnerabilityNote.Detail.Builder setFixedCpeUri(String value)

The distro recommended CPE URI to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_cpe_uri.

string fixed_cpe_uri = 8;

Parameter
NameDescription
valueString

The fixedCpeUri to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setFixedCpeUriBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setFixedCpeUriBytes(ByteString value)

The distro recommended CPE URI to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_cpe_uri.

string fixed_cpe_uri = 8;

Parameter
NameDescription
valueByteString

The bytes for fixedCpeUri to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setFixedPackage(String value)

public VulnerabilityNote.Detail.Builder setFixedPackage(String value)

The distro recommended package to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_package.

string fixed_package = 9;

Parameter
NameDescription
valueString

The fixedPackage to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setFixedPackageBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setFixedPackageBytes(ByteString value)

The distro recommended package to update to that contains a fix for this vulnerability. It is possible for this to be different from the affected_package.

string fixed_package = 9;

Parameter
NameDescription
valueByteString

The bytes for fixedPackage to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setFixedVersion(Version value)

public VulnerabilityNote.Detail.Builder setFixedVersion(Version value)

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Parameter
NameDescription
valueVersion
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setFixedVersion(Version.Builder builderForValue)

public VulnerabilityNote.Detail.Builder setFixedVersion(Version.Builder builderForValue)

The distro recommended version to update to that contains a fix for this vulnerability. Setting this to VersionKind.MAXIMUM means no such version is yet available.

.grafeas.v1.Version fixed_version = 10;

Parameter
NameDescription
builderForValueVersion.Builder
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setIsObsolete(boolean value)

public VulnerabilityNote.Detail.Builder setIsObsolete(boolean value)

Whether this detail is obsolete. Occurrences are expected not to point to obsolete details.

bool is_obsolete = 11;

Parameter
NameDescription
valueboolean

The isObsolete to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setPackageType(String value)

public VulnerabilityNote.Detail.Builder setPackageType(String value)

The type of package; whether native or non native (e.g., ruby gems, node.js packages, etc.).

string package_type = 3;

Parameter
NameDescription
valueString

The packageType to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setPackageTypeBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setPackageTypeBytes(ByteString value)

The type of package; whether native or non native (e.g., ruby gems, node.js packages, etc.).

string package_type = 3;

Parameter
NameDescription
valueByteString

The bytes for packageType to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setRepeatedField(Descriptors.FieldDescriptor field, int index, Object value)

public VulnerabilityNote.Detail.Builder setRepeatedField(Descriptors.FieldDescriptor field, int index, Object value)
Parameters
NameDescription
fieldFieldDescriptor
indexint
valueObject
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

setSeverityName(String value)

public VulnerabilityNote.Detail.Builder setSeverityName(String value)

The distro assigned severity of this vulnerability.

string severity_name = 1;

Parameter
NameDescription
valueString

The severityName to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setSeverityNameBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setSeverityNameBytes(ByteString value)

The distro assigned severity of this vulnerability.

string severity_name = 1;

Parameter
NameDescription
valueByteString

The bytes for severityName to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setSource(String value)

public VulnerabilityNote.Detail.Builder setSource(String value)

The source from which the information in this Detail was obtained.

string source = 13;

Parameter
NameDescription
valueString

The source to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setSourceBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setSourceBytes(ByteString value)

The source from which the information in this Detail was obtained.

string source = 13;

Parameter
NameDescription
valueByteString

The bytes for source to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setSourceUpdateTime(Timestamp value)

public VulnerabilityNote.Detail.Builder setSourceUpdateTime(Timestamp value)

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Parameter
NameDescription
valueTimestamp
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setSourceUpdateTime(Timestamp.Builder builderForValue)

public VulnerabilityNote.Detail.Builder setSourceUpdateTime(Timestamp.Builder builderForValue)

The time this information was last changed at the source. This is an upstream timestamp from the underlying information source - e.g. Ubuntu security tracker.

.google.protobuf.Timestamp source_update_time = 12;

Parameter
NameDescription
builderForValueBuilder
Returns
TypeDescription
VulnerabilityNote.Detail.Builder

setUnknownFields(UnknownFieldSet unknownFields)

public final VulnerabilityNote.Detail.Builder setUnknownFields(UnknownFieldSet unknownFields)
Parameter
NameDescription
unknownFieldsUnknownFieldSet
Returns
TypeDescription
VulnerabilityNote.Detail.Builder
Overrides

setVendor(String value)

public VulnerabilityNote.Detail.Builder setVendor(String value)

The name of the vendor of the product.

string vendor = 14;

Parameter
NameDescription
valueString

The vendor to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.

setVendorBytes(ByteString value)

public VulnerabilityNote.Detail.Builder setVendorBytes(ByteString value)

The name of the vendor of the product.

string vendor = 14;

Parameter
NameDescription
valueByteString

The bytes for vendor to set.

Returns
TypeDescription
VulnerabilityNote.Detail.Builder

This builder for chaining.