Enum CVSSv3.PrivilegesRequired

public enum CVSSv3.PrivilegesRequired extends Enum<CVSSv3.PrivilegesRequired> implements ProtocolMessageEnum

Protobuf enum grafeas.v1beta1.vulnerability.CVSSv3.PrivilegesRequired

Implements

ProtocolMessageEnum

Fields

NameDescription
PRIVILEGES_REQUIRED_HIGH

PRIVILEGES_REQUIRED_HIGH = 3;

PRIVILEGES_REQUIRED_HIGH_VALUE

PRIVILEGES_REQUIRED_HIGH = 3;

PRIVILEGES_REQUIRED_LOW

PRIVILEGES_REQUIRED_LOW = 2;

PRIVILEGES_REQUIRED_LOW_VALUE

PRIVILEGES_REQUIRED_LOW = 2;

PRIVILEGES_REQUIRED_NONE

PRIVILEGES_REQUIRED_NONE = 1;

PRIVILEGES_REQUIRED_NONE_VALUE

PRIVILEGES_REQUIRED_NONE = 1;

PRIVILEGES_REQUIRED_UNSPECIFIED

PRIVILEGES_REQUIRED_UNSPECIFIED = 0;

PRIVILEGES_REQUIRED_UNSPECIFIED_VALUE

PRIVILEGES_REQUIRED_UNSPECIFIED = 0;

UNRECOGNIZED

Methods

NameDescription
forNumber(int value)
getDescriptor()
getDescriptorForType()
getNumber()
getValueDescriptor()
internalGetValueMap()
valueOf(Descriptors.EnumValueDescriptor desc)
valueOf(int value)

(deprecated) Use #forNumber(int) instead.

valueOf(String name)
values()