Política de versões

Nesta página, mostramos como o metastore do Dataproc e o controle de versão do Apache Hive funcionam. Com o controle de versão, é possível agrupar componentes úteis do Hive que podem ser gerenciados em um serviço do metastore do Dataproc.

Compatibilidade com a versão do Hive

O metastore do Dataproc é compatível com as seguintes versões de patch estáveis do Hive:

  • 3.1.2
  • 2.3.6
  • 2.2.0
  • 1.2.2

Janela de suporte da versão do Hive

Depois que o metastore do Dataproc introduzir suporte para uma versão de patch do Hive, ele continuará a oferecer suporte a serviços que usem essa versão do Hive por um período. Após o fechamento da janela de suporte, a versão poderá ficar obsoleta e os serviços que executam versões obsoletas não serão mais aceitos. A política de suporte da versão do metastore do Dataproc é definida da seguinte maneira:

Meses após a versão inicial do Hive Novos serviços Serviços existentes
0 a 12 Compatível Compatível
12-24 Incompatível Compatível
24+ Incompatível Incompatível

Seleção da versão do Hive

Ao criar um novo serviço, é possível selecionar a versão do metastore do Hive a ser usada no serviço. Se você não selecionar uma versão, o Dataproc Metastore usará o Hive versão 3.1.2.