Se usó la API de Cloud Translation para traducir esta página.
Switch to English

Guía de inicio rápido: Ejecuta una app de Kubernetes con Cloud Code

En esta página, se muestra cómo comenzar a usar Cloud Code.

En esta guía de inicio rápido, configurarás una aplicación de Kubernetes nueva con una plantilla de inicio de Hello World, crearás un clúster, ejecutarás tu app en este clúster, iniciarás una compilación continua para desarrollar tu app de forma iterativa, depurar tu {101 }ejecuta el código, relájate y observa los registros de la transmisión de registros.

Crea una app nueva de Hello World con Cloud Code

Antes de comenzar

Si deseas usar Google Cloud, deberás crear un proyecto de Google Cloud y habilitar la facturación.

Como alternativa, puedes usar un clúster alojado en cualquier otra plataforma en la nube o en un clúster de Kubernetes local con herramientas como minikube y Docker Desktop.

Instala el complemento

Para instalar el complemento de Cloud Code, haz lo siguiente:

  1. Instala el IDE de JetBrains versión 2020.1+ (como IntelliJ Ultimate/Community, PyCharm Professional/Community, WebStorm, GoLand), si todavía no lo hiciste.
  2. Para todas las plataformas en la nube, asegúrate de que el cliente de Docker (autenticado con tu registro de Docker) esté instalado en PATH de tu máquina (su respectiva carpeta debe estar visible). en un directorio dentro de tu PATH). Para comprobar si ya tienes instalado Docker, ejecuta docker -v.

    Cloud Code instala y administra de forma automática las siguientes dependencias en tu IDE: kubectl, Skaffold y SDK de Cloud.

  3. Abre IntelliJ IDEA (o cualquier IDE de JetBrains admitido).

  4. En el mercado de complementos, busca el complemento de Cloud Code y, luego, instálalo.

    Se puede acceder al mercado de complementos a través de los siguientes menús:

    • Windows o Linux: Archivo > Configuración > Complementos
    • macOS: IntelliJ IDEA > Preferencias > Complementos

    Si es necesario, se te solicitará que reinicies el IDE para activar el complemento.

Crea una aplicación

Para crear una aplicación nueva mediante una muestra existente sigue estos pasos:

  1. En tu IDE, abre File (Archivo) New Project (Proyecto nuevo) y selecciona Cloud Code: Kubernetes (Cloud Code: Kubernetes).
  2. Selecciona una plantilla de Hello World de la lista de aplicaciones iniciales. Lista de plantillas disponibles: Python, Go, NodeJS, aplicaciones del libro de visitas de Hello World de Java
  3. Si usas IntelliJ IDEA, se te pedirá que especifiques dónde se almacena tu imagen de contenedor.

    Especifica tu repositorio de imágenes predeterminado en el campo mediante el formato gcr.io/{gcp-project-name} o docker.io/{account}.

    Según el registro de contenedores que elijas, selecciona un formato adecuado:

    • Si usas GKE, puedes almacenar tus imágenes en Google Container Repository.

      Además, el campo incluye el autocompletado, por lo que puedes encontrar fácilmente la imagen asociada con tu proyecto de Google Cloud preferido (y, en este momento, un clúster activo, si existe). Si no tienes un clúster o te gustaría un clúster nuevo para esta guía de inicio rápido, crearás uno en la siguiente sección de esta guía de inicio rápido.

      Usa el siguiente formato:

      gcr.io/{project-name}, donde {project-name} es el nombre de tu proyecto de Google Cloud (que contiene o cuya intención deseas crear el clúster).

    • Si eliges almacenar tus imágenes en Docker Hub (asegúrate de estar autenticado de forma correcta si usas un repositorio privado de Docker Hub), usa el siguiente formato:

      docker.io/{account} en el que {account} es el nombre de tu cuenta de Docker Hub.

    • Si ejecutas en un clúster local como Minikube o Docker Desktop, puedes omitir este paso y hacer clic en Next.

  4. Elige un nombre para el proyecto.

    Una vez que hagas clic en Finish (Finalizar), Cloud Code clonará la plantilla que elegiste y abrirá el proyecto que recién creaste para usarlo.

    • En el caso de las plantillas de Java, se te solicitará que importes proyectos de Maven para sincronizar el pom.xml. Haz clic en Agregar como proyecto de Maven.

      Notificación de pom.xml no administrada

      Además, para importar los proyectos de Maven necesarios, haz clic en Importar cambios.

      Importa las notificaciones de cambios de Maven

Crear un clúster

Si ya tienes un clúster configurado para trabajar con las herramientas de Kubernetes (como kubectl) que puedes usar para esta guía de inicio rápido, puedes continuar con el desarrollo de tu aplicación.

Para desarrollar tu aplicación, necesitarás un clúster de Kubernetes asociado (alojado de forma local con Minikube o con una plataforma de nube, como un clúster de Google Kubernetes Engine). las rutas "a GCP". Si aún no tienes un clúster para usar en esta guía de inicio rápido, crea uno con las instrucciones específicas de Cloud Platform.

Si eliges usar Google Cloud, puedes crear un clúster de GKE mediante la terminal de Cloud Code o Cloud Console:

Usa la terminal de Cloud Code

  1. Con la ventana del proyecto abierta en tu IDE, puedes acceder a la terminal de Cloud Code, ya sea en la barra lateral ubicada en la parte inferior de tu IDE o el menú Tools, Tools > Cloud Code > Herramientas > Terminal de Cloud Code.

  2. Si aún no lo has hecho, configura tu proyecto predeterminado:

    gcloud config set project PROJECT_ID
    
  3. Crea un clúster:

    gcloud container clusters create CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Por ejemplo, para crear un clúster llamado test-cluster, ubicado en la zona us-central1-a, ejecutarás gcloud container clusters create test-cluster --zone=us-central1-a.

    Para obtener más detalles sobre la personalización adicional del clúster, consulta la documentación de referencia del comando.

  4. Después de crear un clúster, ejecute el siguiente comando para agregarlo a su archivo local kubeconfig:

    gcloud container clusters get-credentials CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Así también se establece el clúster especificado en el contexto activo.

Usa Cloud Console

  1. Abre el menú de Google Kubernetes Engine.

    Abrir el menú de Google Kubernetes Engine

  2. Haga clic en Crear.

  3. Selecciona el tipo de clúster preferido (estándar o de piloto automático) y haz clic en Configurar.

  4. Elige tu ubicación y nombre de clúster preferidos.

  5. Haz clic en Crear para terminar de crear tu clúster.

    Para obtener más detalles sobre la personalización de campos, consulta la guía de GKE.

  6. Después de crear un clúster, ejecute el siguiente comando para agregarlo a su archivo local kubeconfig:

    gcloud container clusters get-credentials CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Así también se establece el clúster especificado en el contexto activo.

Desarrolla tu aplicación

Para iniciar el desarrollo de tu aplicación en Kubernetes, sigue estos pasos:

  1. Si ejecutas en un clúster alojado en una plataforma de nube, asegúrate de haber definido en el lugar en que se almacenan tus imágenes de contenedor para Desarrollar en Kubernetes.
  2. Selecciona el destino de ejecución Desarrollar en Kubernetes en el selector de configuración de ejecución y depuración en la barra de navegación.

    Esto garantiza que los cambios de código se compilen, se envíen y se implementen de forma automática en una versión nueva de tu aplicación.

    Configuraciones de ejecución para la implementación en Kubernetes

    Haz clic en la acción de ejecución de Desarrollar en Kubernetes ícono de acción de ejecutar para comenzar el ciclo de desarrollo en tu clúster de Kubernetes.

  3. En la ventana de salida, consulta los registros de aplicaciones entrantes.

    Cuando se inicie la implementación, verás la lista de puertos redireccionados de la aplicación implementada.

    Visualizar registros transmitidos desde la aplicación de Kubernetes

  4. Una vez que la implementación sea exitosa, se te solicitará que notifiques que ahora puedes acceder a tu servicio mediante URL locales. Haz clic en Ver para abrir el Registro de eventos.

    La notificación que indica la URL para acceder a la aplicación publicada ahora está disponible en el registro de eventos.

    En Registro de eventos, haz clic en el vínculo para abrir tu navegador con tu aplicación en ejecución.

    Usa el registro de acontecimientos para buscar servicios con redirección de puertos

Depura tu aplicación

Para depurar tu aplicación, haz lo siguiente:

  1. Si ejecutas en un clúster alojado en una plataforma de nube, asegúrate de haber definido en el lugar en que se almacenan tus imágenes de contenedor para Desarrollar en Kubernetes.
  2. Haz clic en la acción de depuración ícono de acción de ejecutar para Develop on Kubernetes (Desarrollar en Kubernetes) a fin de iniciar el ciclo de desarrollo en modo de depuración en tu clúster de Kubernetes.

    Iniciar el ciclo de desarrollo del clúster de Kubernetes en modo de depuración

  3. Cloud Code adjuntará una sesión de depuración. Una vez que se complete de forma correcta, se abrirá la ventana de la Herramienta de depuración para confirmar la conexión (dentro de la pestaña Console).

    Ahora puedes depurar en tu clúster activo de Kubernetes.

  4. Haz clic en el margen en la línea ejecutable del código en el que deseas agregar una interrupción.

    Los círculos rellenos de color rojo indican las interrupciones activas, mientras que los círculos vacíos con contornos rojos indican las interrupciones inhabilitadas.

  5. Cada vez que envíes una solicitud nueva a tu aplicación, se detendrá en la línea deseada.

    Sesión del depurador de Kubernetes

  6. Si deseas finalizar la sesión de depuración, haz clic en el ícono de detención en la configuración de ejecución Develop on Kubernetes.

Ejecuta tu aplicación

Para ejecutar una aplicación en Kubernetes, sigue estos pasos:

  1. Asegúrate de haber definido la ubicación en la que se almacenarán tus imágenes de contenedor para Run on Kubernetes (Ejecutar en Kubernetes).
  2. Asegúrate de que estés listo para implementar tu app en el contexto de Kubernetes que prefieras.

    Elige Edit Configurations... en el selector de configuración de ejecución y depuración de la barra de navegación. En la pestaña Ejecutar de la configuración de Run en Kubernetes, puedes especificar tu preferencia de implementación.

  3. Ahora que tu aplicación está lista para su implementación, elige Ejecutar en Kubernetes en el selector de configuración de ejecución y depuración en la barra de navegación a fin de implementar la aplicación.

    Configuraciones de ejecución para la implementación en Kubernetes

  4. Haz clic en Run on Kubernetes (Ejecutar en Kubernetes).ícono de acción de ejecutar

  5. Al igual que con el desarrollo en Kubernetes, puedes ver los registros de las aplicaciones entrantes en la ventana de salida.

  6. Una vez que la implementación sea exitosa, se te solicitará que notifiques que ahora puedes acceder a tu servicio mediante URL locales. Haz clic en Ver para abrir el Registro de eventos.

    En el Event log, busca el puerto en el que se entrega tu aplicación. Haz clic en el vínculo para abrir el navegador con la aplicación en ejecución.

  7. Visita http://localhost:{port-number} para acceder a la aplicación nueva recién implementada.

    Aplicación en http://localhost:{port-number} que muestra “Hello World!”

Visualiza registros

Si bien puedes ver una transmisión en vivo de los registros de los pods en ejecución en la salida de la terminal mientras desarrollas y ejecutas la aplicación, también puedes ver los registros de un pod específico si navegas hacia el explorador de Kubernetes.

Para ver los registros de un pod específico, sigue estos pasos:

  1. Navega a Kubernetes Explorer. Se puede acceder desde el panel lateral ubicado a la derecha o mediante Herramientas > Cloud Code > Kubernetes > Ver explorador de clústeres.

    Panel de Kubernetes Explorer abierto mediante la pestaña que se encuentra en la barra de tareas del lado derecho

  2. Selecciona el pod del que deseas ver los registros.

  3. Haz clic con el botón derecho en el pod y selecciona Stream Logs (Transmitir registros). Como alternativa, puedes transmitir registros para contenedores individuales que se ejecutan en pods.

    Esto generará registros en la consola de Kubernetes Explorer.

    Transmite registros desde un pod mediante el menú que aparece cuando se hace clic con el botón derecho para generar registros en la consola de Kubernetes Explorer

Realiza una limpieza

Para evitar que se apliquen cargos en tu cuenta por los recursos que se usan en esta guía de inicio rápido, asegúrate de borrar el clúster y el proyecto que creaste.

Si usas Google Cloud y deseas borrar tu proyecto (y los recursos asociados, que se incluyen los clústeres de GKE), sigue estos pasos:

  • Ve a la página Proyectos en Cloud Console:

    Ir a la página Proyectos

  • Selecciona el proyecto que creaste para este inicio rápido y bórralo. Para ello, debes hacer clic en el ícono de la papelera que se encuentra al lado.

    Con esta acción, se cierra el proyecto y se programa su eliminación.

Qué sigue

Obtén asistencia

Si deseas enviar comentarios, informa un problema en GitHub o haz una pregunta en Stack Overflow.