App Engine 표준 환경에 배포

이 문서는 IntelliJ IDEA 내에서 App Engine 애플리케이션을 App Engine 표준 환경에 배포하는 방법을 설명합니다.

시작하기 전에

  • 앱 만들기 가이드에 따라 Cloud Code를 설치 및 설정하고 표준 환경용 App Engine 앱을 만듭니다. App Engine 표준 프레임워크 지원을 추가해야 합니다.

  • Gradle 기반 프로젝트가 있고 IntelliJ IDEA Community Edition을 사용하는 경우, App Engine Gradle 플러그인을 사용하여 프로젝트를 구성하세요. 프로젝트를 Gradle과 동기화해야 합니다.

    애플리케이션이 없지만 이러한 배포 절차를 시도해 보려면 샘플 앱을 다운로드하세요.

    1. Hello World 샘플 앱을 로컬 머신에 복제합니다.

        git clone https://github.com/GoogleCloudPlatform/java-docs-samples
      
    2. IntelliJ에서 File(파일) > Open(열기)을 선택하여 파일 선택기를 엽니다.

    3. /java-docs-samples/appengine-java8/으로 이동합니다.

    4. /helloworld/ 디렉터리를 선택합니다.

    5. OK(확인)를 클릭합니다.

배포 구성 만들기

  1. Tools(도구) > Cloud Code > App Engine > Deploy to App Engine(App Engine에 배포)을 선택합니다.

    배포 구성 만들기 대화상자의 필드를 보여주는 스크린샷.

  2. 서버 구성을 확인합니다.

    1. Server(서버) 필드 옆의 줄임표(...)를 클릭합니다.

    2. 대화상자에서 Name(이름) 필드에 Google App Engine이 표시되는지 확인합니다.

    3. OK(확인)를 클릭합니다.

  3. Deployment(배포) 소스를 선택합니다.

    Community Edition을 사용하는 경우 Cloud Code는 Maven 또는 Gradle 아티팩트에서의 배포만 지원합니다.

  4. Project(프로젝트) 필드에서 프로젝트를 선택합니다.

    배포를 처음으로 구성하면 배포할 Cloud Console 프로젝트와 연결된 계정에 로그인하라는 메시지가 표시됩니다.

    이전에는 서버 필드가 채워질 때까지 숨겨져 있었지만 이제는 표시되는 프로젝트 선택 필드를 보여주는 스크린샷.

  5. 필요에 따라 다른 필드를 입력하여 배포를 구성합니다.

  6. Run(실행)을 클릭하여 앱을 빌드하고 배포합니다.

  7. Application Servers(애플리케이션 서버) 창에서 프로젝트 이름을 클릭하여 배포 프로세스를 모니터링합니다. 창이 표시되지 않으면 View(보기) > Tool Windows(도구 창) > Application Servers(애플리케이션 서버)를 클릭합니다.

    배포가 완료되면 콘솔 출력에 앱의 URL이 표시됩니다.

App Engine 표준 구성 업데이트

초기 배포 구성을 만든 후에 애플리케이션의 필요에 따라 구성을 변경할 수 있습니다.

  1. File(파일) > Project Structure(프로젝트 구조)를 선택합니다.

    Project Structure 대화상자가 표시됩니다.

  2. Project Settings(프로젝트 설정)에서 Facets(속성)를 선택합니다.

  3. App Engine Standard(표준) 속성을 선택합니다.

    프로젝트 설정(프로젝트, 모듈, 라이브러리, 속성, 아티팩트)가 포함된 왼쪽 탐색 메뉴를 표시하는 대화상자. 플랫폼 설정도 표시합니다. 속성 옵션이 선택되고, 중간 열에 프로젝트와 연결된 속성이 표시됩니다. 오른쪽 열에는 프로젝트에 사용할 수 있는 라이브러리가 표시되고, 어떤 라이브러리가 선택되었는지 표시됩니다.

  4. 프로젝트에 추가할 라이브러리를 선택합니다.

  5. OK(확인)를 클릭합니다.

서버 삭제하기

프로젝트를 위해 구성된 서버를 삭제하려면 다음 안내를 따르세요.

  1. File(파일) > Settings(설정) > Build, Execution, Deployment(빌드, 실행, 배포) > Clouds(클라우드)를 선택합니다.

    macOS에서는 IntelliJ IDEA > Preferences(환경설정) > Build, Execution, Deployment(빌드, 실행, 배포) > Clouds(클라우드)입니다.

  2. 서버(App Engine)를 선택하고 창의 상단에 있는 빼기 기호(-)를 클릭하여 제거합니다.

  3. OK(확인)를 클릭합니다.

다음 단계

지원 받기

의견을 보내려면 GitHub에서 문제를 보고하거나 Stack Overflow에서 질문합니다.