Cómo implementar la aplicación en el entorno estándar de App Engine

En este documento, se describe cómo implementar una aplicación de App Engine en el entorno estándar de App Engine desde IntelliJ IDEA.

Antes de comenzar

  • Sigue la guía de inicio rápido para instalar y configurar IntelliJ IDEA si aún no lo has hecho. Luego, vuelve a este documento.

  • Sigue la guía Crear una app para crear una app de App Engine para el entorno estándar. Asegúrate de agregar compatibilidad con el marco de trabajo estándar de App Engine.

  • Si tienes un proyecto basado en Gradle y usas IntelliJ IDEA Community Edition, configura tu proyecto con el complemento de Gradle de App Engine. Asegúrate de sincronizar tu proyecto con Gradle.

    Si no tienes una aplicación, pero aun así deseas probar estos procedimientos de implementación, descarga la app de muestra:

    1. Clona la app de muestra Hello World en tu máquina local:

        git clone https://github.com/GoogleCloudPlatform/java-docs-samples
      
    2. En IntelliJ, selecciona Archivo > Abrir para abrir el selector de archivos.

    3. Navega a /java-docs-samples/appengine/.

    4. Selecciona el directorio /helloworld/.

    5. Haz clic en Aceptar.

Cómo crear la configuración de implementación

  1. Selecciona Herramientas > Cloud Code > Implementar en App Engine.

    Captura de pantalla que muestra los campos del cuadro de diálogo Crear configuración de implementación

  2. Confirma la configuración del servidor:

    1. Haz clic en la elipsis (…) junto al campo Server (Servidor).

    2. En el cuadro de diálogo, verifica que el campo Name (Nombre) muestre Google App Engine.

    3. Haz clic en OK (Aceptar).

  3. Selecciona la fuente de Deployment (Implementación).

    Si usas la Community Edition, Cloud Code solo admite implementaciones desde un artefacto de Maven o Gradle.

  4. En el campo Project (Proyecto), selecciona uno.

    La primera vez que configures la implementación, se te solicitará acceder a la cuenta asociada con el proyecto de GCP Console que deseas implementar.

    Captura de pantalla que muestra el campo de selección de proyecto que estaba oculto hasta que se llenó el campo Servidor.

  5. Llena los otros campos según sea necesario a fin de configurar la implementación.

  6. Haz clic en Run (Ejecutar) para compilar tu app y, luego, implementarla.

  7. En la ventana Servidores de la aplicación, haz clic en el nombre de tu proyecto para supervisar el progreso de su implementación. Si la ventana no se abre, haz clic en Ver > Ventanas de herramientas > Servidores de la aplicación.

    Cuando la implementación se complete, podrás ver la URL de tu app en el resultado de la consola.

Cómo actualizar la configuración estándar de App Engine

Después de crear la configuración inicial de la implementación, puedes modificarla según las necesidades de tu aplicación.

  1. Selecciona Archivo > Estructura del proyecto.

    Aparecerá el cuadro de diálogo Project Structure (Estructura del proyecto).

  2. En Project Settings (Configuración del proyecto), selecciona Facets (Facetas).

  3. Selecciona la faceta estándar de App Engine.

    Un cuadro de diálogo que muestra un panel de navegación izquierdo con la configuración del proyecto (proyecto, módulo, bibliotecas, facetas, artefactos).También muestra la configuración de la plataforma.La opción Facetas está seleccionada y la columna del centro muestra las que están asociadas al proyecto.En la columna de la derecha, se muestran las bibliotecas disponibles para el proyecto y se indica cuáles se seleccionaron.

  4. Selecciona las bibliotecas que quieres agregar a tu proyecto.

  5. Haz clic en OK (Aceptar).

Cómo borrar el servidor

Si alguna vez deseas borrar el servidor que configuraste para tu proyecto, puedes hacerlo de la siguiente manera:

  1. Selecciona Archivo > Configuración > Compilación, Ejecución, Implementación > Nubes.

    En macOS, la ruta es IntelliJ IDEA > Preferencias > Compilación, Ejecución, Implementación > Nubes.

  2. Selecciona tu servidor (App Engine) y haz clic en el signo menos (-) de la parte superior de la ventana para quitarlo.

  3. Haz clic en Aceptar.

Pasos siguientes

Cómo obtener asistencia

Si deseas enviar comentarios, informa problemas en GitHub o haz preguntas en Stack Overflow.
¿Te ha resultado útil esta página? Enviar comentarios:

Enviar comentarios sobre...

Cloud Code para IntelliJ