Créer une application pour l'environnement flexible App Engine

App Engine est une plate-forme sans serveur entièrement gérée pour le développement et l'hébergement d'applications Web à grande échelle.

Ce document explique comment créer une application (ou importer un projet existant) pour l'environnement flexible App Engine avec Cloud Code.

Avant de commencer

  • Installez et configurez l'IDE JetBrains version 2019.3 ou ultérieure (IntelliJ Ultimate ou Community) sur la variable PATH de votre machine.
  • Installez le plug-in Cloud Code :

    • Ouvrez IntelliJ IDEA (ou tout IDE JetBrains compatible).
    • Depuis votre place de marché de plug-ins (Fichier > Paramètres > Plug-ins ou sous Mac OS X, IntelliJ IDEA >) Preferences > Plugins), accédez au plug-in "Cloud Code" et installez-le.

    Vous serez peut-être invité à redémarrer votre IDE pour activer le plug-in.

Créer une application

Vous pouvez créer une application à l'aide de l'assistant de création de projet ou en important un projet existant dans Cloud Source Repositories.

Utiliser l'assistant de création de projet

Pour créer un projet, vous pouvez utiliser l'assistant de création de projet IntelliJ pour générer un modèle d'application servant de base à votre propre application.

1. Créez un projet comme suit :

  1. Sélectionnez File > New > Project (Fichier > Nouveau > Projet) pour afficher la boîte de dialogue New Project (Nouveau projet).

  2. Dans le panneau de gauche, sélectionnez Java.

  3. Dans la section Autres bibliothèques et frameworks, cochez la case Google App Engine pour votre environnement.

    Nouveau projet Java avec l'option "Google App Engine Flexible" sélectionnée dans la section "Additional Libraries and Framework" (Bibliothèques et frameworks supplémentaires).

  4. Si nécessaire, cochez la case Create app.yaml (Créer un fichier app.yaml).

  5. Cliquez sur Next (Suivant).

  6. Saisissez le nom du projet dans le champ Project name (Nom du projet).

  7. Renseignez le champ Project location (Emplacement du projet) si vous ne souhaitez pas conserver la valeur par défaut.

  8. Modifiez les champs de la section More Settings (Plus de paramètres) si vous ne souhaitez pas conserver les valeurs par défaut.

  9. Cliquez sur Finish (Terminer).

Extraire un projet existant

Vous pouvez extraire un projet existant dans Cloud Source Repositories :

  1. Sélectionnez VCS > Get from Version Control... (Système de contrôle des versions > Obtenir depuis…).

  2. Sélectionnez Google Cloud dans la liste déroulante Contrôle des versions, puis cliquez sur Cloner.
  3. Dans la boîte de dialogue Cloner depuis Google Cloud, sélectionnez le projet Cloud associé à votre projet.
  4. Sélectionnez votre dépôt cloud dans le champ Cloud Repository (Dépôt Cloud).
  5. Sélectionnez le répertoire parent dans le champ Parent Directory (Répertoire parent).
  6. Entrez le nom du répertoire dans le champ Directory Name (Nom du répertoire).
  7. Cliquez sur Clone (Cloner).

Ajouter la compatibilité avec un framework

Si vous n'avez jamais ajouté la compatibilité avec un framework à votre application, IntelliJ IDEA vous invite à configurer le framework après avoir détecté que vous avez ouvert une application App Engine.

  1. Faites un clic droit sur le projet.

  2. Choisissez Add Framework Support (Ajouter la compatibilité avec un framework).

  3. Cochez la case App Engine flexible (Environnement flexible App Engine).

    Vous pouvez également ajouter la compatibilité avec le framework App Engine via le menu Cloud Code :

    1. Sélectionnez Outils > Cloud Code > Ajouter la compatibilité avec App Engine > Environnement flexible Google App Engine.

    2. Sélectionnez le module pour lequel vous souhaitez ajouter la compatibilité avec le framework.

    3. Cliquez sur OK.

  4. Si nécessaire, cochez la case Create app.yaml (Créer un fichier app.yaml).

  5. Cliquez sur OK.

Étape suivante

Maintenant que vous avez créé une application, vous pouvez la déployer sur l'environnement flexible App Engine.

Assistance

Pour envoyer des commentaires ou signaler un problème dans votre IDE IntelliJ, accédez à Tools > Cloud Code > Aide / À propos > Envoyez des commentaires ou signalez un problème pour signaler un problème sur GitHub, ou posez une question sur Stack Overflow.

Vous pouvez également rejoindre la chaîne #cloud-code, qui fait partie de la communauté Slack Google Cloud.