Crea una aplicación nueva a partir de una muestra personalizada

Una vez que hayas configurado tu repositorio de muestra (o uno esté configurado para ti), puedes comenzar a crear aplicaciones con estas muestras.

Como alternativa, puedes importar el repositorio de muestra de Cloud Code si deseas probar la experiencia de muestra personalizada. Para comprender mejor cómo se configuran los repositorios de muestra personalizados, se recomienda que intentes bifurcar el repositorio y modificar su estructura y contenido antes de importarlo. Para ello, crea muestras nuevas dentro del repositorio o modifica el código fuente a fin de crear tus propias versiones de las apps de muestra Hello World o Kubernetes Custom Sample.


Para obtener orientación paso a paso directamente sobre esta tarea directamente en el editor de Cloud Shell, haz clic en Guiarme:

GUIARME


En las siguientes secciones, se explican los mismos pasos que cuando se hace clic en Guiarme.

Crea tu app a partir de una muestra importada

Para crear una aplicación nueva con una de las muestras del repositorio de muestra, sigue estos pasos:

  1. Copia la URL de Git del repositorio de muestra que deseas usar.

  2. Navega a la página de configuración de muestras personalizadas conArchivo >Configuración >Herramientas >Cloud Code >Muestras personalizadas o en Mac OS X:IntelliJ IDEA >Preferencias >Herramientas >Cloud Code >Muestras personalizadas ,

    Página de repositorios de muestra de una aplicación personalizada con una tabla con columnas, la URL del repositorio y la rama

  3. Haz clic en el símbolo Agregar, +, para abrir el diálogo Repositorio de muestras de aplicaciones personalizadas.

  4. Ingresa la URL de Git que copiaste antes en el campo URL de repositorio y haz clic en Siguiente.

    La URL de este ejemplo tiene el formato HTTPS de GitHub: https://github.com/username/repo-name.git.

    URL de Git llena de URL en formato HTTPS: https://github.com/GoogleCloudPlatform/cloud-code-samples.git

  5. Haz clic en Add para autorizar el uso del repositorio en tu IDE, si es necesario, y agregar el repositorio de muestra a tu IDE.

  6. Si la adición de tu repositorio es correcta, deberías ver una marca de verificación verde en la columna Estado de tu tabla de repositorios de muestra. El campo de rama se propaga de forma automática con la rama predeterminada del repositorio. Para editar la rama, selecciona el proyecto y haz clic en el botón Editar de la tabla.

    Si se muestra un ícono de advertencia en la columna Estado, desplázate sobre él para obtener más información sobre por qué tu repositorio no es válido. Luego, puedes actualizar tu repositorio según corresponda y verificar el estado del repositorio en tu IDE. Para ello, haz clic en el botón Actualizar de la tabla.

    Página de repositorios de muestra de la aplicación personalizada con el repositorio recién agregado en la tabla, con una marca de verificación verde junto a él para indicar que la adición se realizó de forma correcta.

  7. Para crear un proyecto nuevo, navega a Archivo > Abrir > Proyecto nuevo.

  8. Selecciona Cloud Code: Personalizado como el tipo de proyecto que quieres crear y elige una muestra de la lista de muestras personalizadas disponibles. Haz clic en Next para continuar.

    Lista de muestras personalizadas disponibles cuando se crea una nueva app de Cloud Code

  9. Elige un nombre y una ubicación para el proyecto de tu nueva app.

    Una vez que hagas clic en Finish (Finalizar), Cloud Code creará tu app con la muestra elegida y la abrirá para usarla.

Obtén asistencia

Para enviar comentarios o informar un problema en tu IDE de IntelliJ, ve a Tools > Cloud Code > Help / About > . Envía comentarios o informa un problema para informar un error en GitHub o hacer una pregunta en Stack Overflow.

También puedes unirte al canal #cloud-code, que forma parte de la comunidad de Slack de Google Cloud.