Python 2 is no longer supported by the community. We recommend that you migrate Python 2 apps to Python 3.

Migrating to Cloud SDK

The standalone App Engine SDK was deprecated as of July 30, 2019, and it is now shut down. The following table lists features and their recommended alternatives:

Deprecated Recommended action
standalone App Engine SDK Download Cloud SDK
Access App Engine legacy APIs using the App Engine SDK Migrate to an unbundled Google Cloud or third-party service, or access bundled services using the App Engine services SDK if you are using a second-generation runtime
appcfg commands Migrate from AppCfg to gcloud command line

Migration timetable

July 30, 2019: The standalone App Engine SDK-based tooling is deprecated.

August 30, 2020: The standalone App Engine SDK is not available for download and might not work, if used.

August 30, 2020: Google shut down and removed support for the standalone App Engine SDK.

Backward non-compatible features

As a result of the shutdown of the appcfg tool and the standalone App Engine SDK, the following features are currently not supported in Cloud SDK: