Plates-formes compatibles

Restez organisé à l'aide des collections Enregistrez et classez les contenus selon vos préférences.

Cette page décrit les environnements compatibles avec Anthos Service Mesh intégré en cluster. Pour obtenir la liste des environnements compatibles avec Anthos Service Mesh géré, consultez la page Environnements Anthos Service Mesh gérés.

Anthos Service Mesh 1.13.x

Seuls les environnements suivants sont compatibles avec la version 1.13.x d'Anthos Service Mesh intégré en cluster. Les autres environnements ne sont pas acceptés.

Plate-forme Version
GKE sur Google Cloud Nous vous recommandons d'enregistrer des clusters GKE sur Google Cloud dans une version disponible. Lors de l'inscription, utilisez la version disponible standard, car d'autres canaux peuvent être basés sur une version de GKE non compatible. Anthos Service Mesh 1.13 est compatible avec les versions suivantes de GKE : 1.21 et 1.22.

Pour plus d'informations sur les versions de GKE incluses dans chaque version disponible, consultez les pages suivantes :

Le cluster GKE doit être de type standard. Le cluster GKE Autopilot n'est pas compatible avec le plan de contrôle au sein du cluster. Pour utiliser GKE Autopilot, vous devez choisir l'option Anthos Service Mesh géré.

Clusters Anthos sur VMware 1.11 Kubernetes 1.22
Anthos sur solution Bare Metal 1.11 Kubernetes 1.21
Clusters Anthos sur AWS de la génération actuelle et précédente (1.10) Kubernetes 1.22
Clusters associés à Anthos Amazon EKS et Microsoft AKS sur Kubernetes 1.21 sont compatibles avec Anthos Service Mesh 1.13. Pour en savoir plus sur l'installation d'Anthos Service Mesh sur EKS ou AKS, consultez la page À propos de asmcli.

Anthos Service Mesh 1.12.x

Seuls les environnements suivants sont compatibles avec la version 1.12.x d'Anthos Service Mesh intégré en cluster. Les autres environnements ne sont pas acceptés.

Plate-forme Version
GKE sur Google Cloud Nous vous recommandons d'enregistrer des clusters GKE sur Google Cloud dans une version disponible. Lors de l'inscription, utilisez la version disponible standard, car d'autres canaux peuvent être basés sur une version de GKE non compatible. Anthos Service Mesh 1.12 est compatible avec les versions suivantes de GKE : 1.20-1.22.

Pour plus d'informations sur les versions de GKE incluses dans chaque version disponible, consultez les pages suivantes :

Le cluster GKE doit être de type standard. Le cluster GKE Autopilot n'est pas compatible avec le plan de contrôle au sein du cluster. Pour utiliser GKE Autopilot, vous devez choisir l'option Anthos Service Mesh géré.

Anthos clusters on VMware 1.10 Kubernetes 1.21
Anthos sur solution Bare Metal 1.10 Kubernetes 1.21
Clusters Anthos sur AWS de la génération actuelle et précédente (1.10) Kubernetes 1.21
Clusters associés à Anthos Amazon EKS sur Kubernetes 1.21 et Microsoft AKS sur Kubernetes 1.21 sont compatibles avec Anthos Service Mesh 1.12. Pour en savoir plus sur l'installation d'Anthos Service Mesh sur EKS ou AKS, consultez la page À propos de asmcli.

Anthos Service Mesh 1.11.x

Seuls les environnements suivants sont compatibles avec la version 1.11.x d'Anthos Service Mesh intégré en cluster. Les autres environnements ne sont pas acceptés.

Plate-forme Version
GKE sur Google Cloud Nous vous recommandons d'enregistrer des clusters GKE sur Google Cloud dans une version disponible. Lors de l'inscription, utilisez la version disponible standard, car d'autres canaux peuvent être basés sur une version de GKE non compatible. Anthos Service Mesh 1.11 est compatible avec les versions suivantes de GKE : 1.20.

Pour plus d'informations sur les versions de GKE incluses dans chaque version disponible, consultez les pages suivantes :

Le cluster GKE doit être de type standard. Le cluster GKE Autopilot n'est pas compatible avec le plan de contrôle au sein du cluster. Pour utiliser GKE Autopilot, vous devez choisir l'option Anthos Service Mesh géré.

Anthos clusters on VMware 1.9 Kubernetes 1.21
Anthos on Bare Metal 1.9 Kubernetes 1.21
Clusters Anthos sur les versions actuelles et précédentes d'AWS (1.9) Kubernetes 1.21
Clusters associés à Anthos Amazon EKS sur Kubernetes 1.21 est compatible avec Anthos Service Mesh 1.11. Pour en savoir plus sur l'installation d'Anthos Service Mesh sur EKS, consultez la page À propos de asmcli. Microsoft AKS n'est compatible qu'avec Anthos Service Mesh 1.7 avec Kubernetes 1.17. Pour en savoir plus, consultez l'article Installer Anthos Service Mesh 1.7 sur les clusters associés à Anthos.