Mettre à niveau la version de Redis d'une instance

Cette page décrit comment mettre à niveau la version Redis d'une instance Memorystore pour Redis. Pour obtenir la liste des versions disponibles, consultez la page Versions compatibles. Pour en savoir plus sur le comportement de l'instance lors d'une opération de mise à niveau, consultez la page Comportement de la mise à niveau des versions.

Bonnes pratiques pour mettre à niveau la version Redis d'une instance

  • Nous vous recommandons d'exporter les données de votre instance avant d'exécuter une opération de mise à niveau de version.

  • Notez que la mise à niveau d'une instance est irréversible. Vous ne pouvez pas revenir à la version antérieure de Redis d'une instance Memorystore pour Redis.

  • Mettez à jour les instances de niveau standard pendant les périodes de faible trafic afin d'augmenter la vitesse et la fiabilité de votre opération de mise à niveau. Pour savoir comment surveiller le trafic des instances, consultez la page Surveiller des instances Redis.

Mettre à niveau la version de l'instance

Console

  1. Accédez à la page "Memorystore pour Redis" dans Google Cloud Console
    Memorystore pour Redis
  2. Cliquez sur l'ID de l'instance que vous souhaitez mettre à niveau.
  3. Dans la section Propriétés de l'instance, à côté de Version, cliquez sur METTRE À NIVEAU.
  4. Cliquez sur le bouton METTRE À NIVEAU de la boîte de dialogue pour mettre à niveau votre instance.

gcloud

Pour mettre à niveau la version Redis de votre instance, saisissez la commande suivante en remplaçant les variables par les valeurs appropriées :

gcloud redis instances upgrade instance-id --redis-version=version --region=region

Où :

  • instance-id est l'ID de votre instance.
  • version est la version vers laquelle vous souhaitez effectuer la mise à niveau :
    • Les valeurs acceptables sont : redis_4_0, redis_5_0, redis_6_X.
  • region est la région dans laquelle l'instance est provisionnée.

Exemple :

gcloud redis instances upgrade myinstance --redis-version=redis_5_0 --region=us-central1