Method: projects.locations.clusters.nodePools.update

Updates the version and/or image type of a specific node pool.

HTTP request

PUT https://container.googleapis.com/v1beta1/{name=projects/*/locations/*/clusters/*/nodePools/*}

The URL uses gRPC Transcoding syntax.

Path parameters

Parameters
name

string

The name (project, location, cluster, node pool) of the node pool to update. Specified in the format 'projects/*/locations/*/clusters/*/nodePools/*'.

Authorization requires the following Google IAM permission on the specified resource name:

  • container.clusters.update

Request body

The request body contains data with the following structure:

JSON representation
{
  "projectId": string,
  "zone": string,
  "clusterId": string,
  "nodePoolId": string,
  "nodeVersion": string,
  "imageType": string,
  "locations": [
    string
  ],
  "workloadMetadataConfig": {
    object (WorkloadMetadataConfig)
  },
  "upgradeSettings": {
    object (UpgradeSettings)
  }
}
Fields
projectId
(deprecated)

string

Required. Deprecated. The Google Developers Console project ID or project number. This field has been deprecated and replaced by the name field.

zone
(deprecated)

string

Required. Deprecated. The name of the Google Compute Engine zone in which the cluster resides. This field has been deprecated and replaced by the name field.

clusterId
(deprecated)

string

Required. Deprecated. The name of the cluster to upgrade. This field has been deprecated and replaced by the name field.

nodePoolId
(deprecated)

string

Required. Deprecated. The name of the node pool to upgrade. This field has been deprecated and replaced by the name field.

nodeVersion

string

Required. The Kubernetes version to change the nodes to (typically an upgrade).

Users may specify either explicit versions offered by Kubernetes Engine or version aliases, which have the following behavior:

  • "latest": picks the highest valid Kubernetes version
  • "1.X": picks the highest valid patch+gke.N patch in the 1.X version
  • "1.X.Y": picks the highest valid gke.N patch in the 1.X.Y version
  • "1.X.Y-gke.N": picks an explicit Kubernetes version
  • "-": picks the Kubernetes master version

imageType

string

Required. The desired image type for the node pool.

locations[]

string

The desired list of Google Compute Engine zones in which the node pool's nodes should be located. Changing the locations for a node pool will result in nodes being either created or removed from the node pool, depending on whether locations are being added or removed.

workloadMetadataConfig

object (WorkloadMetadataConfig)

The desired image type for the node pool.

upgradeSettings

object (UpgradeSettings)

Upgrade settings control disruption and speed of the upgrade.

Response body

If successful, the response body contains an instance of Operation.

Authorization Scopes

Requires the following OAuth scope:

  • https://www.googleapis.com/auth/cloud-platform

For more information, see the Authentication Overview.

このページは役立ちましたか?評価をお願いいたします。

フィードバックを送信...