支持的 Go 版本

Go Cloud 客户端库至少与三个最新的 Go 主要版本兼容,并且与 App Engine 和 Cloud Functions 的至少一个正式版运行时兼容。这意味着 Cloud 客户端库与当前支持的所有 Go 版本以及至少一个其他版本兼容。例如,如果当前 Go 版本是 Go 1.17,则 Cloud 客户端库至少与 Go 1.17、Go 1.16 和 Go 1.15 兼容。如需详细了解 Cloud 客户端库,请参阅客户端库说明

新开发

启动新项目时,如果可能,我们建议选择 Go 的当前版本。这可确保您的运行时在受支持的 Go 版本中,并可接收关键安全补丁程序。

使生产系统保持最新

请确保将生产系统保留在受支持的 Go 运行时上是确保获得关键安全和问题修复的最佳方式。我们的 Go Cloud 客户端放弃与早期 Go 运行时版本的兼容性时,会递增次要版本。如需详细了解如何使用主要版本和次要版本,请参阅语义版本控制

何处查找特定版本信息

如需了解当前支持的 Go 版本,请参阅 google-cloud-go README