Google Cloud Spanner v1 API - Class ExecuteSqlRequest.Types.QueryOptions (4.1.0)

Stay organized with collections Save and categorize content based on your preferences.
public sealed class QueryOptions : IMessage<ExecuteSqlRequest.Types.QueryOptions>, IEquatable<ExecuteSqlRequest.Types.QueryOptions>, IDeepCloneable<ExecuteSqlRequest.Types.QueryOptions>, IBufferMessage, IMessage

Reference documentation and code samples for the Google Cloud Spanner v1 API class ExecuteSqlRequest.Types.QueryOptions.

Query optimizer configuration.

Inheritance

Object > ExecuteSqlRequest.Types.QueryOptions

Namespace

Google.Cloud.Spanner.V1

Assembly

Google.Cloud.Spanner.V1.dll

Constructors

QueryOptions()

public QueryOptions()

QueryOptions(ExecuteSqlRequest.Types.QueryOptions)

public QueryOptions(ExecuteSqlRequest.Types.QueryOptions other)
Parameter
NameDescription
otherExecuteSqlRequest.Types.QueryOptions

Properties

OptimizerStatisticsPackage

public string OptimizerStatisticsPackage { get; set; }

An option to control the selection of optimizer statistics package.

This parameter allows individual queries to use a different query optimizer statistics package.

Specifying latest as a value instructs Cloud Spanner to use the latest generated statistics package. If not specified, Cloud Spanner uses the statistics package set at the database level options, or the latest package if the database option is not set.

The statistics package requested by the query has to be exempt from garbage collection. This can be achieved with the following DDL statement:

ALTER STATISTICS <package_name> SET OPTIONS (allow_gc=false)

The list of available statistics packages can be queried from INFORMATION_SCHEMA.SPANNER_STATISTICS.

Executing a SQL statement with an invalid optimizer statistics package or with a statistics package that allows garbage collection fails with an INVALID_ARGUMENT error.

Property Value
TypeDescription
String

OptimizerVersion

public string OptimizerVersion { get; set; }

An option to control the selection of optimizer version.

This parameter allows individual queries to pick different query optimizer versions.

Specifying latest as a value instructs Cloud Spanner to use the latest supported query optimizer version. If not specified, Cloud Spanner uses the optimizer version set at the database level options. Any other positive integer (from the list of supported optimizer versions) overrides the default optimizer version for query execution.

The list of supported optimizer versions can be queried from SPANNER_SYS.SUPPORTED_OPTIMIZER_VERSIONS.

Executing a SQL statement with an invalid optimizer version fails with an INVALID_ARGUMENT error.

See https://cloud.google.com/spanner/docs/query-optimizer/manage-query-optimizer for more information on managing the query optimizer.

The optimizer_version statement hint has precedence over this setting.

Property Value
TypeDescription
String