Database Migration v1 API - Enum MigrationJobVerificationError.Types.ErrorCode (2.4.0)

public enum MigrationJobVerificationError.Types.ErrorCode

Reference documentation and code samples for the Database Migration v1 API enum MigrationJobVerificationError.Types.ErrorCode.

A general error code describing the type of error that occurred.

Namespace

Google.Cloud.CloudDms.V1

Assembly

Google.Cloud.CloudDms.V1.dll

Fields

NameDescription
AuthenticationFailure

We failed to authenticate to one of the connection profile.

CantRestartRunningMigration

Migration is already running at the time of restart request.

ConnectionFailure

We failed to connect to one of the connection profile.

ConnectionProfileTypesIncompatibility

The types of the source and the destination are incompatible.

ErrorRdbms

There was an underlying RDBMS error.

ExistingConflictingDatabases

The destination DB contains existing databases that are conflicting with those in the source DB.

InsufficientMaxReplicationSlots

The value of parameter max_replication_slots is not sufficient.

InsufficientMaxWalSenders

The value of parameter max_wal_senders is not sufficient.

InsufficientMaxWorkerProcesses

The value of parameter max_worker_processes is not sufficient.

InvalidConnectionProfileConfig

One of the involved connection profiles has an invalid configuration.

InvalidRdsLogicalReplication

Invalid RDS logical replication.

InvalidSharedPreloadLibrary

The value of parameter shared_preload_libraries does not include pglogical.

InvalidWalLevel

The value of parameter wal_level is not set to logical.

NoPglogicalInstalled

No pglogical extension installed on databases, applicable for postgres.

ParallelImportInsufficientPrivilege

Insufficient privilege to enable the parallelism configuration.

PglogicalNodeAlreadyExists

pglogical node already exists on databases, applicable for postgres.

SourceAlreadySetup

The source already has a replication setup.

SourceSizeExceedsThreshold

The source DB size in Bytes exceeds a certain threshold. The migration might require an increase of quota, or might not be supported.

TablesWithLimitedSupport

The source has tables with limited support. E.g. PostgreSQL tables without primary keys.

Unspecified

An unknown error occurred

UnsupportedDatabaseFdwConfig

The source uses an unsupported Foreign Data Wrapper configuration.

UnsupportedDatabaseLocale

The source uses an unsupported locale.

UnsupportedDefiner

The definer is not supported.

UnsupportedExtensions

Extensions installed are either not supported or having unsupported versions.

UnsupportedGtidMode

The gtid_mode is not supported, applicable for MySQL.

UnsupportedMigrationType

Unsupported migration type.

UnsupportedTableDefinition

The table definition is not support due to missing primary key or replica identity.

VersionIncompatibility

The versions of the source and the destination are incompatible.