Résoudre les problèmes liés aux tâches KubernetesExecutor

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Cette page explique comment résoudre les problèmes liés aux tâches exécutées par KubernetesExecutor et fournit des solutions aux problèmes courants.

Approche générale pour résoudre les problèmes liés à KubernetesExecutor

Pour résoudre les problèmes liés à une tâche exécutée avec KubernetesExecutor, procédez comme suit:

  1. Vérifiez les journaux de la tâche dans l'interface utilisateur du DAG ou dans l'interface utilisateur d'Airflow.

  2. Vérifiez les journaux du planificateur dans la console Google Cloud:

    1. Dans la console Google Cloud, accédez à la page Environnements.

      Accéder à la page Environnements

    2. Dans la liste des environnements, cliquez sur le nom de votre environnement. La page Détails de l'environnement s'ouvre.

    3. Accédez à l'onglet Journaux, puis vérifiez la section Journaux Airflow > Planificateur.

    4. Pour une période donnée, inspectez le pod de worker KubernetesExecutor qui exécutait la tâche. Si le pod n'existe plus, ignorez cette étape. Le pod comporte le préfixe airflow-k8s-worker et un nom de DAG ou de tâche. Recherchez d'éventuels problèmes signalés, tels qu'une tâche ayant échoué ou une tâche non planifiable.

Scénarios de dépannage courants pour KubernetesExecutor

Cette section répertorie les scénarios de dépannage courants que vous pouvez rencontrer avec KubernetesExecutor.

La tâche passe à l'état Running, puis échoue lors de l'exécution.

Symptômes :

  • Des journaux sont disponibles pour la tâche dans l'UI d'Airflow et dans l'onglet Logs (Journaux) de la section Workers (Nœuds de calcul).

Solution: Les journaux des tâches indiquent le problème.

L'instance de tâche passe à l'état queued, puis est marquée comme UP_FOR_RETRY ou FAILED au bout d'un certain temps.

Symptômes :

  • Aucun journal de tâche n'est disponible dans l'UI d'Airflow ni dans l'onglet Logs (Journaux) de la section Workers (Nœuds de calcul).
  • Des journaux sont disponibles dans l'onglet Journaux de la section Planificateur, avec un message indiquant que la tâche est marquée comme UP_FOR_RETRY ou FAILED.

Solution :

  • Examinez les journaux du planificateur pour obtenir des informations sur le problème.

Causes possibles :

  • Si les journaux du planificateur contiennent le message Adopted tasks were still pending after... suivi de l'instance de tâche imprimée, vérifiez que CeleryKubernetesExecutor est activé dans votre environnement.

L'instance de tâche atteint l'état Queued et est immédiatement marquée comme UP_FOR_RETRY ou FAILED.

Symptômes :

  • Aucun journal de la tâche n'est disponible dans l'interface utilisateur d'Airflow ni dans l'onglet Journals de la section Nœuds de calcul.
  • Les journaux du planificateur dans l'onglet Journaux de la section Planificateur contiennent le message Pod creation failed with reason ... Failing task et le message indiquant que la tâche est marquée comme UP_FOR_RETRY ou FAILED.

Solution :

  • Consultez les journaux du planificateur pour obtenir la réponse exacte et la raison de l'échec.

Cause possible:

Si le message d'erreur est quantities must match the regular expression ..., le problème est très probablement dû à des valeurs personnalisées définies pour les ressources k8s (requêtes/limites) des pods de nœuds de travail de tâche.

Les tâches KubernetesExecutor échouent sans journaux lorsqu'un grand nombre de tâches sont exécutées

Lorsque votre environnement exécute un grand nombre de tâches avec KubernetesExecutor ou KubernetesPodOperator en même temps, Cloud Composer 3 n'accepte pas de nouvelles tâches tant que certaines des tâches existantes ne sont pas terminées. Les tâches supplémentaires sont marquées comme ayant échoué, et Airflow les réessaie plus tard, si vous définissez des tentatives pour les tâches (Airflow le fait par défaut).

Symptôme:les tâches exécutées avec KubernetesExecutor ou KubernetesPodOperator échouent sans journaux de tâches dans l'interface utilisateur d'Airflow ou de DAG. Dans les journaux de l'ordonnanceur, vous pouvez voir des messages d'erreur semblables à ceux-ci:

pods \"airflow-k8s-worker-*\" is forbidden: exceeded quota: k8s-resources-quota,
requested: pods=1, used: pods=*, limited: pods=*","reason":"Forbidden"

Solutions possibles:

  • Ajustez la planification d'exécution du DAG afin que les tâches soient réparties de manière plus uniforme au fil du temps.
  • Réduisez le nombre de tâches en regroupant les petites tâches.

Solution :

Si vous préférez que les tâches restent à l'état planifié jusqu'à ce que votre environnement puisse les exécuter, vous pouvez définir un pool Airflow avec un nombre limité d'emplacements dans l'interface utilisateur Airflow, puis associer toutes les tâches basées sur des conteneurs à ce pool. Nous vous recommandons de définir le nombre d'emplacements du pool sur 50 ou moins. Les tâches supplémentaires resteront à l'état planifié jusqu'à ce que le pool Airflow dispose d'un espace libre pour les exécuter. Si vous utilisez cette solution de contournement sans appliquer les solutions possibles, vous pouvez toujours rencontrer une longue file d'attente de tâches dans le pool Airflow.

Étape suivante