测试版客户端库

您可能需要测试版特定的客户端库才能使用 Video Intelligence 测试版功能,具体取决于您的应用语言。

安装测试版客户端库

v1p3beta1 客户端库可用于流式传输测试版和实时流式传输测试版。

Java

如果您使用的是 Maven,请将以下内容添加到您的 pom.xml 文件中:

<dependency>
  <groupId>com.google.cloud</groupId>
  <artifactId>google-cloud-video-intelligence</artifactId>
  <version>0.116.0-beta</version>
</dependency>

如果您使用的是 Gradle,请将以下内容添加到您的依赖项中:

compile 'com.google.cloud:google-cloud-video-intelligence:0.116.0-beta'

如果您使用的是 SBT,请将以下内容添加到您的依赖项中:

libraryDependencies += "com.google.cloud" % "google-cloud-video-intelligence" % "0.116.0-beta"

Node.js

常规的 Node.js 版 Video Intelligence API 客户端库提供测试版功能。

在您的 Node.js 应用中,使用以下行指定 API 的测试版:

const videoIntelligence = require('@google-cloud/video-intelligence').v1p3beta1;

Python

常规的 Python 版 Video Intelligence API 客户端库提供测试版功能。

在 Python 应用程序中,导入 API 的 v1p3beta1 版本:

from google.cloud import videointelligence_v1p3beta1 as videointelligence