Composer logs are missing after upgrade

Problem

You notice that Cloud Composer logs are missing after upgrading machine type, or creating new Google Kubernetes Engine node-pool.

Environment

  • Any Composer version 

Solution

  1. Always make sure the new node-pool is created with parameters of the original node-pool except the machine type.

Cause

You need to use parameters of the original node-pool while creating the new node-pool except the machine type. If there is a change in image type then composer logs will be missing, however the same logs will be available in the kubernetes logs. 
The airflow-monitoring logs will be missing you have not enabled Integrity Monitoring while creating the node-pool.