Versiones de Go compatibles

Las bibliotecas cliente de Cloud para Go son compatibles con al menos las tres versiones principales de Go más recientes y son compatibles con al menos un entorno de ejecución de GA para App Engine y Cloud Functions. Esto significa que las bibliotecas cliente de Cloud son compatibles con todas las versiones compatibles de Go, además de al menos una versión adicional. Por ejemplo, si la versión actual de Go es Go 1.17, las bibliotecas cliente de Cloud son compatibles con al menos Go 1.17, Go 1.16 y Go 1.15. Para obtener más información sobre las bibliotecas cliente de Cloud, consulta Explicación de las bibliotecas cliente.

Para un desarrollo nuevo

Cuando se inicia un proyecto nuevo, te recomendamos que elijas la versión actual de Go, si es posible. Esto garantiza que el entorno de ejecución se encuentre dentro de las versiones compatibles de Go y reciba parches de seguridad críticos.

Mantén los sistemas de producción actualizados

Mantener los sistemas de producción en entornos de ejecución de Go compatibles es la mejor manera de garantizar que recibas correcciones de errores y seguridad críticas. Nuestras bibliotecas cliente de Cloud de Go incrementan una versión secundaria cuando se descarta la compatibilidad con una versión anterior del entorno de ejecución de Go. Para obtener más información sobre el uso de versiones principales y secundarias, consulta Control de versiones semánticas.

Dónde encontrar la información de la versión específica

Para saber qué versiones de Go son compatibles actualmente, consulta el archivo README de google-cloud-go.