Package spec (1.53.0)

API documentation for spec package.

Classes

DataDriftSpec

Data drift monitoring spec.

Data drift measures the distribution distance between the current dataset and a baseline dataset. A typical use case is to detect data drift between the recent production serving dataset and the training dataset, or to compare the recent production dataset with a dataset from a previous period.

.. rubric:: Example

feature_drift_spec=DataDriftSpec( features=["feature1"] categorical_metric_type="l_infinity", numeric_metric_type="jensen_shannon_divergence", default_categorical_alert_threshold=0.01, default_numeric_alert_threshold=0.02, feature_alert_thresholds={"feature1":0.02, "feature2":0.01}, )

FeatureAttributionSpec

Feature attribution spec.

.. rubric:: Example

feature_attribution_spec=FeatureAttributionSpec( features=["feature1"] default_alert_threshold=0.01, feature_alert_thresholds={"feature1":0.02, "feature2":0.01}, batch_dedicated_resources=BatchDedicatedResources( starting_replica_count=1, max_replica_count=2, machine_spec=my_machine_spec, ), )

FieldSchema

Field Schema.

The class identifies the data type of a single feature, which combines together to form the Schema for different fields in ModelMonitoringSchema.

ModelMonitoringSchema

Initializer for ModelMonitoringSchema.

MonitoringInput

Model monitoring data input spec.

NotificationSpec

Initializer for NotificationSpec.

ObjectiveSpec

Initializer for ObjectiveSpec.

OutputSpec

Initializer for OutputSpec.

TabularObjective

Initializer for TabularObjective.