Como anexar o depurador remoto

Neste documento, descrevemos como anexar o depurador remoto do Visual Studio aos processos em uma máquina virtual do Google Cloud Compute Engine com Windows.

Pré-requisitos

Antes de começar, confirme se a sua máquina virtual atende aos seguintes pré-requisitos:

  • tem o sistema operacional Windows

  • tem um endereço IP público

  • o Remote PowerShell está instalado e ativado

    • Se você não quiser ativar a conexão com o Remote PowerShell, ou se ele não estiver instalado na VM, encontre as etapas para instalar as Ferramentas remotas do Depurador do Visual Studio manualmente procurando a Depuração remota do Visual Studio MSDN.

    • Também é possível adicionar regras de firewall para desbloquear a porta da Ferramenta remota do depurador.

É possível implantar uma imagem da estrutura ASP.NET que atenda a todos esses pré-requisitos.

Como anexar o depurador remoto

Para anexar o depurador remoto:

  1. Selecione Ferramentas > Google Cloud Tools > Mostrar o Google Cloud Explorer para iniciar o Cloud Explorer.

  2. Clique com o botão direito do mouse na instância da VM do Compute Engine em que você queira anexar o depurador remoto e selecione Anexar depurador.

    O assistente para anexar o depurador é exibido.

  3. Clique em OK quando solicitado a adicionar regras de firewall para permitir o tráfego para as portas necessárias.

    1. O link Saiba mais na caixa de diálogo leva você à seção Como abrir portas de firewall. Lá, você encontrará mais informações.
  4. Selecione o processo a ser depurado e clique em OK.

Observe o seguinte:

  • Na primeira vez que você se conecta a uma instância de VM remota, o assistente instala as Ferramentas remotas do Depurador do Visual Studio para você. Essa instalação pode levar algum tempo se a VM estiver em uma região diferente.

  • As ferramentas do depurador são instaladas em Program Files\VisualStudioRemoteTools na máquina de destino.

  • Para otimizar sua versão de lançamento, é preciso carregar os símbolos manualmente:

    1. Como você está depurando seu aplicativo, selecione Depurar > Windows > Módulos.

    2. Localize seu conjunto depurado.

    3. Clique com o botão direito do mouse na entrada apropriada e selecione Carregar símbolos.

Como abrir portas de firewall

Para ativar a depuração remota, você precisa adicionar regras de firewall para permitir o tráfego à máquina de destino e ativar a conexão com as ferramentas remotas de depuração. Para o Visual Studio 2017, a porta é 4022.

O Cloud Tools for Visual Studio instala e inicia ferramentas remotas para você usando uma conexão remota do PowerShell. Primeiro, você precisa ativar a porta HTTPs do PowerShell remoto 5986.

Quando terminar a depuração, remova as regras de firewall:

  1. Selecione Ferramentas > Google Cloud Tools > Mostrar o Google Cloud Explorer para iniciar o Cloud Explorer.

  2. Clique com o botão direito do mouse na instância de VM do Compute Engine e selecione Opções de firewall...

  3. Desmarque as caixas de seleção das regras de firewall Permitir conexões do depurador do Visual Studio com a instância e Permitir tráfego HTTPs do PowerShell remoto para a instância.

  4. Clique em Salvar para remover as regras do firewall.