Guía de inicio rápido

En esta página, se muestra cómo configurar Microsoft Visual Studio y cómo crear y, luego, implementar una aplicación de ASP.NET en Google Cloud.

Antes de comenzar

  1. En la página de selección de proyectos de Cloud Console, haz clic en Crear para comenzar a crear un proyecto de Cloud nuevo.

    Ir a la página de selección de proyectos

  2. Comprueba que la facturación esté habilitada en tu proyecto.

    Descubre cómo puedes habilitar la facturación

  3. Asegúrate de tener instalado el siguiente software en tu sistema local:
  4. Crea una VM nueva de Windows para alojar tu aplicación:
    1. Navega a la imagen de framework de ASP.NET en Google Cloud Marketplace.
      Ir a la imagen de framework de ASP.NET
    2. Selecciona Iniciar en Compute Engine.
    3. Selecciona el nombre de tu implementación y su configuración, y asegúrate de que las opciones Permitir el tráfico HTTP y Permitir el tráfico WebDeploy estén marcadas.
    4. Selecciona Implementar.

Instala Cloud Tools for Visual Studio

Para instalar Cloud Tools for Visual Studio en el cuadro de diálogo Extensions and Updates (Extensiones y actualizaciones) en Visual Studio, sigue estos pasos:

  1. Selecciona Tools (Herramientas) > Extensions and Updates (Extensiones y actualizaciones).
  2. Selecciona la faceta Online (En línea) en el panel izquierdo.
  3. Busca Google Cloud Tools for Visual Studio.
  4. Captura de pantalla en la que se muestra el cuadro de diálogo de Extensions and Updates (Extensiones y actualizaciones). En el panel izquierdo, se muestran las fuentes de extensión organizadas en pestañas. En el panel central, se muestran las entradas en las pestañas; en el panel derecho, se proporcionan detalles sobre la selección actual. Se selecciona la opción Google Cloud Tools for Visual Studio.

  5. Haz clic en Download (Descargar) y sigue las indicaciones.
  6. Reinicia Visual Studio para cargar la extensión.

Accede a Google:

Accede a una Cuenta de Google que uses para implementar tu proyecto en App Engine.

  1. Abre Visual Studio.
  2. Inicia Cloud Explorer. Para ello, selecciona Tools (Herramientas) > Google Cloud Tools (Herramientas de Google Cloud) > Show Google Cloud Explorer (Mostrar Google Cloud Explorer).
  3. Captura de pantalla en la que se muestra Cloud Explorer con el vínculo Select or create account (Seleccionar o crear cuenta).

  4. Haz clic en Select or create account (Seleccionar o crear cuenta).
  5. Haz clic en Add account (Agregar cuenta).
  6. Se abrirá una ventana nueva del navegador y se te solicitarán los permisos que necesita para administrar tus recursos de Google Cloud.

  7. Selecciona la cuenta que se usará para tu aplicación.
  8. Haz clic en Permitir y cierra la ventana del navegador.

Selecciona un proyecto

Para seleccionar un proyecto de Google Cloud en el que implementarás tu aplicación, haz lo siguiente:

  1. En Cloud Explorer, haz clic en Select Project (Seleccionar proyecto).
  2. Selecciona tu proyecto en la lista.
  3. Captura de pantalla en la que se muestra el cuadro de diálogo Select Google Cloud Project (Seleccionar proyecto de Google Cloud) con un proyecto de muestra.

  4. Haga clic en Aceptar.

Cloud Explorer actualiza y muestra los recursos del proyecto seleccionado.

Crea una app de ASP.NET

Para crear un proyecto ASP.NET nuevo y ejecutarlo de manera local, sigue estos pasos:

  1. Selecciona File (Archivo) > New (Nuevo) > Project (Proyecto) para abrir el cuadro de diálogo New Project (Proyecto nuevo).
  2. Cuadro de diálogo New Project (Proyecto nuevo). A la izquierda, se muestran los tipos de proyectos disponibles, con la opción Google Cloud Platform seleccionada. Al centro, se muestran las plantillas disponibles, con la opción ASP.NET en Google Platform seleccionada. También, se muestran los campos para ingresar el nombre del proyecto, la ubicación y el nombre de la solución.

  3. Usa el panel izquierdo para navegar hasta Installed (Instalado) > Visual C# > Google Cloud Platform.
  4. Selecciona ASP.NET on Google Cloud Platform (ASP.NET en Google Cloud Platform).
  5. Para implementar tu aplicación en una VM en Compute Engine, oriéntala a .NET Framework, no a .NET Core. Usa la plantilla de ASP.NET Core on Google Cloud Platform (ASP.NET Core en Google Cloud Platform) para GKE o App Engine.

  6. Ingresa el nombre de tu proyecto en Name (Nombre).
  7. Haga clic en Aceptar.
  8. Cuadro de diálogo para seleccionar el framework de destino del proyecto nuevo. Hay 2 menús desplegables para la selección del framework de destino, un selector de ID del proyecto de Google Cloud y 2 botones de selección.

  9. Selecciona el Template type (Tipo de proyecto).
  10. Haga clic en Aceptar.
  11. Crea la solución, ejecútala de manera local y verifica que funcione.

Implementa una app de ASP.NET

Para implementar tu app de ASP.NET en una VM de Windows que se ejecuta en Compute Engine, sigue estos pasos:

  1. En Cloud Explorer, selecciona el proyecto recién creado y expande GKE.
  2. Haz clic con el botón derecho en la instancia de VM que creaste anteriormente con Cloud Marketplace.
  3. Selecciona Administrar credenciales de Windows.

    Administrar cuentas

  4. Haz clic en Agregar credenciales.
  5. Ingresa un nombre de usuario.
  6. Asegúrate de que la opción Create a password for me (Crear una contraseña) esté seleccionada y haz clic en Save (Guardar).
  7. Haz clic en Reset (Restablecer) cuando aparezca la pregunta de confirmación: "Reset the password for [your username] on the instance [instance you created]?" (¿Restablecer contraseña para [tu nombre de usuario] en la instancia [instancia que creaste]).
  8. Luego, haz clic en el botón Close (Cerrar) para cerrar la ventana de contraseñas.
  9. A continuación, haz clic en el botón Close (Cerrar) para cerrar la ventana Windows Credentials (Credenciales de Windows).
  10. En el panel Solution Explorer (Explorador de soluciones) de Visual Studio, haz clic derecho en tu aplicación.
  11. En el menú contextual, haz clic en Publish to Google Cloud… (Publicar en Google Cloud…).

    Publicar en Google Cloud

  12. En el cuadro de diálogo Publish (Publicar), selecciona Compute Engine.

    Seleccionar para publicar en Compute Engine

  13. Haz clic en Publish (Publicar) para implementar y compilar la aplicación de muestra. Luego de que se complete la publicación, Visual Studio abrirá la aplicación en tu navegador web predeterminado.

    Probar la aplicación

Eso es todo. Tu aplicación está alojada en Compute Engine.

Qué sigue