Como revisar registros com o visualizador do Stackdriver

Neste documento, fornecemos informações sobre como usar o visualizador de registros do Stackdriver.

Antes de começar

  • Configure seu aplicativo para usar a API Stackdriver Logging.

  • Faça login na sua conta para acessar os recursos do Google Cloud Platform.

    • Selecione Ferramentas -> Google Cloud Tools -> Gerenciar contas para selecionar sua conta.

Como acessar o Visualizador de registros

Para acessar o Visualizador de registros do Stackdriver, selecione Ferramentas -> Google Cloud Tools -> Mostrar Visualizador de registros do Stackdriver.

A guia Google Stackdriver Logging é aberta.

Você também pode abrir o Visualizador de registros de um projeto específico do Google Cloud Explorer selecionando Ferramentas -> Google Cloud Tools -> Google Cloud Explorer. Clique com o botão direito do mouse no projeto e selecione Procurar registros do Stackdriver.

Imagem que mostra a visão geral da guia Visualizador de registros

Como chegar na interface

Os componentes principais da interface do Visualizador de registros são:

  • Uma barra de pesquisa para filtrar entradas de registro por rótulo ou pesquisa de texto.

  • Menus suspensos para filtrar a lista por recursos, registros e níveis de gravidade.

  • Menu suspenso Ir para este ponto no tempo para ver uma data e hora específicas nos registros.

  • Um botão Atualizar para recuperar os registros mais recentes em ordem decrescente.

  • O stream de registro de carga automática controla se as novas entradas de registro serão exibidas ou não quando chegarem.

    • Clicar em Reproduzir inicia o stream dos registros mais recentes. O stream será interrompido se você rolar a exibição de registros.

    • Clicar em Pausar interrompe o stream de registros.

  • A tabela de resumos de registros que é possível clicar para ver os detalhes completos das entradas de registro individuais.

  • Uma seta para baixo Expandir tudo no canto superior direito do painel de entradas de registro para mostrar os detalhes de todas essas entradas. Essa ação poderá levar algum tempo, se o painel tiver muitas entradas de registro.

  • Se disponível, um link de origem para localizar o código-fonte que gera a entrada de registro.

O Visualizador de registros permite navegar até o código-fonte que gera uma entrada de registro. Para ativar esse recurso, crie seu projeto de um repositório git local. Adicione informações do local de origem às entradas de registro.

Como adicionar o local de origem ao registro

Configure seu aplicativo para fornecer informações de local do código-fonte nos registros:

  1. Grave informações de local das entradas de registro usando o exemplo do GitHub a seguir.

  2. Implante um arquivo source_context.json na raiz do aplicativo.

    Se você publicar a solução por meio do Cloud Tools for Visual Studio, a extensão gera e implanta o arquivo automaticamente. Você também pode gerar o arquivo sozinho, seguindo as instruções em Gerar o arquivo de contexto da fonte.

Depois que você concluir essas etapas, as entradas de registro incluirão um campo sourceLocation com informações de Arquivo e Linha. A linha opcional Função pode conter o nome da montagem, a versão ou o nome da função.

Imagem que mostra a entrada de registro expandida e um link para navegar até o código-fonte

Ao clicar no link de origem, você navegará para o código-fonte, se o arquivo de origem estiver acessível.

Imagem que mostra o código-fonte acessado a partir do link na entrada de registro

Como visualizar os registros

Na interface do Visualizador de registros, você pode filtrar as entradas de registro ou pesquisar registros específicos para exibição.

Como filtrar os registros

É possível filtrar as entradas de registro para ver apenas os registros que forem de seu interesse.

  • No menu suspenso de tipo de recurso e instância, selecione todas as instâncias de um determinado tipo de recurso ou instância específica que queira ver. Para ver uma lista de tipos de recursos, consulte Recursos e serviços monitorados.

  • No menu suspenso de tipo de registro, selecione os registros nomeados que você quer ver ou selecione Todos os registros. O menu mostra apenas os registros que o recurso selecionado gera.

  • No menu suspenso de gravidade de registro, selecione o nível de gravidade que você quer ver. A seleção de Todos os níveis de registros inclui entradas de registro sem um nível de gravidade.

  • No menu suspenso Ir para este ponto no tempo, selecione uma data e hora. Escolha se você quer ver os registros antes ou depois do carimbo de data/hora selecionado.

Também é possível clicar em Para filtro avançado para acessar a barra de filtro avançado, onde é possível filtrar as entradas de registro por meio de consultas. Clique no link Ajuda do filtro avançado para mais informações.

Imagem que mostra a barra de filtro avançada

Como pesquisar os registros

Na barra de pesquisa, procure palavras-chave que aparecem nas entradas de registro.

Imagem que mostra resultados de pesquisa

Como mostrar registros semelhantes

Clique no valor de um campo individual na visualização expandida de entrada de registro para mostrar ou ocultar todas as entradas de registro com o mesmo valor.

Imagem que mostra como clicar para encontrar entradas de registro semelhantes

Quando as entradas de registro semelhantes forem exibidas, a barra de filtro avançado será exibida. Nela, é possível editar o filtro e clicar em Enviar filtros. Clique no link Ajuda do filtro avançado para mais informações.