Versões PHP compatíveis

Mantenha tudo organizado com as coleções Salve e categorize o conteúdo com base nas suas preferências.

As bibliotecas de cliente do Cloud para PHP são compatíveis com pelo menos as três principais versões mais recentes do PHP. Isso significa que as bibliotecas de cliente PHP são compatíveis com todas as versões PHP com suporte ativo. O PHP lança uma nova versão principal a cada 12 meses, com duas versões ativas e uma versão recebendo apenas correções de segurança.

Por exemplo, se a versão atual das bibliotecas de cliente do Cloud para PHP for PHP 8.1, as bibliotecas de cliente serão compatíveis com PHP 8.1, PHP 8.0 e PHP 7.4. As bibliotecas sempre serão compatíveis com pelo menos um ambiente de execução do GA para o App Engine e o Cloud Functions. Para mais informações, consulte as bibliotecas de cliente explicadas.

Para um desenvolvimento novo

Ao iniciar um novo projeto para desenvolvimento novo, recomendamos usar a versão atual do PHP. Isso garante que o ambiente de execução use uma versão compatível do PHP e receba patches de segurança essenciais.

Como manter os sistemas de produção atualizados

Manter seus sistemas de produção em versões compatíveis do PHP é a melhor maneira de garantir que você receba correções críticas de segurança e bugs. Quando as bibliotecas de cliente do Cloud para PHP incrementam uma versão secundária, elas podem deixar de ser compatível com uma versão anterior do PHP. Quando uma nova versão de uma biblioteca estiver disponível e não for compatível com uma versão do PHP, considere fazer upgrade do ambiente de execução para a versão mais recente do PHP. Para mais informações sobre o uso de versões principal e secundária, consulte Controle de versão semântico.

Onde encontrar informações da versão

Para saber quais versões do PHP são compatíveis no momento, consulte a página Biblioteca de cliente do Google Cloud para PHP.