Overview of Stackdriver support for GKE

Google Kubernetes Engine (GKE) includes managed support for Stackdriver. When you create a GKE cluster, you can select one of the two Stackdriver support options:

  • Legacy Stackdriver support.

  • Stackdriver Kubernetes Engine Monitoring support.

You also have the option to create a GKE cluster without selecting Stackdriver support.

These options are provided by all GKE versions currerntly available for new clusters and for updates to existing clusters. For installation instructions, see Installing Stackdriver support.

Which Stackdriver option should I use?

You can opt-in to use Stackdriver Kubernetes Engine Monitoring or use the default Legacy Stackdriver. Both options are generally available as of GKE version 1.12.7. Here are some issues to consider:

  • Stackdriver Kubernetes Engine Monitoring is the preferred option, starting with GKE versions 1.12.7 and 1.13.

  • Legacy Stackdriver is the default option up through GKE version 1.13; however, it isn't getting any improvements and lacks features present in Stackdriver Kubernetes Engine Monitoring.

  • Only Legacy Stackdriver lets you disable Stackdriver Logging while still using Stackdriver Monitoring.

About Stackdriver Kubernetes Engine Monitoring

Stackdriver Kubernetes Engine Monitoring, the replacement for Legacy Stackdriver, is designed to monitor GKE clusters. It manages Monitoring and Logging services together and features a Stackdriver Kubernetes Engine Monitoring interface that provides a dashboard customized for GKE clusters:

  • In the summary pane, you can view a cluster's key metrics, such as CPU utilization, memory utilization, and the number of open incidents.

  • You can view clusters by their infrastructure, workloads, or services.

  • You can inspect namespaces, nodes, workloads, services, pods, and containers.

  • For pods and containers, you can view metrics as a function of time and view log entries using the Logs Viewer.

Selecting your Stackdriver support for GKE

If you are using Legacy Stackdriver, then you must switch to Stackdriver Kubernetes Engine Monitoring before support for Legacy Stackdriver is removed. The approximate timeline is given in the following table:

GKE version Choose no support Legacy Stackdriver Stackdriver Kubernetes Engine Monitoring
1.10, 1.11, 1.12.5 opt-in default (GA) opt-in (Beta)
1.12.7 opt-in default (GA) opt-in (GA)
1.13 opt-in default (GA) opt-in (GA)
1.14 opt-in opt-in (GA) default (GA)

Pricing

Both versions send chargeable metric data and log data to Stackdriver. See the Pricing page for details.

Stackdriver Kubernetes Engine Monitoring how-to guides

Legacy Stackdriver how-to guides

Segítségére volt ez az oldal? Tudassa velünk a véleményét:

Visszajelzés küldése a következővel kapcsolatban:

Segítségre van szüksége? Keresse fel súgóoldalunkat.