バージョン 4.11

サポートされているオペレーティング システム

Google Cloud Migrate for Compute Engine(旧称 Velostrata)は、次の表のオペレーティング システムを実行する VM の移行をサポートしています。

Linux VM を Google Cloud に移行する前に、再構成を行う追加のパッケージをインストールする必要があります。詳細については、Linux VM の準備をご覧ください。

一部の VM OS はオフライン移行でのみサポートされていることにご注意ください。オフライン移行では、ディスク ボリュームは Google Cloud に直接コピーされ、ストリーミング データはサポートされません。詳細については、オフライン移行の使用をご覧ください。

OS バージョン VMware(BIOS) VMware(EFI) VMware(セキュアブートでの EFI) AWS Azure(BIOS)第 1 / 第 2 世代 Azure(EFI)第 2 世代 コメント
AWS Linux Amazon Linux なし なし なし なし なし オフライン移行のみ。詳細については、Linux VM の準備をご覧ください。Amazon Linux VM はベスト エフォート方式で移行されます。移行後の Google Cloud はサポートされません。
CentOS 6.4 以降 × × ×

移行を行う前に、カーネル バージョン 2.6.32-754 以降が必要です。

dhclient-4.1.1-63.P1.0.1.el6_10 以降が必要です。

7.X * * *  
8.0 * * × ×  
Debian 8.5 以降 × × ×  
9 × × ×  
Oracle Linux 6.4~6.10 × × × × ×

移行を行う前に、カーネル バージョン 2.6.32-754 以降が必要です。

dhclient-4.1.1-63.P1.0.1.el6_10 以降が必要です。

7.0~7.9 * * × × ×  
8.0~8.3 * * × × ×  
RHEL 6.4 以降 × × ×

移行を行う前に、カーネル バージョン 2.6.32-754 以降が必要です。

dhclient-4.1.1-63.P1.0.1.el6_10 以降が必要です。

7.X * * *  
8.0 * * *  
SUSE 11 SP3 以降 なし なし なし なし なし  
12 SP2 なし なし なし なし なし  
12 SP3 * * *  
12 SP4 * * *

Azure の場合、カーネルの your-kernel-version-azure build に依存関係がないため、移行前に your-kernel-version-default に更新する必要があります。

15 * * × *  
Ubuntu 12.04 なし なし なし なし なし オフライン移行のみ
14.04.x LTS × × × オンライン移行にはカーネル バージョン 3.13.0-170 以降が必要
16.04.x LTS × × ×  
18.04.x LTS * * *  
Windows Server 2003 SP2 なし なし なし なし なし オフライン移行のみ
2003 R2 なし なし なし なし なし オフライン移行のみ
2008 R1(64 ビット) なし なし なし なし なし オフライン移行のみ
2008 R2(SP1 以降) * なし *  
2012/2012 R2 * * * 2012(R2 以外)は Google VSS エージェントでサポートされていません(Google ゲスト環境のドキュメントをご覧ください)。
2016 * * *  
2019 * * *  
* オンライン移行のみ(オフライン移行はサポートされていません)。