Sistemas operacionais e versões do Kubernetes compatíveis

Este tópico lista sistemas operacionais e versões do Kubernetes que foram testadas com o Migrate for Anthos.

O Migrate for Anthos fornece ferramentas que você executa em uma carga de trabalho de VM para determinar a compatibilidade dela para migração a um contêiner. Veja mais informações em:

Sistemas operacionais da VM de origem

VMs do Linux

O Migrate for Anthos aceita migrações de VMs para contêineres do Google Kubernetes Engine nos sistemas operacionais Linux de 64 bits listados na tabela a seguir.

SO Compute Engine VMware AWS Azure
CentOS 6.0, 7.0, 7.0 UEFI, 8.0 6.7, 6.9, 7.6 6.10, 7.5, 7.6 6.5 a 7.6, 7.0 LVM
Debian 7.0, 8.0, 9.0, 10.0 9.4, 9.6 6.0, 7.0, 8.0, 9.0, 10.0 8.0, 9.0, 10.0
RHEL 6.0, 7.0, 7.0 UEFI, 7.4 SAP, 7.6 SAP, 8.0 6.5, 7.5, 7.6 5.10, 5.11, 6.5 a 7.0, 7.1 a 7.7, 8.0, 8.1 6.7 a 6.10, 7.2 a 7.4, 7.5 LVM, 7.5 RAW, 7.6 LVM, 7.6 RAW, 7.4 a 7.7 SAP, 8.0
SUSE 12, 12 SP3 SAP, 12 SP4 SAP, 15, 15 SAP, 15 SP1 SAP 12 SP2, 12 SP3, 12 SP4, 15 11 SP4, 11 SP4 SAP, 12 SP2 SAP, 12 SP3, 12 SP3 SAP, 12 SP4, 12 SP4 SAP, 15 SAP, 15 SP1, 15 SP1 SAP 11 SP4 SAP, 11 SP4, 12 SP1, 12 SP1 SAP, 12 SP2, 12 SP2 SAP, 12 SP3, 12 SP3 SAP, 12 SP4, 12 SP4 SAP, 15, 15 SAP, 15 SP1, 15 SP1 SAP
Ubuntu 12 LTS, 14 LTS, 16 LTS, 16 LTS mínima, 18 LTS, 18 LTS mínima, 18 LTS UEFI, 19.04, 19.04 mínima 12.04.5 LTS, 14.04 LTS, 16.04 LTS, 18.04.10 LTS 12 LTS, 14 LTS, 16 LTS, 18 LTS, 19.04 12.04 LTS, 14.04 LTS, 16.04 LTS, 18.04 LTS, 19 LTS

VMs do Windows

O Migrate for Anthos aceita migrações de VMs para contêineres do Google Kubernetes Engine nos sistemas operacionais Windows listados na tabela a seguir:

SO Compute Engine
Windows
  • Microsoft Windows Server 2008R2 ou superior.
  • Microsoft IIS 7 ou aplicativos da Web superiores.
  • ASP.NET e .NET Framework versão 3.5 ou superior.

Após a migração, o contêiner resultante executará o Windows Server versão 1909.

Sistemas operacionais de cluster de processamento

Cargas de trabalho do Linux

  • Ubuntu: compatibilidade total

  • Os clusters com nós do Container-Optimized OS podem migrar cargas de trabalho com os tipos de sistema de arquivos ext2, ext3 ou ext4.

Cargas de trabalho do Windows

Sistemas operacionais do cluster de carga de trabalho

Cargas de trabalho do Linux

Cargas de trabalho do Windows

Versões compatíveis do Kubernetes

Cargas de trabalho do Linux

Para usar os aplicativos Linux migrados, você precisa usar estas versões:

  • 1.13.5-gke.10 e superior

As versões do Kubernetes abaixo de 1.13 não são compatíveis.

Cargas de trabalho do Windows

Para usar os aplicativos Windows migrados, você precisa usar estas versões:

  • 1.16 ou mais recente