Versões compatíveis

Os clusters do Kubernetes Engine são compatíveis com a execução de qualquer uma das três últimas versões secundárias do Kubernetes (atualmente 1.8.x, 1.7.x e 1.6.x). No entanto, as versões intermediárias subsequentes podem alterar as versões disponíveis para novos clusters.

Quando ficam disponíveis no Kubernetes Engine, as novas versões do Kubernetes são lançadas nas zonas de acordo com uma programação. Você pode encontrá-la nas notas da versão.

Além disso, é possível verificar quais versões do Kubernetes são padrão e estão disponíveis em uma determinada zona. Basta executar o comando a seguir:

gcloud container get-server-config --zone [COMPUTE-ZONE]

em que [COMPUTE-ZONE] é a zona de computação do cluster, como us-central1-a. No entanto, se você executar o comando antes da conclusão do lançamento da versão, a saída dele poderá não estar correta para sua zona.

Última atualização: 9 de janeiro de 2018

Versões disponíveis para novos mestres do cluster

Quando você cria um novo cluster, é possível escolher uma das versões do Kubernetes a seguir, qualificadas para o mestre do cluster:

  • 1.8.6-gke.0
  • 1.8.5-gke.0
  • 1.7.12-gke.0
  • 1.7.11-gke.1

Versões de node compatíveis

As seguintes versões do Kubernetes são compatíveis com os nodes de cluster do Kubernetes Engine:

  • Kubernetes 1.8.x
  • Kubernetes 1.7.x
Esta página foi útil? Conte sua opinião sobre:

Enviar comentários sobre…