設定內部部署路由器

建立 VLAN 連結後,您需要設定內部部署路由器,來建立連到雲端路由器的 BGP 工作階段。請使用 VLAN 連結提供的 VLAN ID、介面 IP 位址和對等互連 IP 位址來設定您的內部部署路由器。

本文件提供下列範例拓撲與設定,您可以在設定內部部署路由器時做為指南使用。

  • 僅第 3 層拓撲 (建議):一或多個專屬互連網路連線在內部部署路由器終止 (僅第 3 層拓撲)。路由器會使用雲端路由器執行 BGP 對等互連。這是建議設定。
  • 第 2/3 層拓撲:一或多個專屬互連網路連線在連線至內部部署路由器的內部部署交換器終止。路由器會使用雲端路由器執行 BGP 對等互連。

您也可以參閱 VPN 協同整合指南中的廠商專屬注意事項一節,以取得您可能用於內部部署路由器的某些第三方平台的設定值,或參閱內部部署路由器說明文件以取得確切的設定值。

範例拓撲的參考資料

本文件中的範例拓撲使用下列 Google Cloud Platform 資源:

  • 專案 Sample Interconnect Project
  • 網路 my-network
  • 地區 us-east1

兩個專屬互連網路分別是 my-interconnect1my-interconnect2。這些互連網路已佈建,且狀態為 ready to use

僅第 3 層拓撲

在此拓撲中,一或多個 Cloud Interconnect 連線會在內部部署路由器終止,且路由器會使用雲端路由器執行 BGP 對等互連。

拓撲圖

下圖顯示實體和邏輯的僅第 3 層拓撲。

實體僅第 3 層拓撲範例 (按一下可放大)
實體內部部署僅第 3 層拓撲範例 (按一下可放大)
邏輯僅第 3 層拓撲範例 (按一下可放大)
邏輯內部部署僅第 3 層拓撲範例 (按一下可放大)

內部部署路由器設定

根據 GCP 專案範例中的設定,下表大致列出了用於拓撲範例的內部部署路由器設定。

如要瞭解 GCP 端使用的範例專案名稱、虛擬私人雲端網路和地區,請參閱拓撲參考資料

保留時間和保持運作計時器值可讓 Google 在發生問題時將流量快速轉移至備援連線。如下表所示設定這些值。

安全重新啟動可在雲端路由器維護期間防止 BGP 工作階段發生封包遺失,並避免路徑遭到取消。如果內部部署裝置支援 BGP 安全重新啟動功能,請啟用該功能,並如下表所示設定安全重新啟動和過時路徑計時器。

如要進一步瞭解 BGP 計時器設定,請參閱雲端路由器說明文件中的 BGP 計時器的建議值一文。

設定 my-interconnect1 my-interconnect2
Vlan 號碼 1010 1020
VLAN 介面 IP 位址 169.254.10.2/29 169.254.20.2/29
內部部署 ASN 64500 64500
雲端路由器 ASN 65200 65200
雲端路由器 BGP IP 位址 針對 cr1-us-east1:
169.254.10.1
針對 cr2-us-east1:
169.254.20.1
BGP 計時器 保持運作:20 秒 保持運作:20 秒
保留計時器:60 秒 保留計時器:60 秒
安全重新啟動:1 秒 安全重新啟動:1 秒
過時路徑計時器:300 秒 過時路徑計時器:300 秒
內部部署 LAN 子網路範圍 192.168.12.0/24 192.168.12.0/24

設定指南

設定「僅第 3 層」拓撲時,請遵循下列指南:

  • 連結雲端路由器的一或多個內部部署路由器通訊埠 (圖中的 0/0) 必須是通訊埠通道的一部分,即使只有一個通訊埠也是如此。
  • 通訊埠通道必須啟用 LACP,主動或被動模式均可。
  • 路由器介面 (圖中的 0/0) 的最大傳輸單位 (MTU) 應為 1440 個位元組。
  • 相鄰 EBGP 必須已設定多躍點。建議值為 4

裝置設定

VLAN 1010 路由器 (Cisco)

下列內容列出 VLAN 1010 中內部部署「Router1」(Cisco) 的僅第 3 層範例設定:

    interface E0/0
      description connected_to_google_edge_device
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 65200
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source Po2.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020 路由器 (Juniper)

下列內容列出 VLAN 1020 中內部部署「Router2」(Juniper) 的僅第 3 層範例設定:

    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description "connected_to_google_edge_device"

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
  

第 2/3 層拓撲

在此拓撲中,一或多個 GCP Cloud Interconnect 連線會在內部部署交換器終止,然後內部部署交換器會連線至內部部署路由器。路由器會使用雲端路由器執行 BGP 對等互連。

拓撲圖

下圖顯示實體和邏輯的第 2/3 層拓撲。

實體第 2/3 層拓撲範例 (按一下可放大)
實體第 2/3 層拓撲範例 (按一下可放大)
邏輯第 2/3 層拓撲範例 (按一下可放大)
邏輯第 2/3 層拓撲範例 (按一下可放大)

內部部署路由器設定

根據 GCP 專案範例中的設定,下表大致列出了用於拓撲範例的內部部署路由器設定。

如要瞭解 GCP 端使用的範例專案名稱、虛擬私人雲端網路和地區,請參閱拓撲參考資料

保留時間和保持運作計時器值可讓 Google 在發生問題時將流量快速轉移至備援連線。如下表所示設定這些值。

安全重新啟動可在雲端路由器維護期間防止 BGP 工作階段發生封包遺失,並避免路徑遭到取消。如果內部部署裝置支援 BGP 安全重新啟動功能,請啟用該功能,並如下表所示設定安全重新啟動和過時路徑計時器。

如要進一步瞭解 BGP 計時器設定,請參閱雲端路由器說明文件中的 BGP 計時器的建議值一文。

設定 my-interconnect1 my-interconnect2
Vlan 號碼 1010 1020
VLAN 介面 IP 位址 169.254.10.2/29 169.254.20.2/29
內部部署 ASN 64500 64500
雲端路由器 ASN 65200 65200
雲端路由器 BGP IP 位址 針對 cr1-us-east1:
169.254.10.1
針對 cr2-us-east1:
169.254.20.1
BGP 計時器 保持運作:20 秒 保持運作:20 秒
保留計時器:60 秒 保留計時器:60 秒
安全重新啟動:1 秒 安全重新啟動:1 秒
過時路徑計時器:300 秒 過時路徑計時器:300 秒
內部部署 LAN 子網路範圍 192.168.12.0/24 192.168.12.0/24

設定指南

設定第 2/3 層拓撲時,請遵循內部部署交換器和路由器的下列指南:

  • VLAN 必須在交換器上設定。
  • 連結至雲端路由器的一或多個交換器通訊埠 (如圖中所示的 1/1) 必須是通訊埠通道的一部分。
    • 通訊埠通道必須啟用 LACP,主動或被動模式均可。
    • 通訊埠通道必須在 802.1Q 主幹模式下設定,且必須允許所有 VLAN。
    • 通訊埠通道必須啟用8 802.1Q VLAN 標記。
  • 連結至內部部署路由器的交換器通訊埠 (如圖中所示的 1/2) 可以是主幹通訊埠或存取通訊埠。這包括路由器通訊埠專用於單一 VLAN 的情況。
  • 在交換器端啟用主幹模式時,內部部署路由器必須支援具有必要封裝的子介面 (dot1q 標記)。
  • 路由器介面 (圖中的 0/0) 的最大傳輸單位 (MTU) 應為 1440 個位元組。
  • 相鄰 EBGP 必須已設定多躍點。此設定的建議值為 4

裝置設定

VLAN 1010 (Cisco) 交換器

下列內容列出在 VLAN 1010 使用「Switch1」(Cisco) 的內部部署第 2/3 層拓撲的範例設定:

    vlan 1010
    name cloud_vlan1010

    interface E1/1
      description connected_to_google_edge_device
      Channel-group 1 mode active

    interface port-channel1
      description connected_to_google_edge_device
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010

    interface E1/2
      description connected_to_onprem_router
      channel-group 2 mode active

    interface port-channel2
      description connected_to_onprem_router
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010
  

VLAN 1010 (Cisco) 路由器

下列內容列出在 VLAN 1010 使用「Router1」(Cisco) 的內部部署第 2/3 層拓撲的範例設定:

    interface E0/0
      description connected_to_onprem_switch
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
      neighbor 169.254.10.1 description peering_to_cloud_router
      neighbor 169.254.10.1 remote-as 65200
      neighbor 169.254.10.1 ebgp-multihop 4
      neighbor 169.254.10.1 timers 20 60
      neighbor 169.254.10.1 update-source Po2.1010
      neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020 (Juniper) 交換器

下列內容列出在 VLAN 1020 使用「Switch2」(Juniper) 的內部部署第 2/3 層拓撲的範例設定:

set vlans cloud_vlan1020 vlan-id 1020

set interfaces xe-0/1/1 description "connected_to_google_edge_device"
set interfaces xe-0/1/1 ether-options 802.3ad ae1

set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 0 description "connected_to_google_edge_device"
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

set interfaces xe-0/1/2 description "connected_to_onprem_router"
set interfaces xe-0/1/2 ether-options 802.3ad ae2

set interfaces ae2 unit 0 description "connected_to_onprem_router"
set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020

VLAN 1020 (Juniper) 路由器

下列內容列出在 VLAN 1020 使用「Router2」(Juniper) 的內部部署第 2/3 層拓撲的範例設定:


set interfaces xe-0/0/0 ether-options 802.3ad ae1
set interfaces xe-0/0/0 description connected_to_onprem_switch

set interfaces ae1 description my-interconnect2
set interfaces ae1 flexible-vlan-tagging
set interfaces ae1 aggregated-ether-options minimum-links 1
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 1020 family inet mtu 1440
set interfaces ae1 unit 1020 vlan-id 1020
set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

set routing-options autonomous-system 64500

set policy-options prefix-list TO_GCP 192.168.12.0/24

set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

set protocols bgp group config_vlan_1020 type external
set protocols bgp group config_vlan_1020 multihop ttl 4
set protocols bgp group config_vlan_1020 local-address 169.254.20.2
set protocols bgp group config_vlan_1020 peer-as 65200
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1

最佳做法

使用 Cloud Interconnect 99.9% 和 99.99% 拓撲時,請按照下列最佳做法確保內部部署裝置與 GCP 的連線有效。

針對主動/主動轉送設定裝置

  • 確保在所有 BGP 工作階段之間交換相同的 MED 值。
  • 在 BGP 設定中啟用等價多路徑路由 (ECMP)
  • 在相同地區的多個雲端路由器之間啟用安全重新啟動功能或發佈互連網路連結。也就是說,確保升級程式碼時不會有兩個雲端路由器同時重新啟動。
  • 如果您設定了兩個內部部署裝置,請使用任何轉送通訊協定連接這兩個裝置。如果您將裝置設定為使用重新分配功能,請使用 IBGP 或 IGP。

針對主動/被動轉送設定裝置

  • 確保將較高的 MED 值套用至雲端路由器端和內部部署裝置端,以避免發生不對稱轉送。
  • 在相同地區的多個雲端路由器之間啟用安全重新啟動功能或發佈互連網路連結。也就是說,確保升級程式碼時不會有兩個雲端路由器同時重新啟動。
  • 如果您設定了兩個內部部署裝置,請確保兩個裝置的第 3 層互相連線。如果您將裝置設定為使用重新分配功能,請使用 IBGP 或 IGP。

後續步驟

檢查您的內部部署網路和 Google 虛擬私人雲端網路之間的 BGP 工作階段是否正常運作。詳情請參閱雲端路由器說明文件中的查看路由器狀態和公告路徑一文。

本頁內容對您是否有任何幫助?請提供意見:

傳送您對下列選項的寶貴意見...

這個網頁
互連網路