Lokale Router konfigurieren

Nachdem Sie einen VLAN-Anhang erstellt haben, müssen Sie Ihren lokalen Router konfigurieren, um eine BGP-Sitzung mit Ihrem Cloud-Router einzurichten. Um Ihren lokalen Router zu konfigurieren, verwenden Sie die vom VLAN-Anhang bereitgestellte VLAN-ID, IP-Adresse der Schnittstelle und Peering-IP-Adresse.

Dieses Dokument umfasst die folgenden Beispieltopologien und Konfigurationen, die Sie beim Konfigurieren Ihres lokalen Routers als Orientierungshilfe verwenden können.

  • Nur-Layer-3-Topologie (empfohlen): Dedicated Interconnect-Verbindungen, die auf einem lokalen Router enden (Nur-Layer-3-Topologie). Der Router führt BGP-Peering mit Cloud Router durch. Dies ist die empfohlene Konfiguration.
  • Layer-2/Layer-3-Topologie: Dedicated Interconnect-Verbindungen, die auf einem lokalen Switch enden, der mit einem lokalen Router verbunden ist. Der Router führt BGP-Peering mit Cloud Router durch.

Informationen zu Werten für einige Drittanbieter-Plattformen finden Sie in den anbieterspezifischen Hinweisen im VPN-Interoperabilitätsleitfaden. Spezifische Werte finden Sie auch in der Dokumentation zu den lokalen Routern.

Referenz für Beispieltopologien

Die Beispieltopologien in diesem Dokument verwenden die folgenden Google Cloud-Ressourcen:

  • Das Projekt Sample Interconnect Project
  • Das Netzwerk my-network
  • Die Region us-east1

Es gibt zwei Dedicated Interconnect-Verbindungen: my-interconnect1 und my-interconnect2. Diese Interconnect-Verbindungen wurden bereits bereitgestellt und haben den Status ready to use.

Nur-Layer-3-Topologie

Bei dieser Topologie enden die Cloud Interconnect-Verbindungen auf einem lokalen Router, der BGP-Peering mit Cloud Router durchführt.

Topologiediagramme

Die folgenden Diagramme zeigen sowohl die physische als auch die logische Nur-Layer-3-Topologie.

Beispiel für physische Nur-Layer-3-Topologie (zum Vergrößern klicken)
Beispiel für eine physische, lokale Nur-Layer-3-Topologie (zum Vergrößern klicken)
Beispiel für logische Nur-Layer-3-Topologie (zum Vergrößern klicken)
Beispiel für eine physische, lokale Nur-Layer-3-Topologie (zum Vergrößern klicken)

Einstellungen für lokale Router

Basierend auf der Konfiguration im Google Cloud-Beispielprojekt finden Sie in der folgenden Tabelle eine Übersicht über die Einstellungen des lokalen Routers, die für die Beispieltopologien verwendet werden sollen.

In der Topologiereferenz finden Sie den Beispielprojektnamen, das VPC-Netzwerk und die Region, die von der Google Cloud verwendet werden.

Die Werte für den Hold-Timer und den Keepalive-Timer ermöglichen es Google, im Falle eines Problems den Traffic schnell auf redundante Verbindungen umzuleiten. Legen Sie die Werte wie in der Tabelle angegeben fest.

Ein ordnungsgemäßer Neustart verhindert, dass bei einer Wartung des Cloud-Routers BGP-Sitzungen gelöscht und Routen unterbrochen werden. Wenn Ihr lokales Gerät einen ordnungsgemäßen BGP-Neustart unterstützt, aktivieren Sie diese Funktion und stellen Timer für einen ordnungsgemäßen Neustart und Stalepath-Timer ein, wie in der Tabelle beschrieben.

Weitere Informationen zu Einstellungen für BGP-Timer finden Sie in den empfohlenen Werten für BGP-Timer in der Dokumentation zu Cloud Router.

Einstellungen my-interconnect1 my-interconnect2
VLAN-Nummer 1010 1.020
IP-Adresse der VLAN-Schnittstelle 169.254.10.2/29 169.254.20.2/29
Lokales ASN 64500 64500
Cloud-Router-ASN 65200 65200
BGP-IP-Adresse für Cloud Router Für cr1-us-east1:
169.254.10.1
Für cr2-us-east1:
169.254.20.1
BGP-Timer Keepalive: 20 Sek. Keepalive: 20 Sek.
Hold-Timer: 60 Sek. Hold-Timer: 60 Sek.
Ordnungsgemäßer Neustart: 1 Sek. Ordnungsgemäßer Neustart: 1 Sek.
Stalepath-Timer: 300 Sek. Stalepath-Timer: 300 Sek.
Lokaler LAN-Subnetzbereich 192.168.12.0/24 192.168.12.0/24

Konfigurationsrichtlinien

Beachten Sie beim Konfigurieren der Nur-Layer-3-Topologie die folgenden Richtlinien:

  • Der lokale Routerport (0/0 im Diagramm) oder die Ports, die mit Cloud Router verbunden sind, müssen Teil eines Port-Channels sein, auch wenn es nur einen Port gibt.
  • Auf dem Port-Channel muss LACP entweder im aktiven oder im passiven Modus aktiviert sein.
  • Die maximale Übertragungseinheit (Maximum Transmission Unit, MTU) der Routerschnittstelle (0/0 im Diagramm) darf 1440 Byte nicht überschreiten.
  • Für den EBGP-Nachbarn muss Multihop konfiguriert sein. Der empfohlene Wert ist 4.

Gerätekonfiguration

VLAN 1010-Router (Cisco)

Die folgende Auflistung zeigt eine Nur-Layer-3-Beispielkonfiguration für den lokalen "Router1" (Cisco) im VLAN 1010:

    interface E0/0
      description connected_to_google_edge_device
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 65200
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source Po2.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020-Router (Juniper)

Die folgende Auflistung zeigt eine Nur-Layer-3-Beispielkonfiguration für den lokalen "Router2" (Juniper) im VLAN 1020:

    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description "connected_to_google_edge_device"

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
  

Layer-2/Layer-3-Topologie

Bei dieser Topologie enden die Cloud Interconnect-Verbindungen der Google Cloud auf einem lokalen Switch, der dann eine Verbindung zu einem lokalen Router herstellt. Der Router führt BGP-Peering mit Cloud Router durch.

Topologiediagramme

Die folgenden Diagramme zeigen die physische und logische Layer-2/Layer-3-Topologie.

Beispiel für physische Layer-2/Layer-3-Topologie (zum Vergrößern klicken)
Beispiel für physische Layer-2/Layer-3-Topologie (zum Vergrößern klicken)
Beispiel für logische Layer-2/Layer-3-Topologie (zum Vergrößern klicken)
Beispiel für physische Layer-2/Layer-3-Topologie (zum Vergrößern klicken)

Einstellungen für lokale Router

Basierend auf der Konfiguration im Google Cloud-Beispielprojekt finden Sie in der folgenden Tabelle eine Übersicht über die Einstellungen des lokalen Routers, die für die Beispieltopologien verwendet werden sollen.

In der Topologiereferenz finden Sie den Beispielprojektnamen, das VPC-Netzwerk und die Region, die von der Google Cloud verwendet werden.

Die Werte für den Hold-Timer und den Keepalive-Timer ermöglichen es Google, im Falle eines Problems den Traffic schnell auf redundante Verbindungen umzuleiten. Legen Sie die Werte wie in der Tabelle angegeben fest.

Ein ordnungsgemäßer Neustart verhindert, dass bei einer Wartung des Cloud-Routers BGP-Sitzungen gelöscht und Routen unterbrochen werden. Wenn Ihr lokales Gerät einen ordnungsgemäßen BGP-Neustart unterstützt, aktivieren Sie diese Funktion und stellen Timer für einen ordnungsgemäßen Neustart und Stalepath-Timer ein, wie in der Tabelle beschrieben.

Weitere Informationen zu Einstellungen für BGP-Timer finden Sie in den empfohlenen Werten für BGP-Timer in der Dokumentation zu Cloud Router.

Einstellungen my-interconnect1 my-interconnect2
VLAN-Nummer 1010 1.020
IP-Adresse der VLAN-Schnittstelle 169.254.10.2/29 169.254.20.2/29
Lokales ASN 64500 64500
Cloud-Router-ASN 65200 65200
BGP-IP-Adresse für Cloud Router Für cr1-us-east1:
169.254.10.1
Für cr2-us-east1:
169.254.20.1
BGP-Timer Keepalive: 20 Sek. Keepalive: 20 Sek.
Hold-Timer: 60 Sek. Hold-Timer: 60 Sek.
Ordnungsgemäßer Neustart: 1 Sek. Ordnungsgemäßer Neustart: 1 Sek.
Stalepath-Timer: 300 Sek. Stalepath-Timer: 300 Sek.
Lokaler LAN-Subnetzbereich 192.168.12.0/24 192.168.12.0/24

Konfigurationsrichtlinien

Beachten Sie beim Konfigurieren der Layer-2/Layer-3-Topologie die folgenden Richtlinien:

  • VLANs müssen auf dem Switch konfiguriert sein.
  • Der Switch-Port (1/1 wie in der Abbildung gezeigt) oder die zum Cloud-Router gerichteten Ports müssen Teil eines Port-Channels sein.
  • Auf dem Port-Channel muss LACP entweder im aktiven oder im passiven Modus aktiviert sein.
  • Der Port-Channel muss im 802.1Q-Trunk-Modus konfiguriert und alle VLANs müssen zugelassen sein.
  • Auf dem Port-Channel muss die 802.1Q-VLAN-Tag-Kennzeichnung aktiviert sein.
  • Der Switch-Port (1/2 wie in der Abbildung gezeigt), der mit dem lokalen Router verbunden ist, kann ein Trunk-Port oder ein Access-Port sein. Dies gilt für den Fall, dass ein Routerport einem einzelnen VLAN zugeordnet ist.
  • Wenn der Trunk-Modus für den Switch aktiviert wird, muss der lokale Router Subschnittstellen mit der erforderlichen Kapselung (dot1q-Tags) unterstützen.
  • Die maximale Übertragungseinheit (Maximum Transmission Unit, MTU) der Routerschnittstelle (0/0 im Diagramm) darf 1440 Byte nicht überschreiten.
  • Für den EBGP-Nachbarn muss Multihop konfiguriert sein. Der empfohlene Wert für diese Einstellung ist 4.
  • Gerätekonfiguration

    VLAN 1010-Switch (Cisco)

    Die folgende Auflistung zeigt eine Beispielkonfiguration für eine lokale Layer-2/Layer-3-Topologie unter Verwendung von "Switch1" (Cisco) im VLAN 1010:

        vlan 1010
        name cloud_vlan1010
    
        interface E1/1
          description connected_to_google_edge_device
          Channel-group 1 mode active
    
        interface port-channel1
          description connected_to_google_edge_device
          Switchport trunk encapsulation dot1q
          Switchport mode trunk
          Switchport trunk allowed vlan 1,1010
    
        interface E1/2
          description connected_to_onprem_router
          channel-group 2 mode active
    
        interface port-channel2
          description connected_to_onprem_router
          Switchport trunk encapsulation dot1q
          Switchport mode trunk
          Switchport trunk allowed vlan 1,1010
      

    VLAN 1010-Router (Cisco)

    Die folgende Auflistung zeigt eine Beispielkonfiguration für eine lokale Layer-2/Layer-3-Topologie unter Verwendung von "Router1" (Cisco) im VLAN 1010:

        interface E0/0
          description connected_to_onprem_switch
          channel-group 2 mode active
          no shut
    
        interface Po2
          description my-interconnect1
          no shut
    
        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440
    
        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24
    
        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP
    
        router bgp 64500
          bgp graceful-restart restart-time 1
          neighbor 169.254.10.1 description peering_to_cloud_router
          neighbor 169.254.10.1 remote-as 65200
          neighbor 169.254.10.1 ebgp-multihop 4
          neighbor 169.254.10.1 timers 20 60
          neighbor 169.254.10.1 update-source Po2.1010
          neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

    VLAN 1020-Switch (Juniper)

    Die folgende Auflistung zeigt eine Beispielkonfiguration für eine lokale Layer-2/Layer-3-Topologie unter Verwendung von "Switch2" (Juniper) im VLAN 1020:

    set vlans cloud_vlan1020 vlan-id 1020
    
    set interfaces xe-0/1/1 description "connected_to_google_edge_device"
    set interfaces xe-0/1/1 ether-options 802.3ad ae1
    
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 0 description "connected_to_google_edge_device"
    set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020
    
    set interfaces xe-0/1/2 description "connected_to_onprem_router"
    set interfaces xe-0/1/2 ether-options 802.3ad ae2
    
    set interfaces ae2 unit 0 description "connected_to_onprem_router"
    set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020
    

    VLAN 1020-Router (Juniper)

    Die folgende Auflistung zeigt eine Beispielkonfiguration für eine lokale Layer-2/Layer-3-Topologie unter Verwendung von "Router2" (Juniper) im VLAN 1020:

    
    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description connected_to_onprem_switch
    
    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29
    
    set routing-options autonomous-system 64500
    
    set policy-options prefix-list TO_GCP 192.168.12.0/24
    
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject
    
    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
    

    Best Practices

    Befolgen Sie diese Best Practices, um eine effektive Verbindung zur Google Cloud von Ihren lokalen Geräten aus zu ermöglichen, wenn Sie Cloud Interconnect-Topologien mit einer Verfügbarkeit von 99,9 % und 99,99 % verwenden.

    Geräte für Aktiv/Aktiv-Weiterleitung konfigurieren

    • Achten Sie darauf, dass in allen BGP-Sitzungen dieselben MED-Werte ausgetauscht werden.
    • Aktivieren Sie ECMP (Equal-Cost Multi-Path-Routing) in Ihrer BGP-Konfiguration.
    • Aktivieren Sie einen ordnungsgemäßen Neustart oder verteilen Sie Interconnect-Anhänge auf mehrere Cloud-Router in derselben Region. Sorgen Sie also dafür, dass für Code-Upgrades nicht zwei Cloud-Router gleichzeitig neu gestartet werden.
    • Wenn Sie zwei lokale Geräte konfigurieren, verbinden Sie beide Geräte mithilfe eines beliebigen Routingprotokolls miteinander. Wenn Sie Ihr Gerät für die Weiterverteilung konfigurieren, verwenden Sie entweder IBGP oder IGP.

    Geräte für Aktiv/Passiv-Weiterleitung konfigurieren

    • Achten Sie darauf, dass für den Cloud-Router und das lokale Gerät höhere MED-Werte angewendet werden, um asymmetrisches Routing zu vermeiden.
    • Aktivieren Sie einen ordnungsgemäßen Neustart oder verteilen Sie Interconnect-Anhänge auf mehrere Cloud-Router in derselben Region. Achten Sie auch darauf, dass nicht zwei Cloud-Router gleichzeitig für Code-Upgrades neu gestartet werden.
    • Wenn Sie zwei lokale Geräte konfigurieren, achten Sie darauf, dass beide Geräte über Ebene 3 miteinander verbunden sind. Wenn Sie das Gerät für die Weiterverteilung konfigurieren, verwenden Sie entweder IBGP oder IGP.

    Nächste Schritte

    Überprüfen Sie, ob die BGP-Sitzungen zwischen Ihrem lokalen Netzwerk und dem Google Virtual Private Cloud-Netzwerk funktionieren. Weitere Informationen finden Sie in der Dokumentation zu Cloud Router unter Routerstatus und angebotene Routen anzeigen.