オンプレミス ルーターの構成

VLAN アタッチメントを作成した後、オンプレミス ルーターを構成して、Cloud Router との BGP セッションを確立する必要があります。VLAN アタッチメントによって提供される VLAN ID、インターフェース IP アドレス、ピアリング IP アドレスを使用して、オンプレミス ルーターを構成します。

このドキュメントでは、オンプレミス ルーターを構成する際のガイドとして使用できる、次のサンプルのトポロジや構成について説明します。

  • レイヤ 3 のみのトポロジ(推奨): オンプレミス ルーターで終端する Dedicated Interconnect 接続(レイヤ 3 のみのトポロジ)。ルーターは、Cloud Router との BGP ピアリングを実行します。これが推奨される構成です。
  • レイヤ 2 / レイヤ 3 のトポロジ: オンプレミス ルーターに接続されたオンプレミス スイッチで終端する Dedicated Interconnect 接続。ルーターは、Cloud Router との BGP ピアリングを実行します。

オンプレミス ルーターに使用する可能性のある一部のサードパーティ プラットフォームの値については、VPN 相互運用ガイドベンダー固有の注意事項でも確認できます。また明確な値についてはオンプレミス ルーターのドキュメントをご覧ください。

サンプル トポロジのリファレンス

このドキュメントのサンプル トポロジでは、次の Google Cloud リソースを使用しています。

  • プロジェクト Sample Interconnect Project
  • ネットワーク my-network
  • リージョン us-east1

my-interconnect1my-interconnect2 という 2 つの Dedicated Interconnect があります。これらの相互接続はすでにプロビジョニングされており、ステータスは ready to use になっています。

レイヤ 3 のみのトポロジ

このトポロジでは、Cloud Interconnect 接続がオンプレミス ルーターで終端しています。オンプレミス ルーターは Cloud Router との BGP ピアリングを実行します。

トポロジ図

以下の図では、物理および論理の両方のレイヤ 3 のみのトポロジを示しています。

物理的なレイヤ 3 のみのトポロジのサンプル(クリックして拡大)
物理的なオンプレミスのレイヤ 3 のみのトポロジのサンプル(クリックして拡大)
論理的なレイヤ 3 のみのトポロジのサンプル(クリックして拡大)
論理的なオンプレミスのレイヤ 3 のみのトポロジのサンプル(クリックして拡大)

オンプレミス ルーターの設定

次の表は、サンプルの Google Cloud プロジェクトの構成に基づいて、トポロジ例に使用するオンプレミス ルーターの設定をまとめたものです。

Google Cloud 側で使用される、サンプルのプロジェクト名、VPC ネットワーク、リージョンについては、トポロジのリファレンスを参照してください。

ホールド タイマーと keep-alive タイマーの値により、問題発生時にトラフィックを冗長接続に迅速に転送できます。テーブルに示すように値を設定します。

グレースフル リスタートを使用すると、Cloud Router のメンテナンス中に BGP セッションのパケットのドロップやルートの取り消しを防げます。オンプレミスのデバイスが BGP グレースフル リスタートをサポートしている場合は、それを有効にして、表に示すようにグレースフル リスタート タイマーと stalepath タイマーを設定します。

BGP タイマー設定の詳細については、Cloud Router のドキュメントの BGP タイマーの推奨値を参照してください。

設定 my-interconnect1 my-interconnect2
VLAN 番号 1010 1020
VLAN インターフェースの IP アドレス 169.254.10.2/29 169.254.20.2/29
オンプレミスの ASN 64500 64500
Cloud Router の ASN 65200 65200
Cloud Router の BGP IP アドレス cr1-us-east1 の場合:
169.254.10.1
cr2-us-east1 の場合:
169.254.20.1
BGP タイマー keep-alive: 20 秒 keep-alive: 20 秒
ホールド タイマー: 60 秒 ホールド タイマー: 60 秒
グレースフル リスタート: 1 秒 グレースフル リスタート: 1 秒
stalepath タイマー: 300 秒 stalepath タイマー: 300 秒
オンプレミスの LAN サブネット範囲 192.168.12.0/24 192.168.12.0/24

構成のガイドライン

レイヤ 3 のみのトポロジを構成する場合は、次のガイドラインを参考にしてください。

  • Cloud Router に面しているオンプレミス ルーターのポート(図では 0/0)は、ポートが 1 つしかない場合でも、ポートチャネルの一部である必要があります。
  • ポートチャネルでは、アクティブ モードまたはパッシブモードで LACP を有効にする必要があります。
  • ルーター インターフェース(図では 0/0)の Maximum Transmission Unit(MTU)は 1,440 バイトです。
  • EBGP ネイバーにはマルチホップが構成されている必要があります。推奨値は 4 です。

デバイス構成

VLAN 1010 ルーター(Cisco)

次に、VLAN 1010 上のオンプレミス「Router1」(Cisco)のレイヤ 3 のみのサンプル構成を示します。

    interface E0/0
      description connected_to_google_edge_device
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 65200
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source Po2.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020 ルーター(Juniper)

次に、VLAN 1020 上のオンプレミス「Router2」(Juniper)のレイヤ 3 のみのサンプル構成を示します。

    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description "connected_to_google_edge_device"

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
  

レイヤ 2 / レイヤ 3 のトポロジ

このトポロジでは、Google Cloud の Cloud Interconnect 接続がオンプレミス スイッチで終端し、オンプレミス スイッチがオンプレミス ルーターに接続しています。ルーターは、Cloud Router との BGP ピアリングを実行します。

トポロジ図

以下の図は、物理的および論理的なレイヤ 2 / レイヤ 3 のトポロジを示しています。

物理的なレイヤ 2 / レイヤ 3 のトポロジのサンプル(クリックして拡大)
物理的なレイヤ 2 / レイヤ 3 のトポロジのサンプル(クリックして拡大)
論理的なレイヤ 2 / レイヤ 3 のトポロジのサンプル(クリックして拡大)
論理的なレイヤ 2 / レイヤ 3 のトポロジのサンプル(クリックして拡大)

オンプレミス ルーターの設定

次の表は、サンプルの Google Cloud プロジェクトの構成に基づいて、トポロジ例に使用するオンプレミス ルーターの設定をまとめたものです。

Google Cloud 側で使用される、サンプルのプロジェクト名、VPC ネットワーク、リージョンについては、トポロジのリファレンスを参照してください。

ホールド タイマーと keep-alive タイマーの値により、問題発生時にトラフィックを冗長接続に迅速に転送できます。テーブルに示すように値を設定します。

グレースフル リスタートを使用すると、Cloud Router のメンテナンス中に BGP セッションのパケットのドロップやルートの取り消しを防げます。オンプレミスのデバイスが BGP グレースフル リスタートをサポートしている場合は、それを有効にして、表に示すようにグレースフル リスタート タイマーと stalepath タイマーを設定します。

BGP タイマー設定の詳細については、Cloud Router のドキュメントの BGP タイマーの推奨値を参照してください。

設定 my-interconnect1 my-interconnect2
VLAN 番号 1010 1020
VLAN インターフェースの IP アドレス 169.254.10.2/29 169.254.20.2/29
オンプレミスの ASN 64500 64500
Cloud Router の ASN 65200 65200
Cloud Router の BGP IP アドレス cr1-us-east1 の場合:
169.254.10.1
cr2-us-east1 の場合:
169.254.20.1
BGP タイマー keep-alive: 20 秒 keep-alive: 20 秒
ホールド タイマー: 60 秒 ホールド タイマー: 60 秒
グレースフル リスタート: 1 秒 グレースフル リスタート: 1 秒
stalepath タイマー: 300 秒 stalepath タイマー: 300 秒
オンプレミスの LAN サブネット範囲 192.168.12.0/24 192.168.12.0/24

構成のガイドライン

レイヤ 2 / レイヤ 3 のトポロジを構成する場合は、オンプレミスのスイッチやルーターについて次のガイドラインを参考にしてください。

  • VLAN はスイッチで構成する必要があります。
  • Cloud Router に面しているスイッチポート(図に示す 1/1)は、ポートチャネルの一部である必要があります。
    • ポートチャネルでは、アクティブ モードまたはパッシブモードで LACP を有効にする必要があります。
    • ポートチャネルは 802.1Q トランクモードで構成し、すべての VLAN を許可する必要があります。
    • ポートチャネルでは、802.1Q VLAN タギングを有効にする必要があります。
  • オンプレミス ルーターに面しているスイッチポート(図に示す 1/2)は、トランクポートまたはアクセスポートにできます。これは、ルーターポートが単一の VLAN 専用である場合を対象としています。
  • スイッチ側でトランクモードを有効にする場合、オンプレミス ルーターは、必要なカプセル化(dot1q タグ)を持つサブインターフェースをサポートする必要があります。
  • ルーター インターフェース(図では 0/0)の Maximum Transmission Unit(MTU)は 1,440 バイトです。
  • EBGP ネイバーにはマルチホップが構成されている必要があります。この設定の推奨値は 4 です。

デバイス構成

VLAN 1010(Cisco)スイッチ

次に、VLAN 1010 で「Switch1」(Cisco)を使用する、オンプレミスのレイヤ 2 / レイヤ 3 のトポロジのサンプル構成を示します。

    vlan 1010
    name cloud_vlan1010

    interface E1/1
      description connected_to_google_edge_device
      Channel-group 1 mode active

    interface port-channel1
      description connected_to_google_edge_device
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010

    interface E1/2
      description connected_to_onprem_router
      channel-group 2 mode active

    interface port-channel2
      description connected_to_onprem_router
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010
  

VLAN 1010(Cisco)ルーター

次に、VLAN 1010 で「Router1」(Cisco)を使用する、オンプレミスのレイヤ 2 / レイヤ 3 のトポロジのサンプル構成を示します。

    interface E0/0
      description connected_to_onprem_switch
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
      neighbor 169.254.10.1 description peering_to_cloud_router
      neighbor 169.254.10.1 remote-as 65200
      neighbor 169.254.10.1 ebgp-multihop 4
      neighbor 169.254.10.1 timers 20 60
      neighbor 169.254.10.1 update-source Po2.1010
      neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020(Juniper)スイッチ

次に、VLAN 1020 で「Switch2」(Juniper)を使用する、オンプレミスのレイヤ 2 / レイヤ 3 のトポロジのサンプル構成を示します。

set vlans cloud_vlan1020 vlan-id 1020

set interfaces xe-0/1/1 description "connected_to_google_edge_device"
set interfaces xe-0/1/1 ether-options 802.3ad ae1

set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 0 description "connected_to_google_edge_device"
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

set interfaces xe-0/1/2 description "connected_to_onprem_router"
set interfaces xe-0/1/2 ether-options 802.3ad ae2

set interfaces ae2 unit 0 description "connected_to_onprem_router"
set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020

VLAN 1020(Juniper)ルーター

次に、VLAN 1020 で「Router2」(Juniper)を使用する、オンプレミスのレイヤ 2 / レイヤ 3 のトポロジのサンプル構成を示します。


set interfaces xe-0/0/0 ether-options 802.3ad ae1
set interfaces xe-0/0/0 description connected_to_onprem_switch

set interfaces ae1 description my-interconnect2
set interfaces ae1 flexible-vlan-tagging
set interfaces ae1 aggregated-ether-options minimum-links 1
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 1020 family inet mtu 1440
set interfaces ae1 unit 1020 vlan-id 1020
set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

set routing-options autonomous-system 64500

set policy-options prefix-list TO_GCP 192.168.12.0/24

set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

set protocols bgp group config_vlan_1020 type external
set protocols bgp group config_vlan_1020 multihop ttl 4
set protocols bgp group config_vlan_1020 local-address 169.254.20.2
set protocols bgp group config_vlan_1020 peer-as 65200
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1

おすすめの方法

Cloud Interconnect 99.9% と 99.99% トポロジの使用時に以下のおすすめの方法を実践することで、オンプレミスのデバイスから Google Cloud への効率的な接続を実現できます。

アクティブ / アクティブ転送用のデバイス構成

  • すべての BGP セッションで同じ MED 値が交換されるようにします。
  • BGP 構成で、等コスト マルチパス(ECMP)ルーティングを有効にします。
  • グレースフル リスタートを有効にするか、同一リージョン内にある複数の Cloud Router 間の相互接続のアタッチメントを配布します。この設定は、コードのアップグレードにあたり 2 つの Cloud Router が同時に再起動されることを防ぐものです。
  • 2 つのオンプレミス デバイスを構成する場合は、任意のルーティング プロトコルを使用して両方のデバイスを相互に接続します。再配布用にデバイスを構成する場合は、IBGP や IGP を使用します。

アクティブ転送とパッシブ転送に関するデバイス構成

  • 非対称ルーティングの発生を避けるため、Cloud Router 側とオンプレミス デバイス側により高い MED 値が適用されるようにします。
  • グレースフル リスタートを有効にするか、同一リージョン内にある複数の Cloud Router 間の相互接続のアタッチメントを配布します。この設定は、コードのアップグレードにあたり 2 つの Cloud Router が同時に再起動されることを防ぐものです。
  • 2 つのオンプレミス デバイスを構成する場合は、両方のデバイスがそれぞれ、レイヤ 3 接続に対応していることを確認してください。再配布用にデバイスを構成する場合は、IBGP や IGP を使用します。

次のステップ

オンプレミス ネットワークと Google の Virtual Private Cloud ネットワーク間で BGP セッションが機能していることを確認します。詳細については、Cloud Router のドキュメントにあるルーター ステータスとアドバタイズされたルートの表示をご覧ください。

このページは役立ちましたか?評価をお願いいたします。

フィードバックを送信...