Exigences

Cette page répertorie les exigences et les informations associées concernant l'API Cloud Healthcare.

Régions et versions

régions cloud

Seules les régions Google Cloud suivantes sont disponibles :

Zones régionales

Nom de la région Description de la région
Amérique du Nord
us-central1 Iowa, États-Unis
us-west2 Los Angeles, États-Unis
us-east4 Virginie du Nord, États-Unis
northamerica-northeast1 Montréal, Canada
Amérique du Sud
southamerica-east1 São Paulo, Brésil
Europe
europe-west2 Londres, Royaume-Uni
europe-west4 Pays-Bas
europe-west6 Zurich, Suisse
Asie
asia-east2 Hong Kong
asia-southeast1 Singapour
asia-northeast1 Tokyo, Japon
Australie
australia-southeast1 Sydney

Zones multirégionales

Nom de la zone multirégionale Description de la zone multirégionale
us Centres de données aux États-Unis

SDK Cloud

L'API Cloud Healthcare nécessite la version 236.0.0 ou une version ultérieure du SDK Cloud.

Caractères et taille autorisés

Les ressources de l'API Cloud Healthcare sont limitées à certains caractères et peuvent être limitées à certaines longueurs.

Le tableau suivant répertorie les caractères et les tailles autorisés pour chaque ressource :

Resource Limites
Ensembles de données et noms de magasins FHIR, DICOM et HL7v2
  • Caractères autorisés : toute chaîne composée de nombres Unicode, de lettres Unicode, de traits de soulignement ASCII, de tirets et de points
  • Longueur minimale : 1 caractère
  • Longueur maximale : 256 caractères
  • Conditions requises en tant qu'expression régulière : [\p{L}\p{N}_-.]{1,256}