Versions et mises à jour

Cette page décrit les versions compatibles avec Game Servers qui s'appuient sur Agones en Open Source et sur Kubernetes. Les dernières versions compatibles sont Agones 1.16 et Kubernetes 1.19.

Pour obtenir des conseils et connaître les bonnes pratiques, consultez la page Mettre à niveau Agones.

Rechercher les versions installées

Pour déterminer quelles versions d'Agones et Kubernetes sont installées sur un cluster Game Servers, utilisez les méthodes REST pour :répertorier les clusters ouafficher les détails d'un cluster unique ... Ces méthodes incluent view=full dans la requête, qui répertorie les versions installées dans la section des détails du cluster:

"clusterState": {
  "agonesVersionInstalled": "1.15.0",
  "kubernetesVersionInstalled": "1.18.20-gke.900",
  "installationState": "AGONES_KUBERNETES_VERSION_SUPPORTED",
  "provider": "gke"
}

Versions compatibles avec Agones et Kubernetes

Game Servers est régulièrement testé sur les quatre versions d'Agones les plus récentes. Inclut la compatibilité avec chaque nouvelle version d'Agones peu après sa sortie.

Bien que les versions antérieures d'Agones soient compatibles, elles ne sont pas entièrement testées. La compatibilité avec des versions antérieures n'est pas garantie. Pour obtenir de meilleurs résultats, effectuez une mise à jour.

Chaque version d'Agones est compatible avec une version spécifique de Kubernetes. Lorsqu'une nouvelle version d'Agones est compatible avec une nouvelle version de Kubernetes, elle est explicitement appelée dans les notes de version d'Agones.

Le tableau suivant répertorie les versions compatibles d'Agones et les versions Kubernetes correspondantes correspondantes pour Game Servers:

Version Agones Version de Kubernetes État
1.16 1.19 Compatible et testé régulièrement.
1.15 1.18 Compatible et testé régulièrement.
1.14 1.18 Compatible et testé régulièrement.
1.13 1.18 Compatible et testé régulièrement.
1.12 1.17 Compatible et testé régulièrement.