Migra entre versiones de Dialogflow

V2beta1 a V2

La API de V2beta1 se usa para compartir funciones Beta con los usuarios de Dialogflow. Esta sección contiene consejos para cambiar a la API V2 estable.

  • Si usas REST o RPC, actualiza el extremo de dialogflow.googleapis.com/v2beta1/... a dialogflow.googleapis.com/v2/...
  • Si usas una biblioteca cliente, debes actualizarla:
    • Lenguajes dinámicos (Python, Node.js y Ruby): actualiza el paquete, y el código usará de forma automática la última versión estable.
    • Lenguajes estáticos (Java, C#, PHP y Go): Instala el paquete nuevo y actualiza todas las declaraciones de importación a la referencia “v2” en lugar de “v2beta1”.
  • El campo que controla si el aprendizaje automático (AA) está habilitado para un Intent cambió. Se quitó el campo mlEnabled y se lo reemplazó por el campo mlDisabled; además, el AA está habilitado de forma predeterminada.
    Versión REST RPC Valor predeterminado Comportamiento predeterminado
    V2beta1 mlEnabled ml_enabled verdadero El AA está habilitado.
    V2 mlDisabled ml_disabled falso El AA está habilitado.