Getting Support

Cloud Dataflow SDK Deprecation Notice: The Cloud Dataflow SDK 2.5.0 is the last Cloud Dataflow SDK release that is separate from the Apache Beam SDK releases. The Cloud Dataflow service fully supports official Apache Beam SDK releases. The Cloud Dataflow service also supports previously released Apache Beam SDKs starting with version 2.0.0 and above.

Get a Google support package

Google Cloud Platform offers different support packages to meet different needs, such as 24/7 coverage, phone support, and access to a technical support manager. For more information, see GCP Support.

Get support for the Apache Beam SDK

To get help with Apache Beam, see the list of resources available on the Apache Beam site.

Support status for SDK releases

Apache Beam is an open source, community-led project. Google is part of the community, but we do not own the project or control the release process.

Google might open bugs or submit patches to the Apache Beam codebase on behalf of Cloud Dataflow customers. However, we cannot create hotfixes or official releases of Apache Beam on demand. See the Apache Beam website for more information about release policies.

Note: Development SDK versions (marked as -SNAPSHOT for Java and .dev for Python) are unsupported.

Java: SDK 2.x

Apache Beam SDKs

Cloud Dataflow supports specific Apache Beam SDK components for the SDK versions listed below. These components have been tested thoroughly with Cloud Dataflow. Experimental features are not supported.

SDK version(s) Status Supported components Details
2.7.0
2.6.0
2.5.0
Supported org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
org.apache.beam:beam-sdks-java-io-kafka
See the release notes for more information.
2.4.0
2.3.0
2.2.0
2.1.0
2.0.0
Supported org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
See the release notes for more information.

Cloud Dataflow SDKs

See the Cloud Dataflow SDK 2.x for Java release notes for change information.

SDK version(s) Status Details
2.5.0
2.4.0
2.3.0
2.2.0
2.1.0
Supported
2.0.0 Supported
2.0.0-beta3
2.0.0-beta2
2.0.0-beta1
Unsupported Unsupported as of February 28, 2018.

Python

Apache Beam SDKs

SDK version(s) Status Details
2.7.0
2.6.0
2.5.0
2.4.0
2.3.0
2.2.0
2.1.1
2.1.0
2.0.0
Supported See the release notes for more information.

Cloud Dataflow SDKs

See the Cloud Dataflow SDK 2.x for Python release notes for change information.

SDK version(s) Status Details
2.5.0
2.4.0
2.3.0
2.2.0
Supported
2.1.1 Supported Fixes a compatibility issue with the Python six package.
See the release notes for more information.
2.1.0 Supported Note that this release has a compatibility issue with the Python six 1.11.0 package.
See the Release Notes for more information.
2.0.0 Supported Note that this release has a compatibility issue with the Python six 1.11.0 package.
See the Release Notes for more information.
0.6.0
0.5.5
0.5.1
0.4.4
0.4.3
0.4.2
0.4.1
0.4.0
Unsupported Unsupported as of January 29, 2018.
0.2.7 and earlier versions Unsupported Unsupported as of March 23, 2017.

Java: SDK 1.x

See the Cloud Dataflow SDK 1.x for Java release notes for change information.

SDK version(s) Status Details
1.9.1
Unsupported Unsupported as of October 16, 2018.
1.9.0
Unsupported Unsupported as of October 16, 2018.
1.8.1
1.8.0
Unsupported Unsupported as of April 9, 2018.
1.7.0
Unsupported Unsupported as of March 12, 2018.
1.6.1 Unsupported Unsupported as of January 22, 2018.
1.6.0 Unsupported Unsupported as of January 22, 2018.
1.5.1
1.5.0
1.4.0
1.3.0
Unsupported Unsupported as of October 1, 2017.
1.2.1
1.2.0
1.1.0
1.0.0
Unsupported Unsupported as of February 26, 2017.
Pre-1.0.0 (including 0.4.* and 0.3.*) Unsupported

Get support from the community

Use the following resources to get help from the Cloud Dataflow community. Before submitting a question, check the Cloud Dataflow FAQ for answers to common questions about Cloud Dataflow.

Ask a question on Stack Overflow

Ask a question about Cloud Dataflow on Stack Overflow. Use the tag google-cloud-dataflow for questions about Cloud Dataflow. This tag not only receives responses from the Stack Overflow community, but also from Google engineers, who monitor the tag and offer unofficial support. For production issues (e.g., when you'd like a particular jobId to be looked at) please contact Google Cloud Platform Support.

Stay Informed About Cloud Dataflow

Join the dataflow-announce Google group to receive announcements and updates about Cloud Dataflow.

File bugs or feature requests

You can use the UserVoice forum to send us feedback on various issues, including:

If you're reporting a bug or defect with Cloud Dataflow, please include the following information with your request:

  • What steps will reproduce the problem?
  • What is the expected output? What do you see instead?
  • What version of the product are you using? On what operating system?
  • Please provide any additional information.
Was this page helpful? Let us know how we did:

Send feedback about...

Cloud Dataflow Documentation