Lista de versões do Cloud Composer

O Cloud Composer cria imagens do Docker que combinam versões básicas do Airflow com outros binários comuns e bibliotecas Python. A versão dessas imagens é controlada de acordo com cada versão de serviço do Cloud Composer.

Versões compatíveis do Cloud Composer

Novos ambientes

Na tabela a seguir, você encontra uma lista das versões do Apache Airflow e do Python compatíveis com o Cloud Composer na criação de novos ambientes.

A tabela também lista os pacotes PyPI pré-instalados, as correções com backport e as personalizações de cada versão.

Versão Versão do Airflow Versões compatíveis do Python Inclui pacotes PyPI Personalizações Data de lançamento Observações
composer-1.6.1-airflow-1.10.1 1.10.1 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 4 de abril de 2019
composer-1.6.1-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 4 de abril de 2019
composer-1.6.1-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 4 de abril de 2019 Versão padrão

Ambientes anteriores

Na tabela a seguir, você encontra uma lista das versões do Apache Airflow e do Python compatíveis com versões anteriores do Cloud Composer em ambientes atuais.

Versão Versão do Airflow Versões compatíveis do Python Inclui pacotes PyPI Personalizações Data de lançamento Observações
composer-1.6.0-airflow-1.10.1 1.10.1 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 3 de abril de 2019
composer-1.6.0-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 3 de abril de 2019
composer-1.6.0-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 3 de abril de 2019
composer-1.5.2-airflow-1.10.1 1.10.1 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 11 de março de 2019
composer-1.5.2-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 11 de março de 2019
composer-1.5.2-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 11 de março de 2019
composer-1.5.1-airflow-1.10.1 1.10.1 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 7 de março de 2019 Revertido em 11 de março de 2019
composer-1.5.1-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 7 de março de 2019 Revertido em 11 de março de 2019
composer-1.5.1-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 7 de março de 2019 Revertido em 11 de março de 2019
composer-1.5.0-airflow-1.10.1 1.10.1 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 6 de fevereiro de 2019
composer-1.5.0-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.5.0-airflow-1.9.0 Igual a composer-1.5.0-airflow-1.9.0 6 de fevereiro de 2019
composer-1.5.0-airflow-1.9.0 1.9.0 2, 3 click==6.7, redis==2.10.6, celery[redis], flower, google-api-python-client, google-cloud-bigquery, google-cloud-container, google-cloud-logging, google-cloud-storage, iso8601, kubernetes, protobuf, sendgrid, tensorflow e pipdeptree
- Dependências opcionais do Airflow: mysql, password, postgres, gcp_api e crypto
- Python 2: google-cloud-dataflow ≥ 2.5.0, tensorflow-transform
- Python 3: virtualenv
- Correções com backport de CVE-2018-20244: Stored XSS no Apache Airflow
- Correção com backport na conexão interrompida do GCP no DataflowJavaOperator e no DataflowPythonOperator
6 de fevereiro de 2019 Versão padrão
composer-1.4.2-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 Igual a composer-1.3.0-airflow-1.9.0 10 de janeiro de 2019
composer-1.4.2-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 Igual a composer-1.3.0-airflow-1.9.0 10 de janeiro de 2019
composer-1.4.1-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 Igual a composer-1.3.0-airflow-1.9.0 17 de dezembro de 2018
composer-1.4.1-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 Igual a composer-1.3.0-airflow-1.9.0 17 de dezembro de 2018
composer-1.4.0-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 Com base em composer-1.3.0-airflow-1.10.0, aplicar patch em googleapiclient set_user_agent 26 de novembro de 2018
composer-1.4.0-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 Igual a composer-1.3.0-airflow-1.9.0 26 de novembro de 2018
composer-1.3.0-airflow-1.10.0 1.10.0 2, 3 Igual a composer-1.3.0-airflow-1.9.0 - Ver nome de ambiente na IU da Web do Airflow
- Aplicar patch de esquema para fazer o Airflow 1.10.0 funcionar com o MySQL sem explicit_defaults_for_timestamp=ON
- Fazer backport de GKEPodOperator
- Fazer backport de várias melhorias em operadores relacionados do GCP
- Corrigir a estabilidade de BashTaskRunner
24 de outubro de 2018
composer-1.3.0-airflow-1.9.0 1.9.0 2, 3 urllib3==1.23, requests==2.19.1, celery[redis], flower, google-api-python-client, google-cloud-bigquery, google-cloud-container, google-cloud-logging, google-cloud-storage, iso8601, kubernetes, protobuf, sendgrid e tensorflow Com base em composer-1.2.0-airflow-1.9.0, ver nome de ambiente na IU da Web do Airflow 24 de outubro de 2018
composer-1.2.0-airflow-1.9.0 1.9.0 2, 3 Igual a composer-1.0.0-airflow-1.9.0 Igual a composer-1.1.1-airflow-1.9.0 2 de outubro de 2018 - Python 2.7.13 e 3.6.6
- Atualizar o comportamento de reinicialização do programador para se basear em tempo (10 minutos)
composer-1.1.1-airflow-1.9.0 1.9.0 2 Igual a composer-1.0.0-airflow-1.9.0 Com base em composer-1.1.0-airflow-1.9.0, configuração atenuada de simultaneidade do celeryd 17 de setembro de 2018
composer-1.1.0-airflow-1.9.0 1.9.0 2 Igual a composer-1.0.0-airflow-1.9.0 Com base em composer-1.0.0-airflow-1.9.0:
- Suporte às redes/sub-redes/tags com backport no DataprocClusterCreateOperator
- GkePodOperator com backport
- Correção de incompatibilidade de jobs do Dataflow com backport
17 de agosto de 2018 A verificação de integridade do programador do Airflow agora depende da ativação da geração de registros do Stackdriver
composer-1.0.0-airflow-1.9.0 1.9.0 2 google-cloud-bigquery, google-cloud-dataflow, google-cloud-storage, pandas, pandas-gbq, tensorflow, tensorflow-transform e sendgrid - KubernetesPodOperator com backport e correção da confirmação automática de JDBC/DBAPI
- Adição da origem do PARQUET a bigquery_hook
- Adição do suporte multirregional ao Dataflow
- Correção do link da documentação do Airflow no servidor da Web da ferramenta
- Correção de um loop de falhas no servidor da Web do Airflow causado pela exceção statsd

Versões incompatíveis do Cloud Composer

As versões do Cloud Dataproc a seguir não são compatíveis. O Cloud Composer não fornece atualizações e suporte para os ambientes criados com essas versões.

  • Versões Beta composer-0.*.*-airflow-*.*.*

É possível continuar executando um ambiente criado com uma versão incompatível. No entanto, recomendamos a migração dele para uma versão compatível.

Para mais informações sobre a suspensão de uso das versões, consulte Controle de versões do Cloud Composer.

Esta página foi útil? Conte sua opinião sobre:

Enviar comentários sobre…