Quickstart: Running a Kubernetes app with Cloud Code

This page shows you how to get started with Cloud Code.

In this quickstart, you'll set up a new Kubernetes application using a starter Hello World template, run your app on a cluster of your choosing, kickstart continuous rebuilding to iteratively develop your app, debug your running code, and sit back and view logs streaming from your live application.

Before you begin

If you'd like to use Google Cloud, you'll need to create or select a Google Cloud project and enable billing on your project.

Alternatively, you can use a cluster hosted on any other cloud platform or a local Kubernetes cluster with tools such as minikube and Docker Desktop.

Installing the plugin

To install the Cloud Code plugin:

  1. Install JetBrains IDE version 2020.3+ (such as IntelliJ Ultimate/Community, PyCharm Professional/Community, WebStorm, GoLand), if you haven't already.

  2. For all cloud platforms, ensure the Docker client (authenticated with your Docker registry) is installed on the PATH of your machine (its folder should be visible under a directory in your PATH). To check if you already have Docker installed, run docker -v.

    Cloud Code automatically installs and manages the following dependencies in your IDE: minikube, kubectl, Skaffold, and Cloud SDK.

  3. Open IntelliJ IDEA (or any supported JetBrains IDE).

  4. After your IDE opens, refresh this page.

  5. Install the Cloud Code plugin by clicking the following button:

  6. In the installation dialog that opens in your IDE, click OK to set up Cloud Code.

  7. If you're running Cloud Code on Apple M-series silicon, you're prompted to install Rosetta 2. This allows Cloud Code to install kubectl as a managed dependency.

    If you prefer not to install Rosetta 2, turn off managed dependencies (IntelliJ IDEA > Preferences > Tools > Cloud Code > Dependencies) and install your own ARM version of kubectl as described in Custom versions of dependencies.

Creating an application

To create a new application using an existing sample:

  1. In your IDE, open File > New Project and select Cloud Code: Kubernetes.

  2. Select a Hello World template from the list of starter applications. List of templates available: Python, Go, NodeJS, Java hello world and guestbook applications

  3. Pick a name for your project.

    After you click Finish, Cloud Code clones your chosen template and opens your newly created project for use.

    For Java templates, you're prompted to import required Maven projects to sync your pom.xml. Click Add as Maven project and then click Import Changes.

Choosing a cluster

In order to develop your application, you'll need an associated Kubernetes cluster (hosted either locally with minikube or using a cloud platform, like a Google Kubernetes Engine cluster).

Local cluster

If you don't already have a cluster to use for this quickstart, you can choose to run your application with a Cloud Code-managed local minikube cluster. Cloud Code starts a minikube cluster to run your application and stops the cluster when deployment stops. If a minikube cluster is already running, Cloud Code reuses the existing minikube cluster for deployment.

You can choose to use this Cloud Code-managed minikube cluster in the next step, developing your application, by setting it as your deployment preference.

Cloud platform-based cluster

If you already have a cluster configured to work with Kubernetes tools (like kubectl) that you can use for this quickstart, Cloud Code deploys to it automatically. You can move on to developing your application where you can confirm your preferred cluster is set as your current context.

If you don't, you can create one using your cloud platform-specific instructions. For GKE, you can follow the Creating a cluster guide.

Developing your application

To initiate development of your application on Kubernetes:

  1. If you're running on a cluster hosted on a cloud platform, ensure you have defined where your container images are stored for Develop on Kubernetes.

    If you're logged into Google Cloud in your IDE and you have a default project defined, Cloud Code automatically uses your default container image repository (gcr.io/{project_id} where {project_id} references your default project).

    Default image repository in run configuration being set with the 'gcr.io/' format and being presented autocomplete options based on current project and active cluster

  2. Ensure your preferred Kubernetes context is set. This can be specified in your Develop on Kubernetes configuration (accessible through Run > Edit Configurations... > Develop on Kubernetes), on the Run tab and in the Deployment preferences section.

    You can choose to deploy to a current context (default), locally to a minikube cluster, or to another available context.

    Selecting Kubernetes deployment context in a Cloud Code Kubernetes configuration

  3. Choose the Develop on Kubernetes run target from the Run/Debug configuration selector in the Navigation bar.

    This ensures any code changes to be automatically built, pushed, and deployed to a new version of your application.

    Kubernetes deployment run configurations

  4. To start the development cycle on your Kubernetes cluster, click the run action for Develop on Kubernetes.

    run action icon to start the development cycle on your Kubernetes cluster.

  5. In the output window, on the Logs tab, view incoming application logs.

    After the deployment has started, you'll see the list of forwarded ports for the deployed application.

  6. When the deployment is successful, you're notified that new service URLs are available. Click the Service URLs tab to view the URL(s), then click the URL link to open your browser with your running application.

    Viewing port-forwarded services in the Service URLs tab

    Alternatively, you can open the Event Log and then click the link to open your browser with your running application.

Debugging your application

To debug your application:

  1. Click the debug action run action icon for Develop on Kubernetes to start the development cycle in debug mode on your Kubernetes cluster.

    Starting the Kubernetes cluster development cycle in debug mode

  2. Cloud Code will attach a debug session. When successful, the Debug Tool window opens, confirming connection (on the Console tab).

    You can now debug against your live Kubernetes cluster.

  3. Click the gutter at the executable line of the code where you want to add a breakpoint.

    Red filled circles denote active breakpoints, while red-outlined hollow circles signify disabled breakpoints.

  4. When you send a new request to your application, it will pause at that desired line.

    Kubernetes debugger session

  5. To end the debugging session, click the stop icon on the Develop on Kubernetes run configuration.

Running your application

To run an application on Kubernetes:

  1. Ensure you have defined where your container images are stored for Run on Kubernetes.

    If you're logged into Google Cloud in your IDE and you have a default project defined, Cloud Code automatically uses your default container image repository (gcr.io/{project_id} where {project_id} references your default project).

  2. Ensure you're set up to deploy your app to your preferred Kubernetes context.

    Choose Edit Configurations from the Run/Debug configuration selector in the Navigation bar. On the Run tab of your Run on Kubernetes configuration, you can specify your deployment preference.

  3. Now that your application is ready for deployment, choose Run on Kubernetes from the Run/Debug configuration selector in the Navigation bar to deploy the application.

    Kubernetes deployment run configurations

  4. Click Run on Kubernetes run action icon.

  5. Like developing on Kubernetes, you can view incoming application logs in the output window on the Logs tab.

  6. When the deployment is successful, you're notified that new service URLs are available. Click the Service URLs tab to view the URL(s), then click the URL link to open your browser with your running application.

    Alternatively, you can open the Event Log and then click the link to open your browser with your running application, or visit http://localhost:{port-number} to access your newly deployed application!

    Application at http://localhost:{port-number} displaying 'Hello World!'

Viewing logs

In addition to seeing a live stream of the logs from running pods in the terminal output as you're developing and running your application, you can view logs from a specific pod by navigating to the Kubernetes Explorer.

To view logs from a specific pod, follow these steps:

  1. Navigate to the Kubernetes Explorer. It can be accessed either from the side panel on the right or using Tools > Cloud Code > Kubernetes > View Cluster Explorer.

    Kubernetes Explorer panel open using the tab on the right side taskbar

  2. Select the pod you'd like to see logs from.

  3. Right-click the pod and then select Stream Logs. Alternatively, you can stream logs for individual containers running in pods.

    This outputs logs to the Kubernetes Explorer Console.

    Streaming logs from a pod using its right-click menu to output logs into the Kubernetes Explorer Console

Cleaning up

To avoid incurring charges to your account for the resources used in this quickstart, be sure to delete the cluster and project you created.

If you're using Google Cloud and would like to delete your project (and associated resources, including any GKE clusters):

  1. Go to the Projects page in the Cloud Console:

    Go to the Projects page

  2. Select the project you created for this Quickstart and click the trash can icon next to delete it.

    This shuts down the project and schedules it for deletion.

What's next

Getting support

To submit feedback or report an issue in your IntelliJ IDE, go to Tools > Cloud Code > Help / About > Submit feedback or report an issue to report an issue on GitHub, or ask a question on Stack Overflow.

You can also join the #cloud-code channel, which is part of the Google Cloud Slack community.