Crea una app para el entorno flexible de App Engine

App Engine es una plataforma sin servidores completamente administrada para desarrollar y alojar aplicaciones web a gran escala.

En este documento, se describe cómo crear una aplicación (o importar un proyecto existente) para el entorno flexible de App Engine con Cloud Code.

Antes de comenzar

  • Instala y configura la versión 2019.3 o superior del IDE de JetBrains (IntelliJ Ultimate o Community) en el PATH de tu máquina.
  • Instala el complemento de Cloud Code:

    • Abre IntelliJ IDEA (o cualquier IDE de JetBrains admitido).
    • En el mercado de complementos (File > Settings > Plugins o, en Mac OS X, IntelliJ IDEA > Preferences > Complementos), busca el complemento “Cloud Code” y, luego, instálalo.

    Es posible que debas reiniciar el IDE para activar el complemento.

Crea una aplicación nueva

Para crear una aplicación nueva, puedes usar el asistente de proyectos nuevos o importar uno existente a Cloud Source Repositories.

Usa el asistente de proyectos nuevos

A fin de crear un proyecto nuevo, puedes usar el asistente de proyectos nuevos de IntelliJ para crear una aplicación de plantilla como el punto de inicio de tu propia aplicación.

Crea un proyecto nuevo de la siguiente manera:

  1. Elige Archivo > Nuevo > Proyecto para mostrar el diálogo New Project.

  2. Selecciona Java en el panel izquierdo.

  3. En la sección Additional Libraries and Frameworks (Bibliotecas y frameworks adicionales), marca la casilla Google App Engine para el entorno.

    Proyecto nuevo de Java con “Google App Engine Flexible” seleccionado en la sección Bibliotecas y frameworks adicionales

  4. Si es necesario, selecciona la casilla de verificación Create app.yaml (Crear app.yaml).

  5. Haz clic en Next (Siguiente).

  6. Ingresa un nombre de proyecto.

  7. Ingresa una ubicación del proyecto si no quieres conservar la predeterminada.

  8. Actualiza los campos de la sección Más opciones de configuración si deseas cambiar los valores predeterminados.

  9. Haz clic en Finalizar.

Descarga una copia de un proyecto existente

Puedes descargar una copia de tu proyecto existente en Cloud Source Repositories:

  1. Elige VCS > Obtener desde control de versiones....

  2. Selecciona Google Cloud en el menú desplegable Control de versión y haz clic en Clonar.
  3. En el cuadro de diálogo Clonar desde Google Cloud, selecciona el Proyecto de Cloud asociado a tu proyecto.
  4. Selecciona tu Cloud Repository.
  5. Selecciona el Parent Directory (Directorio superior).
  6. Ingresa el Directory Name (Nombre del directorio).
  7. Haz clic en Clone (Clonar).

Agrega compatibilidad con el marco de trabajo

Si nunca agregaste compatibilidad con el marco de trabajo a tu aplicación, IntelliJ IDEA te solicitará configurar este último cuando detecte que abriste una aplicación de App Engine.

  1. Haz clic derecho en el proyecto.

  2. Selecciona Agregar compatibilidad con el marco de trabajo.

  3. Selecciona la casilla de verificación Entorno flexible de App Engine.

    De manera alternativa, puedes agregar compatibilidad con el marco de trabajo de App Engine mediante el menú de Cloud Code:

    1. Selecciona Herramientas > Cloud Code > Agregar compatibilidad con App Engine > Flexible de Google App Engine.

    2. Selecciona el módulo al que deseas agregar compatibilidad con el marco de trabajo.

    3. Haz clic en Aceptar.

  4. Si es necesario, selecciona la casilla de verificación Crear app.yaml.

  5. Haz clic en Aceptar.

¿Qué sigue?

Ahora que creaste una aplicación, puedes implementarla en el entorno flexible de App Engine.

Obtén asistencia

Para enviar comentarios o informar un problema en tu IDE de IntelliJ, ve a Tools > Cloud Code > Help / About > . Envía comentarios o informa un problema para informar un error en GitHub o hacer una pregunta en Stack Overflow.

También puedes unirte al canal #cloud-code, que forma parte de la comunidad de Slack de Google Cloud.