Como visualizar dados do BigQuery usando o Data Studio

O BigQuery é um serviço de armazenamento de dados para análise em escala de petabyte. Ele é usado para executar consultas SQL em um grande volume de dados, praticamente em tempo real.

Com as ferramentas de visualização de dados, você compreende e analisa os dados do BigQuery com interatividade. Use essas ferramentas para identificar tendências, responder a elas e fazer previsões usando dados. Neste tutorial, você usa o Google Data Studio para visualizar dados na tabela de amostras de natalidade do BigQuery.

Objetivos

Neste tutorial, você:

  • faz conexão com uma fonte de dados do BigQuery;
  • cria relatórios e gráficos para visualizar dados do BigQuery.

Custos

Com o conector do BigQuery para o Google Data Studio, é possível acessar dados das tabelas do BigQuery de dentro do Google Data Studio. O BigQuery é um produto pago e gera custos de uso quando acessado pelo Google Data Studio. Você tem 1 TB por mês grátis para fazer consultas no BigQuery. Para mais informações, consulte a página Preços do BigQuery.

Antes de começar

Antes de começar este tutorial, use o Console do Google Cloud Platform para criar ou selecionar um projeto e ativar o faturamento.

  1. Faça login na sua Conta do Google.

    Se você ainda não tiver uma, inscreva-se.

  2. Selecione ou crie um projeto do Google Cloud Platform.

    Acessar a página Gerenciar recursos

  3. Verifique se o faturamento foi ativado no projeto do Google Cloud Platform.

    Saiba como ativar o faturamento

  4. O BigQuery é ativado automaticamente em novos projetos. Para ativá-lo em um projeto já existente, Ativar BigQuery API.

    Ativar a API

Criar relatórios e gráficos usando o Google Data Studio e o conector do BigQuery

Nesta seção do tutorial, use o Google Data Studio para visualizar dados do BigQuery por meio do conector apropriado. Crie uma fonte de dados, um relatório e gráficos para visualizar os dados da tabela de amostras de natalidade.

Criar uma fonte de dados

A primeira etapa na criação de um relatório no Google Data Studio é criar uma origem de dados para esse relatório. O relatório pode conter uma ou mais fontes de dados. Ao criar uma fonte de dados do BigQuery, o conector dele é utilizado no Google Data Studio.

Para adicionar uma fonte de dados do BigQuery a um relatório do Google Data Studio, é preciso ter as permissões apropriadas. Além disso, as mesmas permissões são aplicáveis aos conjuntos de dados do BigQuery e aos relatórios, gráficos e painéis criados no Google Data Studio. Quando um relatório é compartilhado, os componentes ficam visíveis apenas para os usuários com as permissões adequadas.

Para criar uma fonte de dados:

  1. Abra o Google Data Studio.

  2. Na página Relatórios, na seção Iniciar um novo relatório, clique no modelo Em branco. Isso cria um novo relatório sem título.

    Modelo em branco

  3. Se solicitado, defina as configurações de Preferências de marketing e de Conta e privacidade e clique em Salvar. Talvez seja necessário clicar novamente no modelo em branco depois de salvar as configurações.

  4. Na janela Adicione uma fonte de dados, clique em Criar nova fonte de dados.

    Adicionar fonte de dados

  5. Na seção Conectores do Google, passe o cursor sobre BigQuery e clique em Selecionar.

  6. Em Autorização, clique em Autorizar. Isso permite que o Google Data Studio acesse seu projeto do GCP.

  7. Na caixa de diálogo Solicitar permissão, clique em Permitir para que o Google Data Studio visualize dados no BigQuery. Se você tiver usado o Google Data Studio anteriormente, talvez não receba essa solicitação.

  8. Em Meus projetos, clique em Conjuntos de dados públicos.

  9. Em Projeto de faturamento, clique no nome do projeto do GCP que você criou anteriormente.

  10. Em Conjunto de dados público, clique em samples.

  11. Em Tabela, clique em natality.

    tabela natality

  12. No canto superior direito da janela, clique em Conectar. Depois que o Google Data Studio se conectar à fonte de dados do BigQuery, os campos da tabela serão exibidos. Use essa página para ajustar as propriedades do campo ou criar novos campos calculados.

  13. Na tabela natality, os campos year e source_year são armazenados como números inteiros. Para usar essas colunas como strings no Google Data Studio, altere o tipo delas para texto. À direita dos campos year e source_year, na coluna Tipo, clique em Número e escolha Texto na lista suspensa.

    Caixa de diálogo de campo

  14. Clique em Adicionar ao relatório.

    Adicionar ao relatório

  15. Quando solicitado, clique em Adicionar ao relatório.

  16. Na caixa de diálogo Solicitar permissão, clique em Permitir para que os arquivos do Google Drive possam ser vistos e gerenciados pelo Data Studio. Se você tiver usado o Google Data Studio anteriormente, talvez não receba essa solicitação.

Criar um gráfico de barras usando um campo calculado

Depois de adicionar a fonte de dados de natalidade ao relatório, o próximo passo é criar uma visualização. Comece criando um gráfico de barras. Nesse gráfico é exibido o número total de nascimentos de cada ano. Para exibir os nascimentos por ano, crie um campo calculado.

Para criar um gráfico de barras que exiba o total de nascimentos por ano:

  1. (Opcional) No topo da página, clique em Relatório sem título para alterar o nome do relatório. Por exemplo, digite BigQuery tutorial.

  2. Depois que o editor do relatório for carregado, clique em Inserir > Gráfico de barras.

  3. Usando a alça, coloque o gráfico no seu relatório.

  4. Na guia Dados, observe o valor da "Fonte de dados" (natality) e os valores padrão de "Dimensão" e "Métrica".

  5. Como você está mapeando o número de nascimentos por ano, a dimensão deve estar definida como source_year. Se source_year não for a dimensão padrão, clique e arraste source_year de Campos disponíveis para substituir a dimensão padrão.

  6. Na seção Métrica, clique em Adicionar métrica.

  7. No seletor de métricas, clique em Criar campo.

  8. Para exibir uma contagem do número de crianças nascidas a cada ano (por gênero), crie um campo calculado. Neste tutorial, você conta as entradas no campo is_male. O valor em is_male será true se a criança for do sexo masculino e false se ela for do sexo feminino. Na nova janela de métrica, em Nome, digite birth_count.

  9. Em Fórmula, digite COUNT(is_male).

  10. Clique em Aplicar.

  11. Clique na página do relatório para fechar o seletor de métricas.

  12. Depois de adicionar a métrica, passe o cursor sobre a métrica padrão e clique no ícone de exclusão no lado direito. A dimensão estará definida como source_year e a métrica estará definida como birth_count.

  13. Por padrão, o gráfico é classificado em ordem decrescente. Os anos com mais nascimentos são exibidos primeiro.

    Gráfico do total de nascimentos

  14. Para aprimorar o gráfico, altere os rótulos das barras. Na janela de propriedades do gráfico de barras, clique na guia Estilo.

  15. Na seção Gráfico de barras, marque Mostrar rótulos de dados.

    Mostrar marcadores

    O número total de nascimentos é exibido no topo de cada barra no gráfico.

  16. Classifique os dados por source_year em vez de birth_count. Na janela de propriedades do gráfico de barras, na seção Classificar da guia Dados:

    • Clique em Novo campo.
    • No seletor de classificação, role até Campos do gráfico e selecione source_year.
    • Clique fora da caixa de diálogo para fechar o seletor de classificação.
    • Clique em Decrescente e selecione Crescente. A tela passa a mostrar o número de nascimentos por ano, em ordem crescente.

    Nascimentos em ordem crescente

Filtrar o gráfico

Atualmente, o número total de crianças do sexo masculino e feminino nascidas a cada ano é exibido no gráfico de barras. Adicione um filtro para exibir apenas as crianças do sexo feminino nascidas a cada ano.

  1. Na janela de propriedades do gráfico de barras, clique na guia Dados.

  2. Na seção Filtros, clique em Adicionar um filtro.

  3. Na janela Criar filtro:

    • Em Nome, digite Female birth count.
    • Clique em Incluir e altere para Excluir.
    • Clique em Selecione um campo e escolha is_male.
    • Clique em Selecione uma condição e escolha Verdadeiro.
    • Clique em Salvar.

    Janela para criar filtro

Observe que o gráfico é atualizado para exibir apenas crianças do sexo feminino nascidas a cada ano. A legenda também não muda. O nome da legenda ainda reflete o nome da métrica: birth_count.

Gráfico filtrado

Criar um gráfico usando uma consulta personalizada

Ao criar um gráfico usando a opção "Consulta personalizada", você aproveita todos os recursos de consulta do BigQuery, como mesclagens, uniões e funções analíticas.

Outra opção para usar esses recursos completos é criando uma visualização, uma tabela virtual definida por uma consulta SQL. Consulte os dados dessa visualização, adicionando o conjunto de dados dela como fonte de dados. Para mais informações sobre visualizações, consulte Como usar visualizações.

Ao especificar uma consulta SQL como fonte de dados do BigQuery, os resultados são mostrados como uma tabela, que estabelece a definição dos campos (esquema) da fonte de dados. Ao usar uma consulta personalizada como uma fonte de dados, o SQL vira uma instrução SELECT interna do Google Data Studio para cada consulta feita no BigQuery. Para mais informações sobre consultas personalizadas no Google Data Studio, consulte a ajuda on-line.

Adicionar um gráfico de barras usando uma consulta personalizada

Para adicionar um gráfico de barras ao relatório que usa uma fonte de dados de consulta personalizada:

  1. Nas opções do menu, escolha Página > Nova página.

  2. Clique em Inserir > Gráfico de barras.

  3. Usando a alça, coloque o gráfico no relatório.

  4. Na janela de Propriedades do gráfico de barras, na guia Dados, observe que a Fonte de dados está definida como natality. Clique em natality para abrir a janela Selecione a fonte de dados.

  5. Clique em Criar nova fonte de dados.

  6. Na seção Conectores do Google, passe o cursor sobre BigQuery e clique em Selecionar.

  7. Em Meus projetos, clique em Consulta personalizada.

  8. Em Projeto, selecione o projeto do GCP.

  9. Digite a seguinte consulta SQL padrão na janela Insira a consulta personalizada:

    SELECT
     source_year,
     sum(case when is_male then 1 else 0 end) as male_births,
     sum(case when is_male then 0 else 1 end) as female_births
    FROM
     `bigquery-public-data.samples.natality`
    GROUP BY
     source_year
    ORDER BY
     source_year
    DESC
    

    Essa consulta usa a declaração CASE para avaliar o campo booleano is_male e determinar o número de nascimentos de cada sexo que ocorreram em um determinado ano.

  10. Em Opções de consulta, verifique se Usar o SQL legado está desmarcado. Isso permite usar a sintaxe do SQL padrão do BigQuery.

    Consulta personalizada

  11. Na parte superior da janela, clique em Fonte de dados sem título e altere o nome da fonte de dados para Male female case query.

  12. No canto superior direito da janela, clique em Conectar. Depois que o Google Data Studio se conectar à fonte de dados do BigQuery, os resultados da consulta serão usados para determinar o esquema da tabela.

  13. Quando o esquema for exibido, observe o tipo e agregação de cada campo. Por padrão, source_year é formatado como um número, e a agregação é definida como Nenhuma. À direita do campo source_year, na coluna Tipo, clique em Número e selecione Texto. Verifique se "Agregação" está definida como "Nenhum".

    Gráfico filtrado

  14. Clique em Adicionar ao relatório.

  15. Quando solicitado, clique em Adicionar ao relatório.

  16. Clique na seta para trás para fechar a janela "Selecione a fonte de dados".

  17. O Google Data Studio talvez não consiga determinar corretamente a métrica apropriada para o gráfico. Como você está criando um gráfico do número de nascimentos por gênero a cada ano, os valores da métrica precisam ser female_births e male_births. Na janela de propriedades do gráfico de barras, na guia Dados, seção Métrica, clique em Record Count.

  18. No Seletor de métricas, selecione female_births.

  19. Na seção Métrica, clique em Adicionar métrica.

  20. No seletor de métricas, selecione male_births. O gráfico agora exibe o número de crianças do sexo masculino e feminino que nasceram a cada ano em barras separadas.

    Gráfico filtrado

  21. O gráfico estará classificado por female_births em ordem decrescente. Altere essa configuração para source_year como você fez no gráfico anterior. Na seção Classificar, clique em female_births.

  22. No Seletor de classificação, escolha source_year. O gráfico agora mostra nascimentos por sexo a cada ano e em ordem decrescente.

  23. Para facilitar a leitura, altere os estilos do gráfico. Em Propriedades do gráfico de barras, clique na guia Estilo.

  24. Cada barra tem uma cor padrão com base na ordem em que as métricas foram adicionadas ao gráfico. Clique no segundo quadrado na paleta de cores e altere-o de vermelho para azul.

    Gráfico filtrado

  25. Clique no primeiro quadrado na paleta de cores e altere-o de azul para vermelho.

    O gráfico deve ficar assim:

    Gráfico de barras colorido

Ver o histórico da consulta

Para ver as consultas enviadas pelo conector do BigQuery, examine o histórico de consulta na interface da Web do BigQuery. Usando o histórico de consultas, estime os custos das consultas e salve-as para uso em outros cenários.

Para examinar o histórico da consulta:

Console

  1. Abra a IU da Web do BigQuery no Console do GCP.
    Acessar a IU da Web do BigQuery

  2. Clique em Histórico de consultas na navegação à esquerda.

  3. A lista de consultas mostra as entradas mais recentes primeiro. Clique em uma consulta para ver detalhes como código da tarefa e bytes processados.

IU clássica

  1. Acesse a IU da Web do BigQuery.

    Acessar a IU da Web do BigQuery

  2. Clique em Query History.

  3. A lista de consultas mostra as entradas mais recentes primeiro. Clique em Open Query para ver os detalhes da consulta, como o código da tarefa e bytes processados.

    Gráfico de barras colorido

Limpar

Para evitar cobranças dos recursos usados neste tutorial na conta do Google Cloud Platform:

  1. No Console do GCP, acesse a página Projetos.

    Acessar a página Projetos

  2. Na lista de projetos, selecione o projeto que você quer excluir e clique em Excluir delete.
  3. Na caixa de diálogo, digite o código do projeto e clique em Encerrar para excluí-lo.

A exclusão do projeto impede a consulta de dados pelo Google Data Studio porque a fonte de dados está associada ao projeto. Se não quiser excluir o projeto do Cloud Platform, exclua o relatório e a fonte de dados do Google Data Studio.

Para excluir os recursos do Google Data Studio:

  1. Abra o Google Data Studio.

  2. Na página Relatórios, à direita do relatório Tutorial do BigQuery, clique no botão "mais" (botão de mais opções) e selecione Remover.

  3. Clique em Fontes de dados.

  4. À direita da fonte de dados natality, clique no botão "mais" e escolha Remover.

  5. À direita da fonte de dados Male female case query, clique no botão "mais" e escolha Remover.

A seguir

  • Saiba mais sobre como escrever consultas no BigQuery. O tópico Como consultar dados, na documentação do BigQuery, explica como executar consultas, criar funções definidas pelo usuário (UDFs, na sigla em inglês) e muito mais.

  • Explore a sintaxe do BigQuery. O dialeto preferencial para consultas SQL no BigQuery é o SQL padrão, descrito na Referência do SQL. A sintaxe semelhante ao SQL legado do BigQuery é descrita na Referência de consulta (SQL legado).

Esta página foi útil? Conte sua opinião sobre:

Enviar comentários sobre…

Precisa de ajuda? Acesse nossa página de suporte.