Visualiza datos de BigQuery con Google Data Studio

BigQuery es un almacén de datos estadísticos a escala de petabytes que puedes usar para ejecutar consultas de SQL en grandes cantidades de datos casi en tiempo real.

Las herramientas de visualización de datos pueden ayudarte a comprender los datos de BigQuery y a analizarlos de forma interactiva. Puedes usar herramientas de visualización para que sea más simple identificar tendencias, responder a ellas y hacer predicciones con tus datos. En este instructivo, usarás Google Data Studio para visualizar datos en la tabla de muestra de natalidad de BigQuery.

Objetivos

En este instructivo, harás lo siguiente:

  • Te conectarás a la fuente de datos de BigQuery.
  • Crearás informes y gráficos para visualizar datos de BigQuery

Costos

El conector BigQuery de Data Studio te permite acceder a los datos de tus tablas de BigQuery dentro de Data Studio. BigQuery es un producto pago, por lo que incurrirás en costos de uso de BigQuery cuando accedas a BigQuery a través de Data Studio. El precio de consulta de BigQuery proporciona el primer 1 TB por mes de forma gratuita. Para obtener más información, consulta los precios de BigQuery.

Antes de comenzar

Antes de comenzar este instructivo, usa Google Cloud Platform Console para crear o seleccionar un proyecto y habilitar la facturación.

  1. Sign in to your Google Account.

    If you don't already have one, sign up for a new account.

  2. Select or create a Google Cloud Platform project.

    Go to the Manage resources page

  3. Comprueba que la facturación esté habilitada en tu proyecto.

    Descubre cómo puedes habilitar la facturación

  4. BigQuery se habilita de forma automática en proyectos nuevos. Para activar BigQuery en un proyecto preexistente, {% dynamic if "no_credentials" in setvar.task_params %} {% dynamic setvar credential_type %}NO_AUTH{% dynamic endsetvar %} {% dynamic if not setvar.redirect_url %} {% dynamic setvar redirect_url %}https://console.cloud.google.com{% dynamic endsetvar %} {% dynamic endif %}{% dynamic endif %} {% dynamic if setvar.in_henhouse_no_auth_whitelist %} {% dynamic if not setvar.credential_type %}{% dynamic setvar credential_type %}NO_AUTH{% dynamic endsetvar %} {% dynamic endif %} {% dynamic elif setvar.in_henhouse_service_account_whitelist %} {% dynamic if not setvar.credential_type %}{% dynamic setvar credential_type %}SERVICE_ACCOUNT{% dynamic endsetvar %} {% dynamic endif %}{% dynamic endif %} {% dynamic if not setvar.service_account_roles and setvar.credential_type == "SERVICE_ACCOUNT" %} {% dynamic setvar service_account_roles %} {% dynamic endsetvar %} {% dynamic endif %} {% dynamic setvar console %} {% dynamic if "no_steps" not in setvar.task_params %}
  5. {% dynamic endif %} {% dynamic if setvar.api_list %} {% dynamic if setvar.in_henhouse_no_auth_whitelist or setvar.in_henhouse_service_account_whitelist %} Configurar un proyecto de GCP Console.

    Configurar un proyecto

    Haz clic para realizar alguna de las siguientes acciones:

    • Crear o seleccionar un proyecto.
    • Habilitar las {% dynamic if setvar.api_names %}{% dynamic print setvar.api_names %}{% dynamic else %}{% dynamic endif %}{% dynamic if "," in setvar.api_list %} API{% dynamic elif "API" in setvar.api_names %}{% dynamic else %} API{% dynamic endif %} necesarias para el proyecto.
    • {% dynamic if setvar.credential_type == 'SERVICE_ACCOUNT' %}
    • Crear una cuenta de servicio.
    • Descargar una clave privada como JSON.
    • {% dynamic endif %}

    Puedes visualizar y administrar estos recursos en GCP Console en cualquier momento.

    {% dynamic else %}{% dynamic if "no_text" not in setvar.task_params %} Habilita las {% dynamic if setvar.api_names %}{% dynamic print setvar.api_names %}{% dynamic else %}{% dynamic endif %}{% dynamic if "," in setvar.api_list %} API{% dynamic elif "API" in setvar.api_names %}{% dynamic else %} API{% dynamic endif %} necesarias. {% dynamic endif %}

    Habilita las {% dynamic if "," in setvar.api_list %} API{% dynamic else %} API{% dynamic endif %}

    {% dynamic endif %}{% dynamic endif %}{% dynamic if "no_steps" not in setvar.task_params %}
  6. {% dynamic endif %}{% dynamic endsetvar %}{% dynamic print setvar.console %}

Crea informes y gráficos con Google Data Studio y el conector de BigQuery

En esta sección del instructivo, usas Google Data Studio para visualizar datos en BigQuery con el conector BigQuery. Crea una fuente de datos, un informe y gráficos que visualizan datos en la tabla de muestra de natalidad.

Crea una fuente de datos

El primer paso cuando creas un informe en Data Studio es crear una fuente de datos para el informe. Un informe puede contener una o más fuentes de datos. Cuando creas una fuente de datos de BigQuery, Data Studio usa el conector BigQuery.

Debes contar con los permisos adecuados para agregar una fuente de datos de BigQuery a un informe de Data Studio. Además, los permisos aplicados a los conjuntos de datos de BigQuery se aplicarán a los informes, gráficos y paneles que crees en Data Studio. Cuando se comparte un informe de Data Studio, solo los usuarios que tienen los permisos adecuados pueden ver los componentes del informe.

Para crear una fuente de datos, haz lo siguiente:

  1. Abre Google Data Studio.

  2. En la página Reports (Informes), en la sección Start a new report (Comenzar un informe nuevo), haz clic en la plantilla Blank (En blanco). Esto crea un informe nuevo sin título.

    Plantilla en blanco

  3. Si se te solicita, completa las Marketing Preferences (Preferencias de marketing) y la configuración de Account and Privacy (Cuenta y privacidad) y haz clic en Save (Guardar). Es posible que debas volver a hacer clic en la plantilla Blank después de guardar la configuración.

  4. En la ventana Add a data source (Agregar una fuente de datos), haz clic en Create new data source (Crear una fuente de datos nueva).

    Agregar fuente de datos

  5. En la sección Google Connectors (Conectores de Google), desplázate sobre BigQuery y, luego, haz clic en Select (Seleccionar).

  6. Para Authorization (Autorizaciones), haz clic en Authorize (Autorizar). Esto permite que Data Studio acceda a tu proyecto de GCP.

  7. En el cuadro de diálogo Request for permission (Solicitud de permiso), haz clic en Allow (Permitir) para que Data Studio pueda ver los datos en BigQuery. Es posible que no recibas este mensaje si usaste Data Studio antes.

  8. Para My Projects (Mis proyectos), haz clic en Public Datasets (Conjuntos de datos públicos).

  9. Para Billing Project (Proyecto de facturación), haz clic en el nombre del proyecto de GCP que creaste antes.

  10. Para Public Dataset (Conjunto de datos públicos), haz clic en samples (muestras).

  11. Para Table (Tabla), haz clic en natality.

    tabla de natalidad

  12. En la esquina superior derecha de la ventana, haz clic en Connect (Conectar). Una vez que Data Studio se conecta a la fuente de datos de BigQuery, se muestran los campos de la tabla. Puedes usar esta página para ajustar las propiedades del campo o crear nuevos campos calculados.

  13. En la tabla de natality, los campos year y source_year se almacenan como números enteros. Para usar estas columnas como strings en Data Studio, cambia el tipo de estas columnas a texto. A la derecha de los campos year y source_year, en la columna Type (Tipo), haz clic en Number (Número) y elige Text (Texto) en la lista desplegable.

    Diálogo de campo

  14. Haz clic en Add to report (Agregar al informe).

    Agregar al informe

  15. Cuando se te solicite, haz clic en Add to report.

  16. En el cuadro de diálogo Request for permission (Solicitud de permiso), haz clic en Allow para que Data Studio pueda ver y administrar archivos en Google Drive. Es posible que no recibas este mensaje si usaste Data Studio antes.

Crea un gráfico de barras con un campo calculado

Una vez que hayas agregado la fuente de datos natalidad al informe, el siguiente paso es crear una visualización. Crea un gráfico de barras para comenzar. El gráfico de barras muestra el número total de nacimientos para cada año. Para mostrar los nacimientos por año, crea un campo calculado.

Para crear un gráfico de barras que muestre el total de nacimientos por año, haz lo siguiente:

  1. (Opcional) En la parte superior de la página, haz clic en Untitled Report (Informe sin título) para cambiar el informe. Por ejemplo, escribe BigQuery tutorial.

  2. Después de que se cargue el editor de informes, haz clic en Insert > Bar chart (Insertar > Gráfico de barras).

  3. Con el controlador, dibuja un rectángulo en el informe para mostrar el gráfico.

  4. En la pestaña Data (Datos), observa el valor de Data Source (natality) (Fuente de datos: natality) y los valores predeterminados para Dimension (Dimensión) y Metric (Métrica).

  5. Debido a que estás registrando el número de nacimientos por año, debes establecer Dimension como source_year. En la lista Available Fields (Campos disponibles), haz clic y arrastra source_year al cuadro Add dimension here (Agregar dimensión aquí). El año de origen es el año de cuatro dígitos correspondiente al nacimiento del niño.

    Propiedades predeterminadas del gráfico

  6. Después de agregar la dimensión, desplaza el mouse sobre la dimensión predeterminada y haz clic en el ícono borrar en el lado derecho.

    Propiedades predeterminadas del gráfico

  7. En la sección Metric, haz clic en Add metric here (Agregar métrica aquí).

  8. En el Metric picker (Selector de métricas), haz clic en Create new metric (Crear métrica nueva).

  9. Para mostrar un recuento del número de niños nacidos cada año (por género), crea un campo calculado. Para este instructivo, cuenta las entradas en el campo is_male. El valor en is_male es true si el niño es de sexo masculino false si el niño es de sexo femenino. En la ventana de métrica nueva, para Name (Nombre), escribe birth_count.

  10. No hagas cambios en el ID de campo.

  11. Para Formula (Fórmula), escribe lo siguiente (o usa el asistente de fórmulas): COUNT(is_male).

  12. Haz clic en Save.

    Crear campo calculado

  13. Haz clic en Done (Listo).

  14. Haz clic en la flecha hacia atrás para cerrar el Metric picker.

  15. En la lista Available Fields (Campos disponibles), haz clic y arrastra birth_count al cuadro Add metric here.

  16. Después de agregar la métrica, desplaza el mouse sobre la métrica predeterminada y haz clic en el ícono borrar en el lado derecho. Se debe establecer Dimension en source_year y Metric en birth_count.

  17. Observa que el gráfico tiene un orden descendente de forma predeterminada. Los años con más nacimientos se muestran primero.

    Cuadro de nacimientos totales

  18. Para mejorar el gráfico, cambia las etiquetas de la barra. En la ventana de propiedades del gráfico de barras, haz clic en Style (Estilo).

  19. En la sección Bar chart (Gráfico de barras), haz clic en Show data labels (Mostrar etiquetas de datos).

    Mostrar etiquetas

    El número total de nacimientos se muestra en la parte superior de cada barra en la tabla.

  20. Ordena los datos por source_year en lugar de birth_count. En la ventana de propiedades del gráfico de barras, en la pestaña Data, en la sección Sort (Ordenar):

    • Haz clic en el campo existente (birth_count) para abrir el Sort picker (Seleccionador de ordenamiento).
    • En el Sort picker, selecciona source_year.
    • Haz clic en la flecha hacia atrás para cerrar el Sort picker.
    • Haz clic en Descending (Descendente) y selecciona Ascending (Ascendente). La pantalla cambia para mostrar el número de nacimientos por año en orden ascendente.

    Nacimientos en orden ascendente

Filtra el gráfico

En este momento, el gráfico de barras muestra el número total de niños y niñas nacidos cada año. Agrega un filtro para mostrar solo las niñas nacidas cada año.

  1. En la ventana de propiedades del gráfico de barras, haz clic en la pestaña Data.

  2. En la sección Filter (Filtro), haz clic en Add a filter (Agregar un filtro).

  3. En la ventana Create filter (Crear filtro):

    • Para Name, escribe Female birth count.
    • Haz clic en Include (Incluir) y cámbialo a Exclude (Excluir).
    • Haz clic en Select a field (Seleccionar un campo) y elige is_male.
    • Haz clic en Select a condition (Seleccionar una condición) y elige True (Verdadero).
    • Haz clic en Save.

    Crear ventana de filtro

Observa que la tabla se actualiza para mostrar solo las niñas nacidas cada año. Observa también que la leyenda no cambia. El nombre de la leyenda aún refleja el nombre de la métrica: birth_count.

Gráfico filtrado

Crea un gráfico con una consulta personalizada

Dado que Data Studio no permite agregaciones en las métricas, algunos componentes del informe son más fáciles de generar con una consulta de SQL personalizada. La opción de consulta personalizada también te permite aprovechar las funcionalidades completas de consulta de BigQuery, como las combinaciones, las uniones y las funciones analíticas.

De forma alternativa, puedes aprovechar las funcionalidades completas de consulta de BigQuery cuando creas una vista. Una vista es una tabla virtual definida por una consulta de SQL. Puedes consultar datos en una vista si agregas el conjunto de datos que contiene la vista como fuente de datos. Para obtener más información sobre las vistas, consulta Usa vistas.

Cuando especificas una consulta de SQL como tu fuente de datos de BigQuery, los resultados de la consulta están en formato de tabla, que se convierte en la definición de campo (esquema) para tu fuente de datos. Cuando usas una consulta personalizada como fuente de datos, Data Studio usa tu SQL como una instrucción de selección interna para cada consulta generada a BigQuery. Para obtener más información sobre consultas personalizadas en Data Studio, consulta la ayuda en línea.

Agrega un gráfico de barras con una consulta personalizada

Para agregar un gráfico de barras a tu informe que usa una fuente de datos de consulta personalizada, haz lo siguiente:

  1. Desde las opciones de menú Page > New Page (Página > Página nueva).

  2. Haz clic en Insert > Bar chart (Insertar > Gráfico de barras).

  3. Con el controlador, dibuja un rectángulo en el informe para mostrar el gráfico.

  4. En la ventana Bar chart properties (Propiedades del gráfico de barras), en la pestaña Data, observa que Data Source está configurada como natality. Haz clic en natality para abrir la ventana Select Data Source (Seleccionar fuente de datos).

  5. Haz clic en Create new data source.

  6. En la sección Google Connectors, desplaza el mouse sobre BigQuery y haz clic en Select.

  7. Para My Projects, haz clic en Custom query (Consulta personalizada).

  8. Para Project (Proyecto), selecciona tu proyecto de GCP.

  9. Ingresa la siguiente consulta de SQL estándar en la ventana Enter custom query (Ingresar consulta personalizada):

    SELECT
     source_year,
     sum(case when is_male then 1 else 0 end) as male_births,
     sum(case when is_male then 0 else 1 end) as female_births
    FROM
     `bigquery-public-data.samples.natality`
    GROUP BY
     source_year
    ORDER BY
     source_year
    DESC
    

    Esta consulta usa una declaración CASE para evaluar el campo booleano is_male a fin de determinar cuántos nacimientos fueron femeninos y cuántos fueron masculinos para un año determinado.

  10. En Query Options (Opciones de consulta), deselecciona Use Legacy SQL (Usar SQL heredado). Esto te permite usar una sintaxis SQL estándar de BigQuery.

    Consulta personalizada

  11. En la parte superior de la ventana, haz clic en Untitled data source (Fuente de datos sin título), cambia el nombre de la fuente a Male female case query.

  12. En la esquina superior derecha de la ventana, haz clic en Connect. Después de que Data Studio se conecta a la fuente de datos de BigQuery, los resultados de la consulta se usan para determinar el esquema de la tabla.

  13. Cuando se muestra el esquema, observa el tipo y la agregación para cada campo. De forma predeterminada, source_year está formateado como Number y Aggregation se establece en None (Ninguno). A la derecha del campo source_year, en la columna Type, haz clic en Number y selecciona Text. Verifica que Aggregation está configurada en None.

    Gráfico filtrado

  14. Haz clic en Add to report.

  15. Cuando se te solicite, haz clic en Add to report.

  16. Haz clic en la flecha hacia atrás para cerrar la ventana Select Data Source.

  17. Es posible que Data Studio no pueda determinar correctamente la métrica adecuada para el gráfico. Debido a que estás registrando el número de nacimientos de niños y niñas por año, los valores de métrica deben ser female_births y male_births. En la ventana de propiedades del gráfico de barras, en la pestaña Data, en la sección Metric, haz clic en Record Count (Recuento de registros).

  18. En el Metric picker, selecciona female_births.

  19. Haz clic en la flecha hacia atrás para cerrar el Metric picker.

  20. En la sección Metric, haz clic en Add metric here.

  21. En el Metric picker, selecciona male_births.

  22. Haz clic en la flecha hacia atrás para cerrar el Metric picker. Tu cuadro ahora muestra el número de niños y niñas nacidos cada año con barras separadas.

    Gráfico filtrado

  23. El gráfico debe estar ordenado por female_births en orden descendente. Cambia esto a source_year como lo hiciste en el gráfico anterior. En la sección Sort, haz clic en female_births.

  24. En el Sort picker, elige source_year.

  25. Haz clic en la flecha hacia atrás para cerrar el Sort picker. La tabla ahora muestra los nacimientos femeninos y masculinos cada año en orden descendente.

  26. Para mayor legibilidad, cambia los estilos de gráfico. En Bar chart properties, haz clic en la pestaña Style.

  27. Ten en cuenta que cada barra tiene un color predeterminado según el orden en que se agregaron las métricas al gráfico. Haz clic en el segundo cuadrado de la paleta de colores y cámbialo de rojo a azul.

    Gráfico filtrado

  28. Haz clic en el primer cuadrado de la paleta de colores y cámbialo de azul a rojo.

    El gráfico debería tener el siguiente aspecto:

    Gráfico de barras de color

Observa tu historial de consultas

Puedes visualizar las consultas enviadas a través del conector de BigQuery desde el historial de consultas en la interfaz web de BigQuery. Con el historial de consultas, puedes estimar los costos de las consultas y puedes guardarlas para usarlas en otras situaciones.

Para examinar tu historial de consultas, haz lo siguiente:

  1. Dirígete a la IU web de BigQuery.

    Ir a la IU web de BigQuery

  2. Haz clic en Query History (Historial de consultas).

  3. La lista de consultas se muestra con las consultas más recientes primero. Haz clic en Open Query (Abrir consulta) para ver los detalles de la consulta, como el ID del trabajo y los bytes procesados.

    Gráfico de barras de color

Limpieza

Sigue estos pasos para evitar que se apliquen cargos a tu cuenta de Google Cloud Platform por los recursos que usaste en este instructivo:

  1. In the GCP Console, go to the Projects page.

    Go to the Projects page

  2. In the project list, select the project you want to delete and click Delete delete.
  3. In the dialog, type the project ID, and then click Shut down to delete the project.

Borrar tu proyecto evita que Data Studio consulte los datos, porque la fuente de datos está asociada con tu proyecto. Si no deseas borrar tu proyecto de Cloud Platform, puedes borrar el informe de Data Studio y la fuente de datos.

Para borrar los recursos de Data Studio, haz lo siguiente:

  1. Abre Google Data Studio.

  2. En la página Reports, a la derecha del informe del instructivo de BigQuery, haz clic en el botón “más” botón más y elige Remove (Quitar).

  3. Haz clic en Data Sources.

  4. A la derecha de la fuente de datos de natalidad, haz clic en el botón “más” y elige Remove.

  5. A la derecha de la fuente de datos de consulta de casos femeninos y masculinos, haz clic en el botón “más” y elige Remove.

Pasos siguientes

  • Obtén más información sobre escribir consultas para BigQuery: consulta datos en la documentación de BigQuery explica cómo ejecutar consultas, crear funciones definidas por el usuario (UDF) y más.

  • Explora la sintaxis de BigQuery: el dialecto preferido para consultas de SQL en BigQuery. BigQuery es SQL estándar, que se describe en la Referencia de SQL. La sintaxis similar a SQL heredado de BigQuery se describe en la Referencia de consulta (SQL heredado).

¿Te ha resultado útil esta página? Enviar comentarios:

Enviar comentarios sobre...