Guía de inicio rápido para usar Data Studio

BigQuery BI Engine te permite realizar servicios de análisis rápidos y de baja latencia, y análisis interactivos con informes y paneles respaldados por BigQuery.

Este instructivo introductorio está dirigido a los analistas de datos y los analistas de negocios que usan Google Data Studio para compilar informes y paneles.

Objetivos

En este instructivo, realizarás lo siguiente:

  • Crea una reserva de capacidad de BI Engine con la Consola del administrador de BigQuery
  • Use Data Studio para conectarse a una tabla de BigQuery administrada por BI Engine.
  • Crea un panel de Data Studio que consulte la tabla administrada por BI Engine.

Costos

En este instructivo, se usan los siguientes componentes facturables de Google Cloud:

  • BI Engine: se generan costos por la reserva que creas en BI Engine.
  • BigQuery: se generan costos de almacenamiento de la tabla que creas en BigQuery.

Para generar una estimación de costos en función del uso previsto, usa la calculadora de precios. Es posible que los usuarios nuevos de Google Cloud califiquen para obtener una prueba gratuita.

Para obtener más información sobre los precios de BI Engine, consulta la página Precios.

Para obtener más información sobre los precios de almacenamiento de BigQuery, consulta Precios de almacenamiento en la documentación de BigQuery.

Antes de comenzar

Antes de comenzar, asegúrate de tener un proyecto a fin de usar y de haber habilitado la facturación para ese proyecto y la API de BigQuery.

  1. Accede a tu cuenta de Google Cloud. Si eres nuevo en Google Cloud, crea una cuenta para evaluar el rendimiento de nuestros productos en situaciones reales. Los clientes nuevos también obtienen $300 en créditos gratuitos para ejecutar, probar y, además, implementar cargas de trabajo.
  2. En la página del selector de proyectos de Google Cloud Console, selecciona o crea un proyecto de Google Cloud.

    Ir al selector de proyectos

  3. Asegúrate de que la facturación esté habilitada para tu proyecto de Cloud. Descubre cómo confirmar que tienes habilitada la facturación en un proyecto.

  4. En la página del selector de proyectos de Google Cloud Console, selecciona o crea un proyecto de Google Cloud.

    Ir al selector de proyectos

  5. Asegúrate de que la facturación esté habilitada para tu proyecto de Cloud. Descubre cómo confirmar que tienes habilitada la facturación en un proyecto.

  6. La API de BigQuery se habilita de forma automática en proyectos nuevos. Para activar la API de BigQuery en un proyecto existente, ve a Habilita la API BigQuery.

    Habilita la API

Cree un conjunto de datos de BigQuery

El primer paso es crear un conjunto de datos de BI Engine para almacenar la tabla administrada por BI Engine. Para crear tu conjunto de datos, sigue estos pasos:

  1. En Cloud Console, ve a la página de BigQuery.

    Ir a BigQuery

  2. En el panel de navegación, en el panel Explorador, haz clic en el nombre de tu proyecto.

  3. En el panel de detalles, haz clic en Crear conjunto de datos.

  4. En la página Crear conjunto de datos, haz lo siguiente:

    • En ID del conjunto de datos, ingresa biengine_tutorial.
    • En Ubicación de los datos, elija Estados Unidos (EE.UU.). Los conjuntos de datos públicos se almacenan en la ubicación multirregión de US. Para que sea más simple, te recomendamos que coloques el conjunto de datos en la misma ubicación.

      Crear página de conjunto de datos

  5. Utilice los valores predeterminados para el resto de la configuración y haga clic en Crear conjunto de datos.

Copiar los datos de un conjunto de datos públicos para crear una tabla

Este instructivo utiliza un conjunto de datos disponible a través del Programa de conjuntos de datos públicos de Google Cloud. Los conjuntos de datos públicos son conjuntos que aloja BI Engine para que puedas acceder a ellos y, también, integrarlos en tus aplicaciones.

En esta sección, creará una tabla copiando datos del conjunto de datos solicitudes de servicio de San Francisco 311. Puedes explorar el conjunto de datos con Cloud Console.

Cree la tabla

Para crear la tabla, sigue estos pasos:

  1. En Cloud Console, abre el conjunto de datos de SF 311.

    Ir al conjunto de datos de SF 311

  2. En el panel de navegación, expande san_francisco_311 y haz clic en la tabla 311_service_requests.

  3. Haz clic en Copiar tabla.

  4. En la sección Destino (Destination) del cuadro de diálogo Copiar tabla (Copy table), haz lo siguiente:

    • En Nombre del proyecto, elige tu proyecto.
    • En Nombre del conjunto de datos, verifica que biengine_tutorial esté seleccionado.
    • En Nombre de la tabla, ingresa 311_service_requests_copy.

      Copia la tabla SF 311

    • Haz clic en Copiar.

  5. Cuando se completa el trabajo de copia, puedes verificar el contenido de la tabla expandiendo PROJECT_NAME > biengine_tutorial y haciendo clic en 311_service_requests_copy > Vista previa.

Crea tu reserva de BI Engine

  1. En la Consola del administrador de BigQuery, ve a la página BI Engine.

    Ir a la Consola del administrador de BigQuery

  2. Haz clic en Crear reserva.

  3. En la página Crear reserva, para el Paso 1 haga lo siguiente:

    • Verifica el nombre del proyecto.
    • Elige tu ubicación. La ubicación debe coincidir con la ubicación de los conjuntos de datos que consultas.
    • Ajusta el control deslizante a la cantidad de capacidad de memoria que reserves. En el siguiente ejemplo, se establece la capacidad en 2 GB. El máximo actual es de 100 GB.

      Ubicación de la capacidad BI Engine

  4. Haga clic en Next.

  5. Para el Paso 2, revise los detalles de su reserva y luego haga clic en Siguiente.

  6. Para el Paso 3, revise el acuerdo y luego haga clic en Crear.

  7. Después de confirmar tu reserva, los detalles se muestran en la página Reservas.

    Reserva confirmada

Crea una conexión de fuente de datos en Data Studio

Antes de crear un informe en Google Data Studio, debes crear una fuente de datos para el informe. Un informe puede contener una o más fuentes de datos. Google Data Studio usa el conector de BigQuery para conectarse a una tabla de BigQuery administrada por BI Engine.

Cuando defines tu conexión de fuente de datos en Data Studio, BI Engine usa la tabla y las columnas que configuras para determinar qué datos almacenar en caché. BI Engine solo almacena en caché las columnas que agregas al informe.

Permisos necesarios

Debes tener los permisos adecuados para agregar una fuente de datos de BigQuery a un informe de Google Data Studio. Además, los permisos usados en los conjuntos de datos de BigQuery se aplicarán a los informes, gráficos y paneles que crees en Google Data Studio. Cuando se comparte un informe de Google Data Studio, solo los usuarios que tienen los permisos adecuados pueden ver los componentes del informe.

La ejecución de un trabajo de consulta que se usa para propagar un informe requiere permisos bigquery.jobs.create. Para que el trabajo de consulta se complete con éxito, el usuario o grupo deben tener acceso al conjunto de datos que contiene las tablas a las que hace referencia la consulta. El nivel de acceso mínimo necesario es Puede ver, que se asigna a la función bigquery.dataViewer para ese conjunto de datos.

Debido a que creaste el conjunto de datos que se usa en este instructivo, se te otorga acceso de propietario al conjunto de datos, que te brinda control total sobre él. Además, como creaste el proyecto que se usa en este instructivo, tienes acceso de propietario a nivel de proyecto. El acceso de propietario te permite ejecutar trabajos en el proyecto.

Detalles de permisos

Puede establecer permisos bigquery.jobs.create a nivel de proyecto al otorgar cualquiera de las siguientes funciones de IAM predefinidas:

  • bigquery.user
  • bigquery.jobUser
  • bigquery.admin

Si otorgas a un usuario o grupo la función bigquery.user a nivel del proyecto, de forma predeterminada, no se otorga acceso a ninguno de los conjuntos de datos, tablas o vistas en el proyecto. bigquery.user brinda a los usuarios la capacidad de crear sus propios conjuntos de datos y de ejecutar trabajos de consulta en conjuntos de datos a los que se les dio acceso. Si asignas la función bigquery.user o bigquery.jobUser, también debes asignar controles de acceso a cada conjunto de datos al que el usuario o grupo necesite acceder. t creado por el usuario.

Cuando otorgas acceso a un conjunto de datos, hay 3 opciones:

El acceso mínimo necesario para que un usuario ejecute una consulta es Puede ver.

Para obtener más información sobre las funciones de IAM en BigQuery, consulte Control de acceso en la documentación de BigQuery.

Para obtener más información sobre cómo proteger los conjuntos de datos en BigQuery, consulta Controla el acceso a un conjunto de datos en la documentación de BigQuery.

Cree su fuente de datos

Para crear su fuente de datos, haga lo siguiente:

  1. Abre Google Data Studio.

  2. En la página Informes (Reports), en la sección Comenzar un informe nuevo (Start a new report), haz clic en la plantilla En blanco (Blank). Esto crea un informe nuevo sin título.

    Plantilla en blanco

  3. Si se te solicita, completa las Preferencias de marketing (Marketing Preferences) y la configuración de Cuenta y privacidad (Account and Privacy) y haz clic en Guardar (Save). Es posible que debas volver a hacer clic en la plantilla En blanco (Blank) después de guardar la configuración.

  4. En la ventana Agregar una fuente de datos (Add a data source), haz clic en Crear una fuente de datos nueva (Create new data source).

    Agrega fuente de datos

  5. En la sección Conectores de Google (Google Connectors), coloca el cursor sobre BigQuery y, luego, haz clic en Seleccionar (Select).

  6. En Authorization, haz clic en Authorize. Esto permite que Google Data Studio acceda a tu proyecto de Google Cloud.

  7. En el cuadro de diálogo Solicitud de permiso, haz clic en Permitir para que Google Data Studio pueda ver datos en BigQuery. Es posible que no recibas este mensaje si usaste Google Data Studio con anterioridad.

  8. Deja seleccionada la opción Mis proyectos y, en el panel Proyecto, haz clic en el nombre de tu proyecto.

  9. En el panel Conjunto de datos, haz clic en biengine_tutorial.

  10. En el panel Tabla, haz clic en 311_service_requests_copy.

  11. En la esquina superior derecha de la ventana, haz clic en Connect. Una vez que Google Data Studio se conecta a la fuente de datos de BigQuery, se muestran los campos de la tabla. Puedes usar esta página para ajustar las propiedades del campo o crear nuevos campos calculados.

  12. En la esquina superior derecha, haga clic en Añadir al informe.

  13. Cuando se te solicite, haz clic en Add to report.

  14. En el diálogo Solicitud de permiso, haz clic en Permitir para que Data Studio pueda ver y administrar archivos en Google Drive. Es posible que no recibas este mensaje si usaste Google Data Studio con anterioridad.

Crea un gráfico

Una vez que agregaste la fuente de datos al informe, el siguiente paso es crear una visualización. Primero crea un gráfico de barras. El gráfico de barras que creas muestra los reclamos principales por vecindario.

Para crear un gráfico de barras que muestre reclamos por barrio, haz lo siguiente:

  1. De forma opcional, en la parte superior de la página, haz clic en Informe sin título para cambiar el informe. Por ejemplo, escribe BI Engine tutorial.

  2. Después de que se cargue el editor de informes, haz clic en Insertar > Gráfico de barras.

  3. Expande el tamaño del gráfico con los controladores.

  4. En la pestaña Datos, observa que el valor de fuente de datos es 311_service_requests_copy.

  5. Como estás registrando la cantidad de solicitudes por vecindario, debes establecer la Dimensión en category y la Dimensión de desglose en neighborhood. Haz clic en la dimensión predeterminada (es que sea probable status) y, en la lista, elige categoría.

    Cómo elegir la dimensión de categoría

  6. En la lista Campos disponibles, haga clic en vecindario y arrástrelo hasta el cuadro Agregar aquí la dimensión, en Dimensión de desglose.

    Cómo agregar la dimensión del barrio

Agregar un filtro

Debido a que los datos incluyen una cantidad de valores NULL en la columna neighborhood, debes agregar un filtro que excluya los valores NULL del gráfico.

Para agregar un filtro, haz lo siguiente:

  1. En la pestaña Datos, haz clic en Agregar un filtro.

    Agregar una opción de filtro

  2. En el cuadro de diálogo Crear filtro, haz lo siguiente:

    • En Nombre, ingresa Excluir valores nulos.
    • Verifique que la fuente de datos esté configurada en 311_service_requests_copy.
    • Haz clic en Incluir y selecciona Excluir.
    • Haz clic en Seleccionar un campo y elige vecindario.
    • Haz clic en Seleccionar una condición y selecciona Es nulo.

      Filtro completado

    • Haga clic en Save.

  3. Una vez aplicado el filtro, su gráfico debería verse de la siguiente manera.

    Gráfico de barras completado

Limpia

Para evitar que se apliquen cargos a la cuenta de Google Cloud por los recursos que usaste en esta guía de inicio rápido, puedes borrar el proyecto, borrar la reserva de BI Engine o realizar ambas acciones.

Borra el proyecto

La manera más fácil de eliminar la facturación es borrar el proyecto que creaste para el instructivo.

Para borrar el proyecto, sigue estos pasos:

  1. En Cloud Console, ve a la página Administrar recursos.

    Ir a Administrar recursos

  2. En la lista de proyectos, elige el proyecto que quieres borrar y haz clic en Borrar.
  3. En el diálogo, escribe el ID del proyecto y, luego, haz clic en Cerrar para borrar el proyecto.

Borra la reserva

Como alternativa, si deseas conservar el proyecto, puedes evitar los costos adicionales de BI Engine si borras la reserva de capacidad.

Para borrar tu reserva, sigue estos pasos:

  1. En la Consola del administrador de BigQuery, ve a la página BI Engine.

    Ir a la Consola del administrador de BigQuery

  2. En la sección Reservas, busca tu reserva.

  3. En la columna Acciones, haz clic en el ícono a la derecha de tu reserva y selecciona Borrar.

  4. En el cuadro de diálogo Confirmar eliminación de reserva, ingresa QUITAR y, luego, haz clic en Continuar.

¿Qué sigue?