Como configurar o Eclipse para desenvolvimento e depuração do Python com o Google App Engine

Dê os primeiros passos no desenvolvimento e na depuração locais com os plug-ins Eclipse e PyDev. Essa configuração permite executar o aplicativo do App Engine localmente em um modo de depuração e usar a perspectiva de depuração do Eclipse para definir pontos de interrupção e avançar o código. Os plug-ins PyDev oferecem uma funcionalidade auxiliar para trabalhar com o App Engine, incluindo a criação de projetos iniciais e a implantação de aplicativos.

Antes de começar

  1. Se ainda não tiver o Python instalado, instale o Python 2.7. Não tem certeza?
  2. Na seção Opcional da página de download do SDK instale o SDK original do App Engine para Python.

Verifique a versão do Python

Para verificar qual versão do Python você instalou, execute o seguinte comando:

python --version

Como instalar o Eclipse

As instruções a seguir pressupõem que você instalará o Eclipse IDE para JavaScript e desenvolvedores para Web, baseado no Eclipse Neon (4.6). Use o Eclipse Installer para facilitar o processo de instalação.

  1. Instale o Eclipse Installer.
  2. No Eclipse Installer, escolha o pacote Eclipse IDE para JavaScript e desenvolvedores para Web e clique em Instalar.

    Como instalar o Eclipse com o instalador do EclipseCaptura de tela.

  3. Quando a instalação terminar, clique em Iniciar.

  4. Quando o Eclipse for iniciado, especifique um local de espaço de trabalho ou aceite o padrão.

Como instalar o PyDev

Depois de instalar o Eclipse, você precisará instalar o plug-in PyDev, que permite usar o Eclipse como um Python IDE.

  1. No Eclipse, clique em Ajuda > Eclipse Marketplace.
  2. No campo Encontrar, especifique "PyDev".

    Procure o PyDev no mercado do Eclipse e instale-o.Captura de tela.

  3. Clique em Instalar e conclua o assistente de instalação.

  4. Reinicie o Eclipse quando solicitado.

Como configurar o projeto

  1. Crie um novo projeto: clique em Arquivo > Novo > Projeto.

  2. Na página "Selecionar um assistente", selecione Projeto PyDev para Google App Engine.

    Selecione o assistente do projeto do Pydev.Captura de tela.

  3. Na página "Projeto PyDev", nomeie o projeto. Deixe o Eclipse configurar o interpretador padrão clicando em Configure um interpretador antes de continuar.

    Se o Eclipse não encontrou um interpretador do Python 2.7, clique no link Clique aqui para configurar um interpretador não listado para configurar um.

  4. Na página do Google App Engine, clique em Procurar e localize o diretório em que você instalou o SDK do App Engine. Onde ele está?

    Especifique o local do SDK do App Engine ao criar o projeto.Captura de tela.

  5. Clique em Avançar para continuar configurando um projeto básico ou clique em Concluir para começar um projeto em branco.

  6. Se você estiver configurando um projeto, especifique o código dele. Para ver esse código, acesse o Console do GCP. Se ainda não tiver registrado um projeto, especifique um nome temporário que será inserido no arquivo app.yaml do projeto. Altere esse nome depois, se necessário.

  7. Escolha um modelo inicial. Recomendado: use o modelo Hello World para gerar um arquivo app.yaml e um script simples do Python. Desenvolva-o mais tarde usando o framework de sua escolha, como Flask ou Django.

Local padrão do SDK

macOS
Se você tiver instalado o SDK com o acesso rápido do Google App Engine, precisará criar symlinks quando o acesso rápido for inicializado. Se você tiver criado symlinks, o local padrão será:
/usr/local/google_appengine
Se você não tiver criado symlinks, o local padrão será:
/Applications/GoogleAppEngineLauncher.app/Contents/Resources/GoogleAppEngine-default.bundle/Contents/Resources/google_appengine
Linux
O local é onde você extraiu o arquivo zip do SDK salvo.
Windows
C:\Program Files (x86)\Google\google_appengine\

Como importar bibliotecas do Eclipse a serem reconhecidas

Depois de configurar um projeto, você poderá escolher uma biblioteca de base do código. Você precisará importar a biblioteca para o projeto e configurar o projeto a fim de carregar essa biblioteca, mas também precisará orientar o Eclipse a usar essa biblioteca.

Para o Eclipse reconhecer a biblioteca importada:

  1. Importe a biblioteca para o projeto.
  2. Edite as propriedades do projeto do Eclipse: clique com o botão direito do mouse no projeto e selecione Propriedades.
  3. Selecione PyDev - PYTHONPATH no painel de navegação da caixa de diálogo.
  4. Se você gerenciar as bibliotecas em uma pasta filho do projeto, como "lib", clique em Adicionar pasta de origem.

O Eclipse já inclui as bibliotecas especificadas no caminho do Python para resolver importações.

Como iniciar o app no modo de depuração

Executar o app no modo de depuração no Eclipse permite definir pontos de interrupção no código. Quando essas linhas são executadas, o processamento pausa temporariamente, permitindo inspecionar o código e percorrer a execução. Essa funcionalidade é extremamente útil durante o desenvolvimento do app.

Como definir uma configuração de depuração

Na primeira vez em que você iniciar o app no modo de depuração, ele criará uma configuração de depuração que você poderá executar ou modificar depois para adicionar parâmetros referentes à versão.

  1. Clique com o botão direito do mouse no nome do projeto no explorador de projetos e selecione Depurar como > PyDev: execução do Google App.

    A visualização de console precisa ser aberta e exibir a saída do sistema do servidor de desenvolvimento, o que inclui os URLs que o app está executando.

  2. Verifique se o app está em execução visitando o URL mostrado no console. Por padrão, o app é executado em http://localhost:8080. Se você tiver usado o modelo inicial Hello World, verá "Hello, world!" impresso no navegador.

O modo de depuração já está em execução no Eclipse. Você também criou uma configuração de depuração que poderá ser executada novamente mais tarde, se você tiver saído do Eclipse ou precisar parar e reiniciar o depurador.

Como definir um ponto de interrupção para avançar o código

Agora que você já tem o depurador em execução, pode definir pontos de interrupção e usá-los para avançar a execução do código.

  1. Abra um arquivo no projeto do Eclipse, como helloworld.py, se você estiver usando o modelo inicial.

  2. Clique com o botão direito do mouse no número da linha ao lado do código em que você quer definir um ponto de interrupção e selecione Adicionar ponto de interrupção.

    O menu de contexto exibido quando se clica com o botão direito do mouse no número da linha no EclipseCaptura de tela.

    Um círculo verde é exibido na linha onde você definiu o ponto de interrupção.

  3. Retorne ao navegador e abra o URL que executará a linha onde você definiu o ponto de interrupção. O Eclipse solicita que você alterne para a perspectiva de depuração quando o ponto de interrupção é acionado.

  4. Se for solicitado para você alternar para a perspectiva de depuração, clique em Sim. Essa perspectiva apresenta uma visualização específica de depuração do código, incluindo a de variáveis.

    Uma captura de tela completa do Eclipse IDE no modo de depuração com as diversas visualizações de depuração.

    No visualizador de variáveis, inspecione os objetos e as variáveis atualmente definidos no código.

    Os botões da barra de menu incluem os seguintes controles:

    • Ícone para execução contínua Continuar a execução até o próximo ponto de interrupção ser encontrado ou a execução ser concluída.
    • Ícone para execução contínua Passar para o código de nível inferior, como em um método.
    • Ícone para avanço linha por linha Avançar linha por linha no código atual, em vez de passar para o código de nível inferior.
    • Ícone para retorno ao código superior Retornar ao código de nível superior. Se você passar para o código de nível inferior, poderá retornar ao código de nível superior antes do código de nível inferior concluir a execução para retorná-lo ao código de chamada.
    • Ícone para encerramento da execução Encerrar a execução.
    • Ícone para pulo dos pontos de interrupção restantes Ignorar os pontos de interrupção restantes.
  5. Clique no ícone de continuar (ícone para continuação) para prosseguir com o processo e permitir que o servidor de desenvolvimento envie uma resposta simples "Hello, World!" ao navegador.

Para voltar à perspectiva do PyDev depois que você tiver concluído a depuração, escolha Janela > Perspectiva > Abrir perspectiva e selecione Pydev. Se preferir, clique no ícone do PyDev no canto superior direito do Eclipse:

Exibe os ícones para perspectivas de troca rápida no Eclipse

Como implantar o app do Eclipse

O plug-in PyDev para Eclipse permite implantar o app pelo espaço de trabalho.

  1. Use o console do Google Cloud Platform para configurar o projeto do Google Cloud Platform:

    Selecione ou crie um projeto do GCP e verifique se ele inclui um aplicativo do App Engine:

    Acessar o App Engine

    O Painel será aberto se já houver um aplicativo do App Engine no seu projeto. Caso contrário, você precisará escolher a região em que o aplicativo do App Engine ficará localizado.

    Dica: o código do projeto passa a fazer parte do URL do app. Por exemplo, http://[YOUR_PROJECT_ID].appspot.com.

  2. No Eclipse, edite o arquivo app.yaml e altere o valor do elemento application para o código do projeto do GCP.

  3. No Explorador de pacotes do PyDev ou na visualização "Explorador de pacotes", clique com o botão direito do mouse na pasta do projeto e escolha PyDev: Google App Engine > Fazer upload.

    Imagem do menu de contexto durante o clique com o botão direito do mouse no projeto para exibir a opção de upload do PyDev para o App Engine

    Se esta for a primeira vez que você executa os comandos de gerenciamento do SDK do App Engine, será necessário autorizar o SDK a conceder acesso à ferramenta para modificar os aplicativos do App Engine. Clique em Permitir.

    Feche a janela do navegador quando aparecer "O fluxo de autenticação foi concluído" e retorne ao Eclipse.

  4. Confirme se o aplicativo faz upload na caixa de diálogo Gerenciar o Google App Engine:

    Captura de tela da caixa de diálogo confirmando as etapas de upload e o êxito

  5. Navegue até http://[YOUR_PROJECT_ID].appspot.com para ver o aplicativo processando o tráfego.

A seguir

Agora que tem um ambiente de desenvolvimento configurado, os tópicos a seguir podem ajudar você a dar os primeiros passos no App Engine:

Esta página foi útil? Conte sua opinião sobre:

Enviar comentários sobre…

Ambiente padrão do App Engine para Python 2